summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-12-14 16:09:23 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-12-14 16:09:23 +0000
commit404511948b6138a2d9f1e7264b6431d985e775ee (patch)
treebc57961319b15669bb0c5ced1acb6bef529c14d0 /sys-kernel/dracut
parentAdded new drives to hddgentoo.db. Rels bug #492324. (diff)
downloadgentoo-2-404511948b6138a2d9f1e7264b6431d985e775ee.tar.gz
gentoo-2-404511948b6138a2d9f1e7264b6431d985e775ee.tar.bz2
gentoo-2-404511948b6138a2d9f1e7264b6431d985e775ee.zip
Committing on behalf of Alexander Tsoy <alexander@tsoy.me>.
Fixes bug #489624 and bug #491778. usrmount module used to be not always installed when it was needed. (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'sys-kernel/dracut')
-rw-r--r--sys-kernel/dracut/ChangeLog11
-rw-r--r--sys-kernel/dracut/dracut-034-r2.ebuild322
-rw-r--r--sys-kernel/dracut/files/034-0013-usrmount-always-install.patch31
3 files changed, 363 insertions, 1 deletions
diff --git a/sys-kernel/dracut/ChangeLog b/sys-kernel/dracut/ChangeLog
index 6449e1a2e027..3bed5b6dde85 100644
--- a/sys-kernel/dracut/ChangeLog
+++ b/sys-kernel/dracut/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-kernel/dracut
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.141 2013/12/10 19:38:08 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.142 2013/12/14 16:09:23 aidecoe Exp $
+
+*dracut-034-r2 (14 Dec 2013)
+
+ 14 Dec 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> +dracut-034-r2.ebuild,
+ +files/034-0013-usrmount-always-install.patch:
+ Committing on behalf of Alexander Tsoy <alexander@tsoy.me>.
+ Fixes bug #489624 and bug #491778.
+
+ usrmount module used to be not always installed when it was needed.
10 Dec 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> dracut-034-r1.ebuild:
Committing on behalf of Alexander Tsoy <alexander@tsoy.me>.
diff --git a/sys-kernel/dracut/dracut-034-r2.ebuild b/sys-kernel/dracut/dracut-034-r2.ebuild
new file mode 100644
index 000000000000..37658700713d
--- /dev/null
+++ b/sys-kernel/dracut/dracut-034-r2.ebuild
@@ -0,0 +1,322 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/dracut-034-r2.ebuild,v 1.1 2013/12/14 16:09:23 aidecoe Exp $
+
+EAPI=4
+
+inherit bash-completion-r1 eutils linux-info multilib systemd
+
+add_req_use_for() {
+ local dep="$1"; shift
+ local f
+
+ for f in "$@"; do
+ REQUIRED_USE+="${f}? ( ${dep} )
+"
+ done
+}
+
+DESCRIPTION="Generic initramfs generation tool"
+HOMEPAGE="http://dracut.wiki.kernel.org"
+SRC_URI="mirror://kernel/linux/utils/boot/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+REQUIRED_USE="
+ dracut_modules_bootchart? ( !dracut_modules_systemd )
+ dracut_modules_crypt-gpg? ( dracut_modules_crypt )
+ dracut_modules_crypt-loop? ( dracut_modules_crypt )
+ dracut_modules_livenet? ( dracut_modules_dmsquash-live )
+ "
+COMMON_MODULES="
+ dracut_modules_biosdevname
+ dracut_modules_bootchart
+ dracut_modules_btrfs
+ dracut_modules_caps
+ dracut_modules_crypt-gpg
+ dracut_modules_crypt-loop
+ dracut_modules_dash
+ dracut_modules_gensplash
+ dracut_modules_mdraid
+ dracut_modules_multipath
+ dracut_modules_plymouth
+ dracut_modules_syslog
+ dracut_modules_systemd
+ "
+DM_MODULES="
+ dracut_modules_crypt
+ dracut_modules_dmraid
+ dracut_modules_dmsquash-live
+ dracut_modules_livenet
+ dracut_modules_lvm
+ "
+NETWORK_MODULES="
+ dracut_modules_cifs
+ dracut_modules_iscsi
+ dracut_modules_livenet
+ dracut_modules_nbd
+ dracut_modules_nfs
+ dracut_modules_ssh-client
+ "
+add_req_use_for device-mapper ${DM_MODULES}
+add_req_use_for net ${NETWORK_MODULES}
+IUSE_DRACUT_MODULES="${COMMON_MODULES} ${DM_MODULES} ${NETWORK_MODULES}"
+IUSE="debug device-mapper net selinux ${IUSE_DRACUT_MODULES}"
+
+RESTRICT="test"
+
+CDEPEND="virtual/udev
+ dracut_modules_systemd? ( >=sys-apps/systemd-199 )
+ selinux? ( sec-policy/selinux-dracut )
+ "
+RDEPEND="${CDEPEND}
+ app-arch/cpio
+ >=app-shells/bash-4.0
+ >=sys-apps/baselayout-1.12.14-r1
+ >sys-apps/kmod-5[tools]
+ || ( >=sys-apps/sysvinit-2.87-r3 sys-apps/systemd-sysv-utils )
+ >=sys-apps/util-linux-2.21
+ virtual/pkgconfig
+
+ debug? ( dev-util/strace )
+ device-mapper? ( >=sys-fs/lvm2-2.02.33 )
+ net? ( net-misc/curl >=net-misc/dhcp-4.2.4_p2-r1[client] sys-apps/iproute2 )
+ selinux? ( sys-libs/libselinux sys-libs/libsepol )
+ dracut_modules_biosdevname? ( sys-apps/biosdevname )
+ dracut_modules_bootchart? ( app-benchmarks/bootchart2 sys-apps/usleep
+ sys-process/acct )
+ dracut_modules_btrfs? ( sys-fs/btrfs-progs )
+ dracut_modules_caps? ( sys-libs/libcap )
+ dracut_modules_cifs? ( net-fs/cifs-utils )
+ dracut_modules_crypt? ( sys-fs/cryptsetup )
+ dracut_modules_crypt-gpg? ( app-crypt/gnupg )
+ dracut_modules_dash? ( >=app-shells/dash-0.5.4.11 )
+ dracut_modules_dmraid? ( sys-fs/dmraid sys-fs/multipath-tools )
+ dracut_modules_gensplash? ( media-gfx/splashutils )
+ dracut_modules_iscsi? ( >=sys-block/open-iscsi-2.0.871.3 )
+ dracut_modules_lvm? ( >=sys-fs/lvm2-2.02.33 )
+ dracut_modules_mdraid? ( >=sys-fs/mdadm-3.2.6-r1 )
+ dracut_modules_multipath? ( sys-fs/multipath-tools )
+ dracut_modules_nbd? ( sys-block/nbd )
+ dracut_modules_nfs? ( net-fs/nfs-utils net-nds/rpcbind )
+ dracut_modules_plymouth? ( >=sys-boot/plymouth-0.8.3-r1 )
+ dracut_modules_ssh-client? ( dev-libs/openssl )
+ dracut_modules_syslog? ( || ( app-admin/syslog-ng app-admin/rsyslog ) )
+ "
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ >=dev-libs/libxslt-1.1.26
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75.2
+ "
+
+DOCS=( AUTHORS HACKING NEWS README README.generic README.kernel README.modules
+ README.testsuite TODO )
+MY_LIBDIR=/usr/lib
+
+#
+# Helper functions
+#
+
+# Returns true if any of specified modules is enabled by USE flag and false
+# otherwise.
+# $1 = list of modules (which have corresponding USE flags of the same name)
+any_module() {
+ local m modules=" $@ "
+
+ for m in ${modules}; do
+ ! use $m && modules=${modules/ $m / }
+ done
+
+ shopt -s extglob
+ modules=${modules%%+( )}
+ shopt -u extglob
+
+ [[ ${modules} ]]
+}
+
+# Removes module from modules.d.
+# $1 = module name
+# Module name can be specified without number prefix.
+rm_module() {
+ local force m
+ [[ $1 = -f ]] && force=-f
+
+ for m in $@; do
+ if [[ $m =~ ^[0-9][0-9][^\ ]*$ ]]; then
+ rm ${force} --interactive=never -r "${modules_dir}"/$m
+ else
+ rm ${force} --interactive=never -r "${modules_dir}"/[0-9][0-9]$m
+ fi
+ done
+}
+
+#
+# ebuild functions
+#
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-0001-dracut.sh-do-not-bail-out-if-kernel-mo.patch"
+ epatch "${FILESDIR}/${PV}-0002-dracut-functions.sh-support-for-altern.patch"
+ epatch "${FILESDIR}/${PV}-0003-gentoo.conf-let-udevdir-be-handled-by-.patch"
+ epatch "${FILESDIR}/${PV}-0004-Use-the-same-paths-in-dracut.sh-as-tho.patch"
+ epatch "${FILESDIR}/${PV}-0005-Install-dracut-install-into-libexec-di.patch"
+ epatch "${FILESDIR}/${PV}-0006-resume-fix-swap-detection-in-hostonly.patch"
+ epatch "${FILESDIR}/${PV}-0007-dracut.sh-also-mkdir-run-lock-which-is.patch"
+ epatch "${FILESDIR}/${PV}-0008-dracut.sh-no-need-to-make-subdirs-in-r.patch"
+ epatch "${FILESDIR}/${PV}-0009-lvm-install-thin-utils-for-non-hostonl.patch"
+ epatch "${FILESDIR}/${PV}-0010-module-setup.sh-add-comments-for-dracu.patch"
+ epatch "${FILESDIR}/${PV}-0011-lvm-fix-thin-recognition.patch"
+ epatch "${FILESDIR}/${PV}-0012-lvm-always-install-thin-utils-for-lvm.patch"
+ epatch "${FILESDIR}/${PV}-0013-usrmount-always-install.patch"
+
+ local libdirs
+
+ #local ldir
+ #for ldir in $(get_all_libdirs); do
+ # libdirs+=" /$ldir /usr/$ldir"
+ #done
+ #libdirs="${libdirs# }"
+
+ libdirs="/$(get_libdir) /usr/$(get_libdir)"
+ [[ $libdirs =~ /lib\ ]] || libdirs+=" /lib /usr/lib"
+ einfo "Setting libdirs to \"${libdirs}\" ..."
+ sed -e "3alibdirs=\"${libdirs}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+
+ if use dracut_modules_systemd; then
+ local systemdutildir="$(systemd_get_utildir)"
+ local systemdsystemunitdir="$(systemd_get_unitdir)"
+ einfo "Setting systemdutildir to ${systemdutildir} and ..."
+ sed -e "5asystemdutildir=\"${systemdutildir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ einfo "Setting systemdsystemunitdir to ${systemdsystemunitdir}..."
+ sed -e "6asystemdsystemunitdir=\"${systemdsystemunitdir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ fi
+}
+
+src_configure() {
+ local myconf="--libdir=${MY_LIBDIR}"
+ myconf+=" --bashcompletiondir=$(get_bashcompdir)"
+
+ if use dracut_modules_systemd; then
+ myconf+=" --systemdsystemunitdir='$(systemd_get_unitdir)'"
+ fi
+
+ econf ${myconf}
+}
+
+src_compile() {
+ tc-export CC
+ emake doc install/dracut-install
+}
+
+src_install() {
+ default
+
+ local my_libdir="${MY_LIBDIR}"
+ local dracutlibdir="${my_libdir#/}/dracut"
+
+ echo "DRACUT_VERSION=$PVR" > "${D%/}/${dracutlibdir}/dracut-version.sh"
+
+ insinto "${dracutlibdir}/dracut.conf.d/"
+ newins dracut.conf.d/gentoo.conf.example gentoo.conf
+
+ insinto /etc/logrotate.d
+ newins dracut.logrotate dracut
+
+ dodir /var/lib/dracut/overlay
+
+ dohtml dracut.html
+
+ #
+ # Modules
+ #
+ local module
+ modules_dir="${D%/}/${dracutlibdir}/modules.d"
+
+ # Remove modules not enabled by USE flags
+ for module in ${IUSE_DRACUT_MODULES} ; do
+ ! use ${module} && rm_module -f ${module#dracut_modules_}
+ done
+
+ # Those flags are specific, and even are corresponding to modules, they need
+ # to be declared as regular USE flags.
+ use debug || rm_module 95debug
+ use selinux || rm_module 98selinux
+
+ # Following flags define set of helper modules which are base dependencies
+ # for others and as so have no practical use, so remove these modules.
+ use device-mapper || rm_module 90dm
+ use net || rm_module 40network 45ifcfg 45url-lib
+
+ if use dracut_modules_systemd; then
+ # With systemd following modules do not make sense
+ rm_module 96securityfs 98selinux
+ else
+ # Without systemd following modules do not make sense
+ rm_module 00systemd-bootchart
+ fi
+
+ # Remove S/390 modules which are not tested at all
+ rm_module 80cms 95dasd 95dasd_mod 95zfcp 95znet
+
+ # Remove modules which won't work for sure
+ rm_module 95fcoe # no tools
+ # fips module depends on masked app-crypt/hmaccalc
+ rm_module 01fips 02fips-aesni
+
+ # Remove extra modules which go to future dracut-extras
+ rm_module 05busybox 97masterkey 98ecryptfs 98integrity
+}
+
+pkg_postinst() {
+ if linux-info_get_any_version && linux_config_src_exists; then
+ ewarn ""
+ ewarn "If the following test report contains a missing kernel"
+ ewarn "configuration option, you should reconfigure and rebuild your"
+ ewarn "kernel before booting image generated with this Dracut version."
+ ewarn ""
+
+ local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS"
+
+ # Kernel configuration options descriptions:
+ local desc_DEVTMPFS="Maintain a devtmpfs filesystem to mount at /dev"
+ local desc_BLK_DEV_INITRD="Initial RAM filesystem and RAM disk "\
+"(initramfs/initrd) support"
+
+ local opt desc
+
+ # Generate ERROR_* variables for check_extra_config.
+ for opt in ${CONFIG_CHECK}; do
+ opt=${opt#\~}
+ desc=desc_${opt}
+ eval "local ERROR_${opt}='CONFIG_${opt}: \"${!desc}\"" \
+ "is missing and REQUIRED'"
+ done
+
+ check_extra_config
+ echo
+ else
+ ewarn ""
+ ewarn "Your kernel configuration couldn't be checked. Do you have"
+ ewarn "/usr/src/linux/.config file there? Please check manually if"
+ ewarn "following options are enabled:"
+ ewarn ""
+ ewarn " CONFIG_BLK_DEV_INITRD"
+ ewarn " CONFIG_DEVTMPFS"
+ ewarn ""
+ fi
+
+ if use dracut_modules_crypt || use dracut_modules_dmraid || use \
+ dracut_modules_mdraid || use dracut_modules_lvm; then
+
+ if ! [[ $(</proc/cmdline) =~ rd.auto[\ =] ]]; then
+ ewarn "Autoassembly of special devices like cryptoLUKS, dmraid, "
+ ewarn "mdraid or lvm is off for default as of >=dracut-024."
+ ewarn "Use rd.auto option to turn it on."
+ fi
+ fi
+}
diff --git a/sys-kernel/dracut/files/034-0013-usrmount-always-install.patch b/sys-kernel/dracut/files/034-0013-usrmount-always-install.patch
new file mode 100644
index 000000000000..55fd87c1b08c
--- /dev/null
+++ b/sys-kernel/dracut/files/034-0013-usrmount-always-install.patch
@@ -0,0 +1,31 @@
+From ffbe30d1e1e9fb09136bfc2d29a3cc65292b5690 Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Thu, 21 Nov 2013 20:33:38 +0400
+Subject: [PATCH 13/13] usrmount: always install
+
+/usr should be mounted by initramfs even if /sbin/init lives in /
+
+Conflicts:
+ modules.d/98usrmount/module-setup.sh
+---
+ modules.d/98usrmount/module-setup.sh | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/modules.d/98usrmount/module-setup.sh b/modules.d/98usrmount/module-setup.sh
+index 1af789f..31a6229 100755
+--- a/modules.d/98usrmount/module-setup.sh
++++ b/modules.d/98usrmount/module-setup.sh
+@@ -4,10 +4,7 @@
+
+ # called by dracut
+ check() {
+- local _init
+ [[ $mount_needs ]] && return 1
+- _init=$(readlink -f /sbin/init)
+- [[ "$init" == "${init##/usr}" ]] && return 255
+ return 0
+ }
+
+--
+1.8.4.4
+