summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-09-15 10:18:36 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-09-15 10:18:36 +0000
commitf47d8d31b2fc2f45c3f0e7cde1f9ff281c305764 (patch)
tree1729cd69666c00c2f3cad77af538acf9f1f7a5aa /sys-kernel/gentoo-sources
parentStable for amd64, wrt bug #484822 (diff)
downloadgentoo-2-f47d8d31b2fc2f45c3f0e7cde1f9ff281c305764.tar.gz
gentoo-2-f47d8d31b2fc2f45c3f0e7cde1f9ff281c305764.tar.bz2
gentoo-2-f47d8d31b2fc2f45c3f0e7cde1f9ff281c305764.zip
Linux patches 3.0.96, 3.4.62, 3.10.12 and 3.11.1. Applied (and backported for 3.0) a726915cef1daab57aad4c5b5e4773822f0a4bf8 to branches 3.0, 3.2 and 3.4; a commit that fixes i915 panel lid handling bugs that were introduced in 2.6, which was fixed in 3.7 and later.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'sys-kernel/gentoo-sources')
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog15
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.0.96.ebuild29
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.10.12.ebuild29
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.11.1.ebuild29
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.4.62.ebuild29
5 files changed, 130 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index 57dbb6cfd89c..0a3a422b8590 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for sys-kernel/gentoo-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1188 2013/09/11 10:07:21 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1189 2013/09/15 10:18:36 tomwij Exp $
+
+*gentoo-sources-3.4.62 (15 Sep 2013)
+*gentoo-sources-3.11.1 (15 Sep 2013)
+*gentoo-sources-3.10.12 (15 Sep 2013)
+*gentoo-sources-3.0.96 (15 Sep 2013)
+
+ 15 Sep 2013; Tom Wijsman <TomWij@gentoo.org> +gentoo-sources-3.0.96.ebuild,
+ +gentoo-sources-3.10.12.ebuild, +gentoo-sources-3.11.1.ebuild,
+ +gentoo-sources-3.4.62.ebuild:
+ Linux patches 3.0.96, 3.4.62, 3.10.12 and 3.11.1. Applied (and backported for
+ 3.0) a726915cef1daab57aad4c5b5e4773822f0a4bf8 to branches 3.0, 3.2 and 3.4; a
+ commit that fixes i915 panel lid handling bugs that were introduced in 2.6,
+ which was fixed in 3.7 and later.
*gentoo-sources-3.4.61 (11 Sep 2013)
*gentoo-sources-3.2.51 (11 Sep 2013)
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.0.96.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.0.96.ebuild
new file mode 100644
index 000000000000..d64280958e32
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.0.96.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.0.96.ebuild,v 1.1 2013/09/15 10:18:36 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="66"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.10.12.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.10.12.ebuild
new file mode 100644
index 000000000000..37a2c19850f1
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.10.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.10.12.ebuild,v 1.1 2013/09/15 10:18:36 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="19"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.11.1.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.11.1.ebuild
new file mode 100644
index 000000000000..5377b778ee53
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.11.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.11.1.ebuild,v 1.1 2013/09/15 10:18:36 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="4"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.4.62.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.4.62.ebuild
new file mode 100644
index 000000000000..5e2825cc397b
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.4.62.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.4.62.ebuild,v 1.1 2013/09/15 10:18:36 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="43"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}