summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-06-14 19:51:46 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-06-14 19:51:46 +0000
commit4707f28509cd5553db5b077d01ae18b965612959 (patch)
tree688bc25f67e9d329c28e199111cf652b9bb8cffd /sys-kernel/gs-sources
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-4707f28509cd5553db5b077d01ae18b965612959.tar.gz
gentoo-2-4707f28509cd5553db5b077d01ae18b965612959.tar.bz2
gentoo-2-4707f28509cd5553db5b077d01ae18b965612959.zip
Added a patch for the FPU-lockup issue; please see bug #58304 for details.
Diffstat (limited to 'sys-kernel/gs-sources')
-rw-r--r--sys-kernel/gs-sources/ChangeLog9
-rw-r--r--sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r6 (renamed from sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r5)0
-rw-r--r--sys-kernel/gs-sources/files/gs-sources.FPULockup-53804.patch11
-rw-r--r--sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r6.ebuild (renamed from sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r5.ebuild)11
4 files changed, 25 insertions, 6 deletions
diff --git a/sys-kernel/gs-sources/ChangeLog b/sys-kernel/gs-sources/ChangeLog
index f5f0c2cd7d4a..24e2038c282a 100644
--- a/sys-kernel/gs-sources/ChangeLog
+++ b/sys-kernel/gs-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/gs-sources
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.39 2004/05/31 17:22:06 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.40 2004/06/14 19:51:46 plasmaroo Exp $
+
+*gs-sources-2.4.25_pre7-r6 (14 Jun 2004)
+
+ 14 Jun 2004; <plasmaroo@gentoo.org> -gs-sources-2.4.25_pre7-r5.ebuild,
+ +gs-sources-2.4.25_pre7-r6.ebuild, +files/gs-sources.FPULockup-53804.patch:
+ Added a patch for the FPU-lockup issue; please see bug #58304 for details.
+ Old sources removed.
*gs-sources-2.4.25_pre7-r5 (31 May 2004)
diff --git a/sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r5 b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r6
index f55b28665921..f55b28665921 100644
--- a/sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r5
+++ b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre7-r6
diff --git a/sys-kernel/gs-sources/files/gs-sources.FPULockup-53804.patch b/sys-kernel/gs-sources/files/gs-sources.FPULockup-53804.patch
new file mode 100644
index 000000000000..1dd5ed87b520
--- /dev/null
+++ b/sys-kernel/gs-sources/files/gs-sources.FPULockup-53804.patch
@@ -0,0 +1,11 @@
+--- linux-2.4/include/asm-i386/i387.h 2004-06-13 20:06:05.044881328 +0100
++++ linux-2.4/include/asm-i386/i387.h 2004-06-13 20:25:42.836829736 +0100
+@@ -34,7 +34,7 @@
+
+ #define clear_fpu( tsk ) do { \
+ if ( tsk->flags & PF_USEDFPU ) { \
+- asm volatile("fwait"); \
++ asm volatile("fnclex ; fwait"); \
+ tsk->flags &= ~PF_USEDFPU; \
+ stts(); \
+ } \
diff --git a/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r5.ebuild b/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r6.ebuild
index eaaacdaea5fc..ec923f6e43bc 100644
--- a/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r5.ebuild
+++ b/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r5.ebuild,v 1.1 2004/05/31 17:22:06 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/gs-sources-2.4.25_pre7-r6.ebuild,v 1.1 2004/06/14 19:51:46 plasmaroo Exp $
IUSE="build crypt"
@@ -20,8 +20,8 @@ ETYPE="sources"
inherit kernel eutils
PROVIDE="virtual/linux-sources virtual/winkernel"
OKV=2.4.24
-EXTRAVERSION=_pre7-gss-r5
-KV=2.4.25_pre7-gss-r5
+EXTRAVERSION=_pre7-gss-r6
+KV=2.4.25_pre7-gss-r6
S=${WORKDIR}/linux-${KV}
# Documentation on the patches contained in this kernel will be installed
@@ -31,14 +31,14 @@ DESCRIPTION="This kernel stays up to date with current kernel -pres,
with recent acpi,evms,win4lin,futexes,aic79xx,
superfreeswan,preempt, and various hw fixes."
SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
- mirror://gentoo/patches-${KV/r5/r1}.tar.bz2"
+ mirror://gentoo/patches-${KV/r6/r1}.tar.bz2"
KEYWORDS="x86 -ppc -sparc"
SLOT="${KV}"
src_unpack() {
unpack ${A}
mv linux-${OKV} linux-${KV} || die
- cd ${KV/r5/r1} || die
+ cd ${KV/r6/r1} || die
# Kill patches we aren't suppposed to use, don't worry about
# failures, if they aren't there that is a good thing!
# This is the ratified crypt USE flag, enables IPSEC and patch-int
@@ -61,4 +61,5 @@ src_unpack() {
epatch ${FILESDIR}/${PN}.CAN-2004-0181.patch || die "Failed to add the CAN-2004-0181 patch!"
epatch ${FILESDIR}/${PN}.CAN-2004-0394.patch || die "Failed to add the CAN-2004-0394 patch!"
epatch ${FILESDIR}/${PN}.CAN-2004-0427.patch || die "Failed to add the CAN-2004-0427 patch!"
+ epatch ${FILESDIR}/${PN}.FPULockup-53804.patch || die "Failed to apply FPU-lockup patch!"
}