summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-01-15 21:02:57 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-01-15 21:02:57 +0000
commit371784d2d54c1905f5f49a2e5abbd3ad9de92b7d (patch)
tree983d01ad605df71bc7475f40cd7f47d329b2de20 /sys-kernel/hardened-sources/hardened-sources-2.6.36-r9.ebuild
parentBased on vanilla 2.6.32.28 + genpatches-2.6.32-30 + grsecurity-2.2.1-2.6.32.2... (diff)
downloadgentoo-2-371784d2d54c1905f5f49a2e5abbd3ad9de92b7d.tar.gz
gentoo-2-371784d2d54c1905f5f49a2e5abbd3ad9de92b7d.tar.bz2
gentoo-2-371784d2d54c1905f5f49a2e5abbd3ad9de92b7d.zip
Based on vanilla 2.6.36.3 + genpatches-2.6.36-10 + grsecurity-2.2.1-2.6.36.3-201101131705
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-2.6.36-r9.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.36-r9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.36-r9.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.36-r9.ebuild
new file mode 100644
index 000000000000..106aee05e4a3
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.36-r9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.36-r9.ebuild,v 1.1 2011/01/15 21:02:57 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-10"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.1*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}