summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Rickard <frogger@gentoo.org>2003-06-17 03:16:00 +0000
committerMatt Rickard <frogger@gentoo.org>2003-06-17 03:16:00 +0000
commit7b4e824992b7d1acf84c2a1f928aac3155fda3c6 (patch)
tree268c86cb1471373039cb376cdaf731c575e91051 /sys-kernel/hardened-sources
parentNew revision for ioperm bug fix (diff)
downloadgentoo-2-7b4e824992b7d1acf84c2a1f928aac3155fda3c6.tar.gz
gentoo-2-7b4e824992b7d1acf84c2a1f928aac3155fda3c6.tar.bz2
gentoo-2-7b4e824992b7d1acf84c2a1f928aac3155fda3c6.zip
New revision for ioperm bug fix
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog13
-rw-r--r--sys-kernel/hardened-sources/Manifest4
-rw-r--r--sys-kernel/hardened-sources/files/digest-hardened-sources-2.4.20-r42
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.4.20-r4.ebuild70
4 files changed, 86 insertions, 3 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 0c102e54c1bb..2a8bea58b6ea 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.10 2003/06/12 22:13:45 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.11 2003/06/17 03:15:50 frogger Exp $
+
+ 16 Jun 2003; Matthew Rickard <frogger@gentoo.org> :
+ Initial import of hardened-sources-2.4.20-r4. This revision
+ includes only a few changes, but one of these is an important
+ security fix. It is recommended all users of hardened-sources
+ upgrade to this release.
+ - ioperm bug fix
+ - fixed compilation failure when building without GRSec
+ SAL (Secure Auditing for Linux) is NOT included in this revision
+ due to time constraints, but is planned for inclusion in the near
+ future.
*hardened-sources-2.4.20-r2 (12 Jun 2003)
diff --git a/sys-kernel/hardened-sources/Manifest b/sys-kernel/hardened-sources/Manifest
index 2e56d5420b08..e7466fb9ecbe 100644
--- a/sys-kernel/hardened-sources/Manifest
+++ b/sys-kernel/hardened-sources/Manifest
@@ -1,6 +1,6 @@
-MD5 aa215d618b8b3e3a05e78f2a70819e0e hardened-sources-2.4.20-r4.ebuild 2156
+MD5 9620e138e947911421670be21fe8c2be hardened-sources-2.4.20-r4.ebuild 2155
MD5 5d8a9ff40b4b4d8f8ab1e6adb8018dfa hardened-sources-2.4.20-r3.ebuild 2156
-MD5 d477d4c4c0720c254453db6d6b5a15c5 ChangeLog 3371
+MD5 cc39ef8d66c72f73ec517da3e762d22c ChangeLog 3370
MD5 bd4794f3f8e14a2f23fabbc634d12ed3 hardened-sources-2.4.20-r2.ebuild 2238
MD5 e8b051baa93e07c4185474fb0e94e3af files/digest-hardened-sources-2.4.20-r2 147
MD5 58eba2e705c5a3f06366c1da54194deb files/digest-hardened-sources-2.4.20-r3 147
diff --git a/sys-kernel/hardened-sources/files/digest-hardened-sources-2.4.20-r4 b/sys-kernel/hardened-sources/files/digest-hardened-sources-2.4.20-r4
new file mode 100644
index 000000000000..46944ceef544
--- /dev/null
+++ b/sys-kernel/hardened-sources/files/digest-hardened-sources-2.4.20-r4
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 e2cda990f7f433af5bc59bf89794fd5f patches-2.4.20-hardened-r4.tar.bz2 1711757
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.4.20-r4.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.4.20-r4.ebuild
new file mode 100644
index 000000000000..4b97d500695e
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.4.20-r4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.4.20-r4.ebuild,v 1.1 2003/06/17 03:15:51 frogger Exp $
+
+IUSE="build selinux"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV=2.4.20
+EXTRAVERSION=-hardened-r4
+KV=${OKV}${EXTRAVERSION}
+S=${WORKDIR}/linux-${KV}
+DESCRIPTION="Special Security Hardened Gentoo Linux Kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+
+
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/hardened/"
+KEYWORDS="~x86"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2 patches-${KV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # We can't use LSM/SELinux and GRSec in the same kernel. If USE=selinux, we will
+ # patch in LSM/SELinux and drop support for GRsec. Otherwise we will include GRSec.
+ if [ "`use selinux`" ]; then
+ einfo "Enabling SELinux support. This will drop GRSec2 support."
+ for file in *grsec*; do
+ einfo "Dropping ${file}.."
+ rm -f ${file}
+ done
+ else
+ einfo "Did not find \"selinux\" in use, building with GRSec2 support."
+ for file in *lsm* *selinux*; do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ kernel_src_unpack
+}
+
+src_install() {
+ if [ "`use selinux`" ]; then
+ insinto /usr/flask
+ doins ${S}/security/selinux/flask/access_vectors
+ doins ${S}/security/selinux/flask/security_classes
+ doins ${S}/security/selinux/flask/initial_sids
+ insinto /usr/include/linux/flask
+ doins ${S}/security/selinux/include/linux/flask/*.h
+ insinto /usr/include/asm/flask
+ doins ${S}/security/selinux/include/asm/flask/uninstd.h
+ fi
+
+ kernel_src_install
+}
+
+pkg_postinst() {
+ einfo "This kernel contains LSM/SElinux or GRSecurity, and Systrace"
+ einfo "Also included are various other performance and security related patches"
+ einfo "If you experience problems with this kernel please report them by"
+ einfo "assigning bugs on bugs.gentoo.org to frogger@gentoo.org"
+}