summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2011-12-11 18:45:09 +0000
committerMike Pagano <mpagano@gentoo.org>2011-12-11 18:45:09 +0000
commitad1b966aa1751eadd439d8f2555a950a4d151ad5 (patch)
tree589f987a7d3c34c49cf1d055dfae4b5386c28e6b /sys-kernel/linux-docs/linux-docs-3.0.ebuild
parentTake over maintainership, thanks Dane for proxying. (diff)
downloadgentoo-2-ad1b966aa1751eadd439d8f2555a950a4d151ad5.tar.gz
gentoo-2-ad1b966aa1751eadd439d8f2555a950a4d151ad5.tar.bz2
gentoo-2-ad1b966aa1751eadd439d8f2555a950a4d151ad5.zip
Add 3.0 documentation
(Portage version: 2.2.0_alpha80/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/linux-docs/linux-docs-3.0.ebuild')
-rw-r--r--sys-kernel/linux-docs/linux-docs-3.0.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/linux-docs-3.0.ebuild b/sys-kernel/linux-docs/linux-docs-3.0.ebuild
new file mode 100644
index 000000000000..f0a1a83ae217
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-3.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/linux-docs-3.0.ebuild,v 1.1 2011/12/11 18:45:09 mpagano Exp $
+
+inherit toolchain-funcs
+
+MY_P=linux-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="http://www.kernel.org/"
+SRC_URI="mirror://kernel/linux/kernel/v3.x/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE="html"
+DEPEND="app-text/docbook-sgml-utils
+ app-text/xmlto
+ sys-apps/sed
+ ~app-text/docbook-xml-dtd-4.1.2"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e "s:db2:docbook2:g" \
+ -e "s:/usr/local/man:${D}/usr/share/man:g" \
+ "${S}"/Documentation/DocBook/Makefile
+
+ # fix for parallel build as per bug #248337
+ sed -i \
+ -e "s:\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:+\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:" \
+ "${S}"/Makefile
+}
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ emake mandocs || die "make mandocs failed"
+
+ if use html; then
+ emake htmldocs || die "make htmldocs failed"
+ fi
+}
+
+src_install() {
+ local file
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ make installmandocs || die "make installmandocs failed"
+
+ if use html; then
+ for file in Documentation/DocBook/*.html; do
+ dohtml -r ${file/\.html/}
+ done
+ fi
+}