summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-06 16:31:02 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-06 16:31:02 +0000
commite87e4f766bef4358c0f2343bd1fa083b2124f904 (patch)
tree5a08796c40ea8f8bc34efee1fa6bb10de3d22eec /sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild
parentStable on ppc64; bug #132183 (diff)
downloadgentoo-2-e87e4f766bef4358c0f2343bd1fa083b2124f904.tar.gz
gentoo-2-e87e4f766bef4358c0f2343bd1fa083b2124f904.tar.bz2
gentoo-2-e87e4f766bef4358c0f2343bd1fa083b2124f904.zip
Replace malloc.h with stdlib.h when building on FreeBSD libc.
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild
index 497b890d10de..c65db7e4f77e 100644
--- a/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild,v 1.13 2006/04/11 00:26:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild,v 1.14 2006/05/06 16:31:02 flameeyes Exp $
ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arm bfin cris hppa ia64 m68k nios2 ppc ppc64 s390 sh sparc x86"
@@ -54,4 +54,7 @@ src_unpack() {
if use ppc && [[ ${PROFILE_ARCH} == "ppc64" ]]; then
epatch "${FILESDIR}"/2.6.11-ppc64-32ul-spinlock.patch
fi
+
+ # Allow to install in Gentoo/FreeBSD for crosscompile purposes
+ [[ ${CHOST} == *-freebsd* ]] && sed -i -e 's:<malloc.h>:<stdlib.h>:g' ${S}/scripts/genksyms/*
}