summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-11-18 12:32:17 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-11-18 12:32:17 +0000
commitd34886c7aa55d1dbc8da4eac4839e045b2184017 (patch)
tree101bdefd79759cc65b331050ba3fc872c6b45582 /sys-kernel/linux-headers
parentupdated to latest version (diff)
downloadgentoo-2-d34886c7aa55d1dbc8da4eac4839e045b2184017.tar.gz
gentoo-2-d34886c7aa55d1dbc8da4eac4839e045b2184017.tar.bz2
gentoo-2-d34886c7aa55d1dbc8da4eac4839e045b2184017.zip
update 2.4.14 with latest patches; fix so that it dont use perl
Diffstat (limited to 'sys-kernel/linux-headers')
-rw-r--r--sys-kernel/linux-headers/files/2.4.14-loop.c.diff17
-rw-r--r--sys-kernel/linux-headers/files/digest-linux-headers-2.4.14-r27
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.14-r2.ebuild320
3 files changed, 344 insertions, 0 deletions
diff --git a/sys-kernel/linux-headers/files/2.4.14-loop.c.diff b/sys-kernel/linux-headers/files/2.4.14-loop.c.diff
new file mode 100644
index 000000000000..0f8c41bbaef8
--- /dev/null
+++ b/sys-kernel/linux-headers/files/2.4.14-loop.c.diff
@@ -0,0 +1,17 @@
+--- linux.orig/drivers/block/loop.c Fri Nov 9 22:37:23 2001
++++ linux/drivers/block/loop.c Fri Nov 9 22:38:05 2001
+@@ -218,14 +218,12 @@
+ index++;
+ pos += size;
+ UnlockPage(page);
+- deactivate_page(page);
+ page_cache_release(page);
+ }
+ return 0;
+
+ unlock:
+ UnlockPage(page);
+- deactivate_page(page);
+ page_cache_release(page);
+ fail:
+ return -1;
diff --git a/sys-kernel/linux-headers/files/digest-linux-headers-2.4.14-r2 b/sys-kernel/linux-headers/files/digest-linux-headers-2.4.14-r2
new file mode 100644
index 000000000000..534b1fce0a52
--- /dev/null
+++ b/sys-kernel/linux-headers/files/digest-linux-headers-2.4.14-r2
@@ -0,0 +1,7 @@
+MD5 123dce508ca65a066fba7644b306180e 2.4.14-low-latency.patch.gz 12288
+MD5 1201fb14c225d918825bbd98f562ebd2 acpi-20011109.diff.gz 102400
+MD5 29df832104cc0655396e8a9a452bef2a ext3-2.4-0.9.15-2414.gz 143360
+MD5 dc03387783a8f58c90ef7b1ec6af252a linux-2.4.14.tar.bz2 23232512
+MD5 dc1098abb4b2d20d5869f6b0392cb734 lvm-1.0.1-rc4-2.4.14-r2.patch.bz2 32768
+MD5 1aa87a35a1d808534cc78f32af0a1b2d lvm_1.0.1-rc4.tar.gz 364544
+MD5 5b349b78918163fbbebf77a5593ab4b2 preempt-kernel-rml-2.4.14-2.patch 49152
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.14-r2.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.14-r2.ebuild
new file mode 100644
index 000000000000..4685fbb42d4a
--- /dev/null
+++ b/sys-kernel/linux-headers/linux-headers-2.4.14-r2.ebuild
@@ -0,0 +1,320 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.14-r2.ebuild,v 1.1 2001/11/18 12:32:17 azarah Exp $
+
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+OKV=2.4.14
+KV=2.4.14
+S=${WORKDIR}/linux-${KV}
+S2=${WORKDIR}/linux-${KV}-extras
+if [ $PN = "linux-extras" ]
+then
+ KS=${ROOT}usr/src/linux-${KV}
+ KS2=${ROOT}usr/src/linux-${KV}-extras
+else
+ KS=${S}
+ KS2=${S2}
+fi
+
+# Kernel Features Enabled USE Variable Status
+#
+# Reiserfs Y - Production-ready
+# JFS N jfs Testing-only (commented out for now)
+# LVM Y lvm Production-ready
+# ext3 Y ext3 Production-ready
+# MOSIX N mosix Testing only, probably quite stable
+# XFS N xfs will probably need to be placed in a separate kernel
+# PCMCIA-CS N pcmcia Need to move this to its own ebuild
+# lm-sensors N lm_sensors Need to move this to its own ebuild
+
+# Patch Versions
+ACPIV=20011109
+LVMV=1.0.1-rc4
+EXT3V=0.9.15
+LOWLV=2.4.14
+PREEV="${KV}-2"
+
+EXT3P="ext3-2.4-${EXT3V}-`echo ${KV} |sed -e 's:\.::g' -e 's:-::'`"
+
+[ "${PN}" = "linux" ] && DESCRIPTION="Linux kernel version ${KV}, including modules, binary tools, libraries and includes"
+[ "${PN}" = "linux-sources" ] && DESCRIPTION="Linux kernel version ${KV} - full sources"
+[ "${PN}" = "linux-extras" ] && DESCRIPTION="Linux kernel support tools and libraries"
+
+# We use build in /usr/src/linux in case of linux-extras
+# so we need no sources
+[ ! "${PN}" = "linux-extras" ] && SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ftp://ftp.sistina.com/pub/LVM/1.0/lvm_${LVMV}.tar.gz
+ftp://ftp.kernel.org/pub/linux/kernel/people/rml/preempt-kernel/2.4/preempt-kernel-rml-${PREEV}.patch
+http://www.uow.edu.au/~andrewm/linux/${LOWLV}-low-latency.patch.gz
+http://www.zip.com.au/~akpm/${EXT3P}.gz
+http://developer.intel.com/technology/iapc/acpi/downloads/acpi-${ACPIV}.diff.gz"
+
+# Make live easier for creating the LVM patch when packaging
+# The patch will be copied to /tmp/kpatches. Maybe some other
+# stuff can make use of this?
+[ "$MAKEPATCH" != "yes" ] && SRC_URI="${SRC_URI}
+http://www.ibiblio.org/gentoo/distfiles/lvm-${LVMV}-${PVR}.patch.bz2"
+
+[ "$PN" != "linux-extras" ] && PROVIDE="virtual/kernel"
+
+HOMEPAGE="http://www.kernel.org/
+ http://www.namesys.com
+ http://www.sistina.com/lvm/
+ http://developer.intel.com/technology/iapc/acpi/"
+
+DEPEND=">=sys-apps/modutils-2.4.2 sys-devel/perl"
+#these deps are messed up; fix 'em and add ncurses (required my mosix compile, menuconfig)
+if [ $PN = "linux" ]
+then
+# RDEPEND="mosix? ( ~sys-apps/mosix-user-${MOSV} ) >=sys-apps/e2fsprogs-1.22 >=sys-apps/util-linux-2.11f >=sys-apps/reiserfs-utils-3.6.25-r1"
+ RDEPEND=">=sys-apps/e2fsprogs-1.22 >=sys-apps/util-linux-2.11f >=sys-apps/reiserfs-utils-3.6.25-r1"
+elif [ $PN = "linux-sources" ]
+then
+ if [ "`use build`" ]
+ then
+ DEPEND=""
+ RDEPEND=""
+ else
+ #ncurses is required for "make menuconfig"
+ RDEPEND=">=sys-libs/ncurses-5.2"
+ fi
+elif [ $PN = "linux-extras" ]
+then
+ #linux-extras/headers requires a rev of the current kernel sources to be installed
+ RDEPEND="~sys-kernel/linux-sources-${PV}"
+elif [ $PN = "linux-headers" ]
+then
+ DEPEND=""
+ RDEPEND=""
+fi
+
+# this is not pretty...
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${KS}/include"
+
+src_unpack() {
+
+ [ "$PN" = "linux-extras" ] && return
+ mkdir ${S2}
+
+ #unpack kernel and apply reiserfs-related patches
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ cd ${S}
+ if [ "$KV" != "$OKV" ]
+ then
+ echo "Applying ${KV} patch..."
+ bzip2 -dc ${DISTDIR}/patch-${KV}.bz2 | patch -p1 || die
+ fi
+ dodir /usr/src/linux-${KV}-extras
+
+ #specific to 2.4.10; preempt and ext3 patches
+ cd ${S}
+ patch -p1 < ${DISTDIR}/preempt-kernel-rml-${PREEV}.patch
+ cat ${DISTDIR}/${EXT3P}.gz | gzip -dc | patch -p1 || die
+
+ #get LVM sources ready for compile or sitting at /usr/src;
+ #generate the kernel patch, and apply it
+ cd ${S2}
+ unpack lvm_${LVMV}.tar.gz
+
+ #Generate the patch, and cp it to /tmp/kpatches
+ if [ "$MAKEPATCH" = "yes" ] ; then
+ local S_LVM="${S2}/LVM/${LVMV}"
+ cd ${S_LVM}
+ ./configure --with-kernel_dir=${S} || die
+ cd ${S_LVM}/PATCHES
+ mv Makefile Makefile.orig
+ sed -e 's:/usr/src/linux:${S}:' Makefile.orig >Makefile || die
+ make || die
+ mv ${S_LVM}/PATCHES/lvm-${LVMV}-${KV}.patch ${WORKDIR}
+ mv Makefile.orig Makefile
+ cd ${S_LVM}
+ make distclean
+ #the LVM patch is included to replace the old version, irregardless if USE lvm is set
+ cd ${S}
+ patch -l -p1 <${WORKDIR}/lvm-${LVMV}-${KV}.patch || die
+ mkdir /tmp/kpatches
+ bzip2 -c ${WORKDIR}/lvm-${LVMV}-${KV}.patch >/tmp/kpatches/lvm-${LVMV}-${PVR}.patch.bz2
+
+ #normar merge, just patch with patch from gentoo mirror
+ else
+ cd ${S}
+ cat ${DISTDIR}/lvm-${LVMV}-${PVR}.patch.bz2 | bzip2 -dc | patch -l -p1 || die
+ fi
+
+ #apply low-latency patch
+ cd ${S}
+ cat ${DISTDIR}/${LOWLV}-low-latency.patch.gz | gzip -d | patch -p1 || die
+
+ #apply ACPI updates
+ cat ${DISTDIR}/acpi-${ACPIV}.diff.gz | gzip -d | patch -p1 || die
+
+ #fix problem compiling ${S}/drivers/block/loop.c as module
+ patch -p1 <${FILESDIR}/2.4.14-loop.c.diff || die
+
+ echo "Preparing for compilation..."
+ cd ${S}
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #linux-sources needs to be fully configured, too. Not just linux
+ #this is the configuration for the default kernel
+ cp ${PORTDIR}/sys-kernel/linux-sources/files/config.default .config || die
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ #seems they cant make up their mind if it should be a space or tab
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's/#export\tINSTALL_PATH/export\tINSTALL_PATH/' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+
+ if [ "${PN}" = "linux-headers" ]
+ then
+ cd ${KS}
+ make include/linux/autoconf.h include/linux/version.h || die
+ elif [ "${PN}" = "linux-sources" ]
+ then
+ echo
+ else
+ if [ $PN = "linux" ]
+ then
+ cd ${KS}
+ make symlinks || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" bzImage || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" modules || die
+ fi
+ #LVM tools are included in the linux and linux-extras pakcages
+ cd ${KS2}/LVM/${LVMV}
+
+ # This is needed for linux-extras
+ if [ -f "Makefile" ]
+ then
+ make clean || die
+ fi
+ # I had to hack this in so that LVM will look in the current linux
+ # source directory instead of /usr/src/linux for stuff - pete
+ CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ make || die
+ fi
+}
+
+src_install() {
+
+ if [ "${PN}" = "linux" ] || [ "${PN}" = "linux-extras" ]
+ then
+ dodir /usr/lib
+
+ cd ${KS2}/LVM/${LVMV}/tools
+ CFLAGS="${CFLAGS} -I${KS}/include" make install -e prefix=${D} mandir=${D}/usr/share/man sbindir=${D}/sbin libdir=${D}/lib || die
+ #no need for a static library in /lib
+ mv ${D}/lib/*.a ${D}/usr/lib
+
+ if [ "${PN}" = "linux" ]
+ then
+ dodir /usr/src/linux-${KV}
+ cd ${D}/usr/src
+ #grab includes and documentation only
+ echo ">>> Copying includes and documentation..."
+ cp -ax ${S}/include ${D}/usr/src/linux-${KV}
+ cp -ax ${S}/Documentation ${D}/usr/src/linux-${KV}
+
+ #grab compiled kernel
+ dodir /boot/boot
+ insinto /boot/boot
+ cd ${S}
+ doins arch/i386/boot/bzImage
+
+ #grab modules
+ # Do we have a bug in modutils ?
+ # Meanwhile we use this quick fix (achim)
+
+ install -d ${D}/lib/modules/`uname -r`
+ make INSTALL_MOD_PATH=${D} modules_install || die
+
+ cd ${S}
+ depmod -b ${D} -F ${S}/System.map ${KV}
+ #rm -rf ${D}/lib/modules/`uname -r`
+ #fix symlink
+ cd ${D}/lib/modules/${KV}
+ rm build
+ ln -sf /usr/src/linux-${KV} build
+ fi
+
+ cd ${KS2}/cloop-${CLOOPV}
+ insinto /lib/modules/${KV}/kernel/drivers/block
+ doins cloop.o
+ into /usr
+ dobin create_compressed_fs extract_compressed_fs
+
+ elif [ "$PN" = "linux-sources" ]
+ then
+ dodir /usr/src
+ cd ${S}
+ echo ">>> Copying sources..."
+ cp -ax ${WORKDIR}/* ${D}/usr/src
+ elif [ "$PN" = "linux-headers" ]
+ then
+ dodir /usr/include/linux
+ cp -ax ${KS}/include/linux/* ${D}/usr/include/linux
+ dodir /usr/include/asm
+ cp -ax ${KS}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+ if [ -d ${D}/usr/src/linux-${KV} ]
+ then
+ #don't overwrite existing .config if present
+ cd ${D}/usr/src/linux-${KV}
+ if [ -e .config ]
+ then
+ cp -a .config .config.eg
+ fi
+ fi
+}
+
+pkg_preinst() {
+
+ if [ "$PN" = "linux-headers" ]
+ then
+ if [ -L ${ROOT}usr/include/linux ]
+ then
+ rm ${ROOT}usr/include/linux
+ fi
+ if [ -L ${ROOT}usr/include/asm ]
+ then
+ rm ${ROOT}usr/include/asm
+ fi
+ fi
+}
+
+pkg_postinst() {
+
+ if [ "$PN" = "linux-extras" ] || [ "$PN" = "linux-headers" ]
+ then
+ return
+ fi
+ rm -f ${ROOT}/usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+
+ #copy over our .config if one isn't already present
+ cd ${ROOT}/usr/src/linux-${KV}
+ if [ "${PN}" = "linux-sources" ] && [ -e .config.eg ] && [ ! -e .config ]
+ then
+ cp -a .config.eg .config
+ fi
+}