summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-09-03 05:32:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-09-03 05:32:03 +0000
commitf6b50929fee3c2b11fe0db8e536e6649afc9be43 (patch)
tree6edd9d135a4c0bc9696aa01fc266ba44a612687f /sys-kernel/mips-sources
parentStable for HPPA (bug #185747). (diff)
downloadgentoo-2-f6b50929fee3c2b11fe0db8e536e6649afc9be43.tar.gz
gentoo-2-f6b50929fee3c2b11fe0db8e536e6649afc9be43.tar.bz2
gentoo-2-f6b50929fee3c2b11fe0db8e536e6649afc9be43.zip
whitespace
(Portage version: 2.1.2.12)
Diffstat (limited to 'sys-kernel/mips-sources')
-rw-r--r--sys-kernel/mips-sources/mips-sources-2.6.20.18.ebuild44
-rw-r--r--sys-kernel/mips-sources/mips-sources-2.6.22.6.ebuild44
2 files changed, 2 insertions, 86 deletions
diff --git a/sys-kernel/mips-sources/mips-sources-2.6.20.18.ebuild b/sys-kernel/mips-sources/mips-sources-2.6.20.18.ebuild
index 3ba8a2171eb0..68e3ff538934 100644
--- a/sys-kernel/mips-sources/mips-sources-2.6.20.18.ebuild
+++ b/sys-kernel/mips-sources/mips-sources-2.6.20.18.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.20.18.ebuild,v 1.1 2007/09/03 02:12:39 kumba Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.20.18.ebuild,v 1.2 2007/09/03 05:32:03 mr_bones_ Exp $
# INCLUDED:
# 1) linux sources from kernel.org
@@ -13,11 +12,8 @@
# 7) Patch for Remaining Cobalt Bits (http://www.colonel-panic.org/cobalt-mips/)
# 8) Experimental patches (IP27 hacks, et al)
-
#//------------------------------------------------------------------------------
-
-
# Version Data
OKV=${PV/_/-}
GITDATE="20070902" # Date of diff between kernel.org and lmo GIT
@@ -44,7 +40,6 @@ KEYWORDS="-* mips"
IUSE="cobalt ip27 ip28 ip30 ip32r10k"
DEPEND=">=sys-devel/gcc-4.1.1"
-
# Version Control Variables
USE_RC="no" # If set to "yes", then attempt to use an RC kernel
USE_PNT="yes" # If set to "yes", then attempt to use a point-release (2.6.x.y)
@@ -65,7 +60,6 @@ SV_IP30="" # DO_IP30 == "no", IP30
SV_IP32="" # DO_IP32 == "no", IP32
SV_CBLT="" # DO_CBLT == "no", Cobalt
-
# If USE_RC == "yes", use a release candidate kernel (2.6.X-rcY)
if [ "${USE_RC}" = "yes" ]; then
KVXY="$(get_version_component_range 1-2)" # Kernel Major/Minor
@@ -89,19 +83,14 @@ if [ "${USE_PNT}" = "yes" ]; then
USE_RC="no"
fi
-
DESCRIPTION="Linux-Mips GIT sources for MIPS-based machines, dated ${GITDATE}"
SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${STABLEVER}.tar.bz2
mirror://gentoo/mipsgit-${F_KV}-${GITDATE}.diff.bz2
mirror://gentoo/${PN}-generic_patches-${GENPATCHVER}.tar.bz2
${PATCHVER}"
-
-
#//------------------------------------------------------------------------------
-
-
# Error/Warning messages
err_only_one_mach_allowed() {
echo -e ""
@@ -148,12 +137,8 @@ err_disabled_mach() {
return 0
}
-
-
#//------------------------------------------------------------------------------
-
-
# Machine Information Messages
#
# If needing to whitespace for formatting in 'einfo', 'ewarn', or 'eerror', use
@@ -279,12 +264,8 @@ show_cobalt_info() {
echo -e ""
}
-
-
#//------------------------------------------------------------------------------
-
-
# Check our USE flags for machine-specific flags and give appropriate warnings/errors.
# Hope the user isn't crazy enough to try using combinations of these flags.
# Only use one machine-specific flag at a time for each type of desired machine-support.
@@ -356,12 +337,8 @@ pkg_setup() {
fi
}
-
-
#//------------------------------------------------------------------------------
-
-
# Generic Patches - Safe to use globally
do_generic_patches() {
echo -e ""
@@ -387,7 +364,6 @@ do_generic_patches() {
eend
}
-
# NOT safe for production systems
# Use at own risk, do _not_ file bugs on effects of these patches
do_sekrit_patches() {
@@ -406,12 +382,8 @@ do_sekrit_patches() {
# /* EXPERIMENTAL - DO NOT USE IN PRODUCTION KERNELS */
}
-
-
#//------------------------------------------------------------------------------
-
-
# Exclusive Machine Patchsets
# SGI Origin (IP27)
@@ -431,7 +403,6 @@ do_ip28_support() {
epatch ${MIPS_PATCHES}/misc-2.6.20-ip28-i2_impact-support-r2.patch
}
-
# SGI Octane 'Speedracer' (IP30)
do_ip30_support() {
echo -e ""
@@ -440,12 +411,8 @@ do_ip30_support() {
epatch ${MIPS_PATCHES}/misc-2.6.20-ip30-octane-support-r28.patch
}
-
-
#//------------------------------------------------------------------------------
-
-
# Renames source trees for the few machines that we have separate patches for
rename_source_tree() {
if [ ! -z "${1}" ]; then
@@ -456,12 +423,8 @@ rename_source_tree() {
fi
}
-
-
#//------------------------------------------------------------------------------
-
-
src_unpack() {
local x
@@ -469,7 +432,6 @@ src_unpack() {
mv ${WORKDIR}/linux-${STABLEVER} ${WORKDIR}/linux-${OKV}-${GITDATE}
cd ${S}
-
# If USE_RC == "yes", use a release candidate kernel (2.6.x-rcy)
# OR
# if USE_PNT == "yes", use a point-release kernel (2.6.x.y)
@@ -479,7 +441,6 @@ src_unpack() {
epatch ${WORKDIR}/patch-${OKV}
fi
-
# Update the vanilla sources with linux-mips GIT changes
echo -e ""
einfo ">>> linux-${OKV} --> linux-${OKV}-${GITDATE} patch ..."
@@ -496,12 +457,10 @@ src_unpack() {
# Patches for experimental use
do_sekrit_patches
-
# All done, resume normal portage work
kernel_universal_unpack
}
-
src_install() {
# Rename the source trees for exclusive machines
local x
@@ -525,5 +484,4 @@ pkg_postinst() {
fi
}
-
#//------------------------------------------------------------------------------
diff --git a/sys-kernel/mips-sources/mips-sources-2.6.22.6.ebuild b/sys-kernel/mips-sources/mips-sources-2.6.22.6.ebuild
index 18672f3d46f4..0796638b193d 100644
--- a/sys-kernel/mips-sources/mips-sources-2.6.22.6.ebuild
+++ b/sys-kernel/mips-sources/mips-sources-2.6.22.6.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.22.6.ebuild,v 1.1 2007/09/03 02:12:39 kumba Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.22.6.ebuild,v 1.2 2007/09/03 05:32:03 mr_bones_ Exp $
# INCLUDED:
# 1) linux sources from kernel.org
@@ -13,11 +12,8 @@
# 7) Patch for Remaining Cobalt Bits (http://www.colonel-panic.org/cobalt-mips/)
# 8) Experimental patches (IP27 hacks, et al)
-
#//------------------------------------------------------------------------------
-
-
# Version Data
OKV=${PV/_/-}
GITDATE="20070902" # Date of diff between kernel.org and lmo GIT
@@ -44,7 +40,6 @@ KEYWORDS="-* ~mips"
IUSE="cobalt ip27 ip28 ip30 ip32r10k"
DEPEND=">=sys-devel/gcc-4.1.1"
-
# Version Control Variables
USE_RC="no" # If set to "yes", then attempt to use an RC kernel
USE_PNT="yes" # If set to "yes", then attempt to use a point-release (2.6.x.y)
@@ -65,7 +60,6 @@ SV_IP30="" # DO_IP30 == "no", IP30
SV_IP32="" # DO_IP32 == "no", IP32
SV_CBLT="" # DO_CBLT == "no", Cobalt
-
# If USE_RC == "yes", use a release candidate kernel (2.6.X-rcY)
if [ "${USE_RC}" = "yes" ]; then
KVXY="$(get_version_component_range 1-2)" # Kernel Major/Minor
@@ -89,19 +83,14 @@ if [ "${USE_PNT}" = "yes" ]; then
USE_RC="no"
fi
-
DESCRIPTION="Linux-Mips GIT sources for MIPS-based machines, dated ${GITDATE}"
SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${STABLEVER}.tar.bz2
mirror://gentoo/mipsgit-${F_KV}-${GITDATE}.diff.bz2
mirror://gentoo/${PN}-generic_patches-${GENPATCHVER}.tar.bz2
${PATCHVER}"
-
-
#//------------------------------------------------------------------------------
-
-
# Error/Warning messages
err_only_one_mach_allowed() {
echo -e ""
@@ -148,12 +137,8 @@ err_disabled_mach() {
return 0
}
-
-
#//------------------------------------------------------------------------------
-
-
# Machine Information Messages
#
# If needing to whitespace for formatting in 'einfo', 'ewarn', or 'eerror', use
@@ -279,12 +264,8 @@ show_cobalt_info() {
echo -e ""
}
-
-
#//------------------------------------------------------------------------------
-
-
# Check our USE flags for machine-specific flags and give appropriate warnings/errors.
# Hope the user isn't crazy enough to try using combinations of these flags.
# Only use one machine-specific flag at a time for each type of desired machine-support.
@@ -356,12 +337,8 @@ pkg_setup() {
fi
}
-
-
#//------------------------------------------------------------------------------
-
-
# Generic Patches - Safe to use globally
do_generic_patches() {
echo -e ""
@@ -384,7 +361,6 @@ do_generic_patches() {
eend
}
-
# NOT safe for production systems
# Use at own risk, do _not_ file bugs on effects of these patches
do_sekrit_patches() {
@@ -403,12 +379,8 @@ do_sekrit_patches() {
# /* EXPERIMENTAL - DO NOT USE IN PRODUCTION KERNELS */
}
-
-
#//------------------------------------------------------------------------------
-
-
# Exclusive Machine Patchsets
# SGI Origin (IP27)
@@ -429,7 +401,6 @@ do_ip28_support() {
epatch ${MIPS_PATCHES}/misc-2.6.20-ip28-i2_impact-support-r2.patch
}
-
# SGI Octane 'Speedracer' (IP30)
do_ip30_support() {
echo -e ""
@@ -439,12 +410,8 @@ do_ip30_support() {
epatch ${MIPS_PATCHES}/misc-2.6.22-ioc3-revert_commit_691cd0c.patch
}
-
-
#//------------------------------------------------------------------------------
-
-
# Renames source trees for the few machines that we have separate patches for
rename_source_tree() {
if [ ! -z "${1}" ]; then
@@ -455,12 +422,8 @@ rename_source_tree() {
fi
}
-
-
#//------------------------------------------------------------------------------
-
-
src_unpack() {
local x
@@ -468,7 +431,6 @@ src_unpack() {
mv ${WORKDIR}/linux-${STABLEVER} ${WORKDIR}/linux-${OKV}-${GITDATE}
cd ${S}
-
# If USE_RC == "yes", use a release candidate kernel (2.6.x-rcy)
# OR
# if USE_PNT == "yes", use a point-release kernel (2.6.x.y)
@@ -478,7 +440,6 @@ src_unpack() {
epatch ${WORKDIR}/patch-${OKV}
fi
-
# Update the vanilla sources with linux-mips GIT changes
echo -e ""
einfo ">>> linux-${OKV} --> linux-${OKV}-${GITDATE} patch ..."
@@ -495,12 +456,10 @@ src_unpack() {
# Patches for experimental use
do_sekrit_patches
-
# All done, resume normal portage work
kernel_universal_unpack
}
-
src_install() {
# Rename the source trees for exclusive machines
local x
@@ -524,5 +483,4 @@ pkg_postinst() {
fi
}
-
#//------------------------------------------------------------------------------