summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-04-15 09:33:17 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-04-15 09:33:17 +0000
commit5650b55b27447233727da92f90f068f539dfe377 (patch)
tree2978eecd9d2798e23540037041c0d3a5eb070448 /sys-kernel/pac-sources
parentNew version and fixed ebuild (Manifest recommit) (diff)
downloadgentoo-2-5650b55b27447233727da92f90f068f539dfe377.tar.gz
gentoo-2-5650b55b27447233727da92f90f068f539dfe377.tar.bz2
gentoo-2-5650b55b27447233727da92f90f068f539dfe377.zip
Version bump for the CAN-2004-0109 issue; bug #47881.
Diffstat (limited to 'sys-kernel/pac-sources')
-rw-r--r--sys-kernel/pac-sources/ChangeLog8
-rw-r--r--sys-kernel/pac-sources/files/digest-pac-sources-2.4.23-r4 (renamed from sys-kernel/pac-sources/files/digest-pac-sources-2.4.23-r3)0
-rw-r--r--sys-kernel/pac-sources/files/pac-sources.CAN-2004-0109.patch87
-rw-r--r--sys-kernel/pac-sources/pac-sources-2.4.23-r4.ebuild (renamed from sys-kernel/pac-sources/pac-sources-2.4.23-r3.ebuild)5
4 files changed, 96 insertions, 4 deletions
diff --git a/sys-kernel/pac-sources/ChangeLog b/sys-kernel/pac-sources/ChangeLog
index 3744375b1c89..23adbe7a8190 100644
--- a/sys-kernel/pac-sources/ChangeLog
+++ b/sys-kernel/pac-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/pac-sources
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pac-sources/ChangeLog,v 1.4 2004/04/12 16:36:22 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pac-sources/ChangeLog,v 1.5 2004/04/15 09:33:16 plasmaroo Exp $
+
+*pac-sources-2.4.23-r4 (15 Apr 2004)
+
+ 15 Apr 2004; <plasmaroo@gentoo.org> pac-sources-2.4.23-r3.ebuild,
+ pac-sources-2.4.23-r4.ebuild, files/pac-sources.CAN-2004-0109.patch:
+ Version bump for the CAN-2004-0109 issue; bug #47881.
12 Apr 2004; Daniel Ahlberg <aliz@gentoo.org> pac-sources-2.4.23-r3.ebuild:
Add eutils to inherit.
diff --git a/sys-kernel/pac-sources/files/digest-pac-sources-2.4.23-r3 b/sys-kernel/pac-sources/files/digest-pac-sources-2.4.23-r4
index 75e05aae1086..75e05aae1086 100644
--- a/sys-kernel/pac-sources/files/digest-pac-sources-2.4.23-r3
+++ b/sys-kernel/pac-sources/files/digest-pac-sources-2.4.23-r4
diff --git a/sys-kernel/pac-sources/files/pac-sources.CAN-2004-0109.patch b/sys-kernel/pac-sources/files/pac-sources.CAN-2004-0109.patch
new file mode 100644
index 000000000000..d02b51c57fc6
--- /dev/null
+++ b/sys-kernel/pac-sources/files/pac-sources.CAN-2004-0109.patch
@@ -0,0 +1,87 @@
+--- linux/fs/isofs/rock.c.orig
++++ linux/fs/isofs/rock.c
+@@ -14,6 +14,7 @@
+ #include <linux/slab.h>
+ #include <linux/pagemap.h>
+ #include <linux/smp_lock.h>
++#include <asm/page.h>
+
+ #include "rock.h"
+
+@@ -419,7 +420,7 @@
+ return 0;
+ }
+
+-static char *get_symlink_chunk(char *rpnt, struct rock_ridge *rr)
++static char *get_symlink_chunk(char *rpnt, struct rock_ridge *rr, char *plimit)
+ {
+ int slen;
+ int rootflag;
+@@ -431,16 +432,25 @@
+ rootflag = 0;
+ switch (slp->flags & ~1) {
+ case 0:
++ if (slp->len > plimit - rpnt)
++ return NULL;
+ memcpy(rpnt, slp->text, slp->len);
+ rpnt+=slp->len;
+ break;
++ case 2:
++ if (rpnt >= plimit)
++ return NULL;
++ *rpnt++='.';
++ break;
+ case 4:
++ if (2 > plimit - rpnt)
++ return NULL;
+ *rpnt++='.';
+- /* fallthru */
+- case 2:
+ *rpnt++='.';
+ break;
+ case 8:
++ if (rpnt >= plimit)
++ return NULL;
+ rootflag = 1;
+ *rpnt++='/';
+ break;
+@@ -457,17 +467,23 @@
+ * If there is another SL record, and this component
+ * record isn't continued, then add a slash.
+ */
+- if ((!rootflag) && (rr->u.SL.flags & 1) && !(oldslp->flags & 1))
++ if ((!rootflag) && (rr->u.SL.flags & 1) &&
++ !(oldslp->flags & 1)) {
++ if (rpnt >= plimit)
++ return NULL;
+ *rpnt++='/';
++ }
+ break;
+ }
+
+ /*
+ * If this component record isn't continued, then append a '/'.
+ */
+- if (!rootflag && !(oldslp->flags & 1))
++ if (!rootflag && !(oldslp->flags & 1)) {
++ if (rpnt >= plimit)
++ return NULL;
+ *rpnt++='/';
+-
++ }
+ }
+ return rpnt;
+ }
+@@ -548,7 +564,10 @@
+ CHECK_SP(goto out);
+ break;
+ case SIG('S', 'L'):
+- rpnt = get_symlink_chunk(rpnt, rr);
++ rpnt = get_symlink_chunk(rpnt, rr,
++ link + (PAGE_SIZE - 1));
++ if (rpnt == NULL)
++ goto out;
+ break;
+ case SIG('C', 'E'):
+ /* This tells is if there is a continuation record */
+
diff --git a/sys-kernel/pac-sources/pac-sources-2.4.23-r3.ebuild b/sys-kernel/pac-sources/pac-sources-2.4.23-r4.ebuild
index efc373f029f0..17e36f70c763 100644
--- a/sys-kernel/pac-sources/pac-sources-2.4.23-r3.ebuild
+++ b/sys-kernel/pac-sources/pac-sources-2.4.23-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pac-sources/pac-sources-2.4.23-r3.ebuild,v 1.2 2004/04/12 16:36:22 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pac-sources/pac-sources-2.4.23-r4.ebuild,v 1.1 2004/04/15 09:33:16 plasmaroo Exp $
IUSE="build"
@@ -26,7 +26,6 @@ PRERC="`echo ${PV}|grep \_`"
# Other working variables
S=${WORKDIR}/linux-${KV}
EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
-BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
# If it's a last-stable+pre/rc+aa (marcelo), we need to handle it differently
# ourkernel is the stable kernel we'll be working with (previous or current)
@@ -47,7 +46,6 @@ KEYWORDS="~x86"
SLOT="${KV}"
src_unpack() {
- sleep 1
unpack linux-${OURKERNEL}.tar.bz2
mv linux-${OURKERNEL} linux-${KV} || die
@@ -60,6 +58,7 @@ src_unpack() {
bzcat ${DISTDIR}/patch-${KV}.bz2|patch -p1 || die "-pac patch failed"
epatch ${FILESDIR}/${PN}.CAN-2003-0985.patch || die "Failed to patch mremap() vulnerability!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0109.patch || die "Failed to patch CAN-2004-0109 vulnerability!"
epatch ${FILESDIR}/${PN}.munmap.patch || die "Failed to apply munmap patch!"
epatch ${FILESDIR}/${PN}.rtc_fix.patch || die "Failed to patch RTC vulnerabilities!"