summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-12-23 14:44:33 +0000
committerAlex Alexander <wired@gentoo.org>2011-12-23 14:44:33 +0000
commit10551f00493c4f2563f4f024c023c0d0e3ca9fb2 (patch)
treee929a2389991c9b205b3e8431b716710a665178b /sys-kernel/pf-sources
parentVersion bump (diff)
downloadgentoo-2-10551f00493c4f2563f4f024c023c0d0e3ca9fb2.tar.gz
gentoo-2-10551f00493c4f2563f4f024c023c0d0e3ca9fb2.tar.bz2
gentoo-2-10551f00493c4f2563f4f024c023c0d0e3ca9fb2.zip
version bump
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/ChangeLog7
-rw-r--r--sys-kernel/pf-sources/pf-sources-3.1.6.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index 8b307b0f97bd..9ddfcc6d8714 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/pf-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.43 2011/12/10 18:16:38 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.44 2011/12/23 14:44:33 wired Exp $
+
+*pf-sources-3.1.6 (23 Dec 2011)
+
+ 23 Dec 2011; Alex Alexander <wired@gentoo.org> +pf-sources-3.1.6.ebuild:
+ version bump
*pf-sources-3.1.5 (10 Dec 2011)
diff --git a/sys-kernel/pf-sources/pf-sources-3.1.6.ebuild b/sys-kernel/pf-sources/pf-sources-3.1.6.ebuild
new file mode 100644
index 000000000000..4ebf828a2bc0
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-3.1.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-3.1.6.ebuild,v 1.1 2011/12/23 14:44:33 wired Exp $
+
+EAPI="2"
+
+inherit versionator
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="$(get_version_component_range 1-2)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and LinuxIMQ"
+HOMEPAGE="http://pf.natalenko.name/"
+
+PF_FILE="patch-${PV}-pf${COMPRESSTYPE}"
+PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
+EXPERIMENTAL_PATCHES=(
+ # http://ck-hack.blogspot.com/2010/11/create-task-groups-by-tty-comment.html
+ # http://ck.kolivas.org/patches/bfs/bfs357-penalise_fork_depth_account_threads.patch
+)
+EXPERIMENTAL_URI="
+ experimental? (
+ ${EXPERIMENTAL_PATCHES[@]}
+ )
+"
+SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="" # experimental
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+ #if use experimental; then
+ #for patch in ${EXPERIMENTAL_PATCHES[@]}; do
+ #epatch "${DISTDIR}"/"${patch/*\/}"
+ #done
+ #fi
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."