summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJay Pfeifer <pfeifer@gentoo.org>2003-03-19 06:42:49 +0000
committerJay Pfeifer <pfeifer@gentoo.org>2003-03-19 06:42:49 +0000
commit00a7b5ffbe8520ebf82b2b961d016128982ba5ba (patch)
treeae71789c0ef70956eac94add1e40715234cbef52 /sys-kernel/pfeifer-sources
parentbump (diff)
downloadgentoo-2-00a7b5ffbe8520ebf82b2b961d016128982ba5ba.tar.gz
gentoo-2-00a7b5ffbe8520ebf82b2b961d016128982ba5ba.tar.bz2
gentoo-2-00a7b5ffbe8520ebf82b2b961d016128982ba5ba.zip
Used portage move facility to migrate lolo-sources users to pfeifer-sources.
Diffstat (limited to 'sys-kernel/pfeifer-sources')
-rw-r--r--sys-kernel/pfeifer-sources/ChangeLog40
-rw-r--r--sys-kernel/pfeifer-sources/files/digest-pfeifer-sources-2.4.20.1_pre12
-rw-r--r--sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre1.ebuild82
3 files changed, 124 insertions, 0 deletions
diff --git a/sys-kernel/pfeifer-sources/ChangeLog b/sys-kernel/pfeifer-sources/ChangeLog
new file mode 100644
index 000000000000..e376ba16d8d8
--- /dev/null
+++ b/sys-kernel/pfeifer-sources/ChangeLog
@@ -0,0 +1,40 @@
+# ChangeLog for sys-kernel/lolo-sources
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pfeifer-sources/ChangeLog,v 1.1 2003/03/19 06:42:49 pfeifer Exp $
+
+ TODO:
+ * Keep grabbing hardware stuff from xfs-sources
+ * Update iptables a few more times (just for good measure)
+ * Updated chipset support (including new ide-core)
+ * Update SuperFreeS/WAN
+ * Maybe:
+ RSBAC
+ Win4Lin
+ Optional RMAP
+ skas
+ Re-add XFS
+ ht support
+ new O(1) sched stuff from linus & mingo
+
+*pfeifer-sources-2.4.20.1_pre1 (19 Mar 2003)
+
+ 19 Mar 2003; Jay Pfeifer <pfeifer@gentoo.org> pfeifer-sources-2.4.20.1_pre1.ebuild:
+
+ First release of pfeifer-sources, please test and provide productive feedback.
+ This is based off of the lolo-sources 2.4.20.2_pre5 that I put out on 13 Mar 2003
+ This release contains the ptrace fix.
+ See info below for what was in pre5
+
+*lolo-sources-2.4.20.2_pre5 (13 Mar 2003)
+
+ 13 Mar 2002; Jay Pfeifer <pfeifer@gentoo.org> lolo-sources-2.4.20.2_pre5.ebuild:
+ Changes from _pre4:
+ * Process priorities are now obeyed. :)
+ * pom updated to 20030310
+ * removed aavm
+ * removed ck4 O(1) sched, ll, preempt patch
+ * added rml preempt & ll
+ * update xattr+acl to xattr+acl+trusted 0.8.55
+ * update usbdnet
+ * add dac960 root fix
+ * add sim710 compile fix
diff --git a/sys-kernel/pfeifer-sources/files/digest-pfeifer-sources-2.4.20.1_pre1 b/sys-kernel/pfeifer-sources/files/digest-pfeifer-sources-2.4.20.1_pre1
new file mode 100644
index 000000000000..a8e16ff8810c
--- /dev/null
+++ b/sys-kernel/pfeifer-sources/files/digest-pfeifer-sources-2.4.20.1_pre1
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 7b86ef301a47fd2d7f6337d8ef399096 patches-2.4.20-pfeifer-r1_pre1.tar.bz2 2520695
diff --git a/sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre1.ebuild b/sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre1.ebuild
new file mode 100644
index 000000000000..1d12022a7e35
--- /dev/null
+++ b/sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pfeifer-sources/pfeifer-sources-2.4.20.1_pre1.ebuild,v 1.1 2003/03/19 06:42:49 pfeifer Exp $
+
+IUSE="build crypt xfs"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.20"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the experimental Gentoo Kernel. Patches from here may move into sys-kernel/gentoo-sources"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+HOMEPAGE="http://www.gentoo.org/ http://www.kernel.org/"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc -alpha -hppa -mips -arm"
+SLOT="${KV}"
+DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3.x"
+ einfo "Enabling gcc>31 processor optimizations."
+ einfo "To use, choose the processor family labelled with (gcc>31) in"
+ einfo "Processor type and features -> Processor Family"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC & USAGI
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 6* 7* 8* ;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ einfo "Please be warned, you have just installed a untested"
+ einfo "patchset of the Gentoo Linux kernel sources."
+ einfo "This set contains the ptrace patch."
+ einfo "If there are issues with it, please report them"
+ einfo "by assigning bugs on bugs.gentoo.org to"
+ einfo "x86-kernel@gentoo.org"
+}