summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStratos Psomadakis <psomas@gentoo.org>2015-07-08 13:14:57 +0000
committerStratos Psomadakis <psomas@gentoo.org>2015-07-08 13:14:57 +0000
commit00b50f036a84b1990607b9fc4942faf758cf6214 (patch)
tree1806bbb5d7abee68deef7a7190409028048d3eec /sys-kernel/rt-sources
parentVersion bump. Fix licensing issues (bug #552372). (diff)
downloadgentoo-2-00b50f036a84b1990607b9fc4942faf758cf6214.tar.gz
gentoo-2-00b50f036a84b1990607b9fc4942faf758cf6214.tar.bz2
gentoo-2-00b50f036a84b1990607b9fc4942faf758cf6214.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key BC35D737)
Diffstat (limited to 'sys-kernel/rt-sources')
-rw-r--r--sys-kernel/rt-sources/ChangeLog12
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.14.46_p46.ebuild (renamed from sys-kernel/rt-sources/rt-sources-3.14.36_p34.ebuild)2
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.18.17_p14.ebuild46
-rw-r--r--sys-kernel/rt-sources/rt-sources-4.0.5_p4.ebuild (renamed from sys-kernel/rt-sources/rt-sources-3.18.11_p7.ebuild)2
4 files changed, 59 insertions, 3 deletions
diff --git a/sys-kernel/rt-sources/ChangeLog b/sys-kernel/rt-sources/ChangeLog
index 8552f4040814..9a89411a8dd7 100644
--- a/sys-kernel/rt-sources/ChangeLog
+++ b/sys-kernel/rt-sources/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-kernel/rt-sources
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.32 2015/04/15 10:15:55 psomas Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.33 2015/07/08 13:14:57 psomas Exp $
+
+*rt-sources-4.0.5_p4 (08 Jul 2015)
+*rt-sources-3.18.17_p14 (08 Jul 2015)
+*rt-sources-3.14.46_p46 (08 Jul 2015)
+
+ 08 Jul 2015; Stratos Psomadakis <psomas@gentoo.org>
+ -rt-sources-3.14.36_p34.ebuild, +rt-sources-3.14.46_p46.ebuild,
+ -rt-sources-3.18.11_p7.ebuild, +rt-sources-3.18.17_p14.ebuild,
+ +rt-sources-4.0.5_p4.ebuild:
+ Version bump
15 Apr 2015; Stratos Psomadakis <psomas@gentoo.org>
-rt-sources-3.10.6_p3.ebuild, -rt-sources-3.12.31_p45.ebuild,
diff --git a/sys-kernel/rt-sources/rt-sources-3.14.36_p34.ebuild b/sys-kernel/rt-sources/rt-sources-3.14.46_p46.ebuild
index f801627c01bb..bacdcd271aa4 100644
--- a/sys-kernel/rt-sources/rt-sources-3.14.36_p34.ebuild
+++ b/sys-kernel/rt-sources/rt-sources-3.14.46_p46.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/rt-sources-3.14.36_p34.ebuild,v 1.1 2015/04/15 10:11:36 psomas Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/rt-sources-3.14.46_p46.ebuild,v 1.1 2015/07/08 13:14:57 psomas Exp $
EAPI="5"
ETYPE="sources"
diff --git a/sys-kernel/rt-sources/rt-sources-3.18.17_p14.ebuild b/sys-kernel/rt-sources/rt-sources-3.18.17_p14.ebuild
new file mode 100644
index 000000000000..4d9b168e64df
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-3.18.17_p14.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/rt-sources-3.18.17_p14.ebuild,v 1.1 2015/07/08 13:14:57 psomas Exp $
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit versionator
+
+CKV="$(get_version_component_range 1-3)"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst(){
+
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."
diff --git a/sys-kernel/rt-sources/rt-sources-3.18.11_p7.ebuild b/sys-kernel/rt-sources/rt-sources-4.0.5_p4.ebuild
index 105243667654..0198eb5d68b7 100644
--- a/sys-kernel/rt-sources/rt-sources-3.18.11_p7.ebuild
+++ b/sys-kernel/rt-sources/rt-sources-4.0.5_p4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/rt-sources-3.18.11_p7.ebuild,v 1.1 2015/04/15 10:11:36 psomas Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/rt-sources-4.0.5_p4.ebuild,v 1.1 2015/07/08 13:14:57 psomas Exp $
EAPI="5"
ETYPE="sources"