summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2004-12-03 02:11:12 +0000
committerChristian Birchinger <joker@gentoo.org>2004-12-03 02:11:12 +0000
commit91a2dbe437fc3dcbec6d0259129ea4addb7a2fe8 (patch)
treee0ed13b6c080c93af2ea1dbf25889d72cbb98134 /sys-kernel/sparc-sources
parentAdded to ~sparc. (Manifest recommit) (diff)
downloadgentoo-2-91a2dbe437fc3dcbec6d0259129ea4addb7a2fe8.tar.gz
gentoo-2-91a2dbe437fc3dcbec6d0259129ea4addb7a2fe8.tar.bz2
gentoo-2-91a2dbe437fc3dcbec6d0259129ea4addb7a2fe8.zip
Security fix for CAN-2004-1074 (Bug #72452). Added a sparc64 smbfs fix.
Diffstat (limited to 'sys-kernel/sparc-sources')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog6
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r12
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.28-r1.ebuild63
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 0c7dcaa758e8..2da9e91ecfee 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.69 2004/11/27 15:34:58 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.70 2004/12/03 02:11:12 joker Exp $
+
+ 02 Dec 2004; Christian Birchinger <joker@gentoo.org> :
+ Security fix for CAN-2004-1074 (Bug #72452).
+ Added a sparc64 smbfs fix.
27 Nov 2004; Christian Birchinger <joker@gentoo.org>
-files/gentoo-sources-2.4.27-binfmt_elf.patch,
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r1 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r1
new file mode 100644
index 000000000000..8eca5b3cc081
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r1
@@ -0,0 +1,2 @@
+MD5 ac7735000d185bc7778c08288760a8a3 linux-2.4.28.tar.bz2 31064046
+MD5 1f3b29948122dc9dff19fde8d3631419 patches-2.4.28-sparc-r1.tar.bz2 178778
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.28-r1.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.28-r1.ebuild
new file mode 100644
index 000000000000..e1b82c3bc0dd
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.28-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.28-r1.ebuild,v 1.1 2004/12/03 02:11:12 joker Exp $
+
+IUSE="ultra1"
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="grsecurity" would not patch any patches whose names match
+# *grsecurity*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+inherit kernel eutils
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+[ "$OKV" == "" ] && OKV="${PV}"
+
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+PATCH_VERSION="${KV}"
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${PATCH_VERSION}.tar.bz2"
+
+S=${WORKDIR}/linux-${KV}
+KEYWORDS="~x86 -ppc sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+ cd ${PATCH_VERSION} || die "Unable to cd into ${PATCH_VERSION}"
+
+ kernel_src_unpack
+
+ # Patch the HME driver only on Ultra1 machines.
+ use ultra1 && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+}