summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-11-20 16:23:20 +0000
committerPacho Ramos <pacho@gentoo.org>2011-11-20 16:23:20 +0000
commit31535f129727de3cd2f3b8795236be52955ab6a2 (patch)
tree3e95d68540325abf2bdae88d0a144642d29587e5 /sys-kernel/tuxonice-sources
parentVersion bump, remove old. (diff)
downloadgentoo-2-31535f129727de3cd2f3b8795236be52955ab6a2.tar.gz
gentoo-2-31535f129727de3cd2f3b8795236be52955ab6a2.tar.bz2
gentoo-2-31535f129727de3cd2f3b8795236be52955ab6a2.zip
Version bump.
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/tuxonice-sources')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog7
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-3.0.9.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index 0a29f0ceffd6..358d433e2d85 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.125 2011/11/10 17:25:08 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.126 2011/11/20 16:23:20 pacho Exp $
+
+*tuxonice-sources-3.0.9 (20 Nov 2011)
+
+ 20 Nov 2011; Pacho Ramos <pacho@gentoo.org> +tuxonice-sources-3.0.9.ebuild:
+ Version bump.
10 Nov 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
tuxonice-sources-2.6.38-r1.ebuild:
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.9.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.9.ebuild
new file mode 100644
index 000000000000..b9174ffc7bb6
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.9.ebuild,v 1.1 2011/11/20 16:23:20 pacho Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT="20111012"
+TUXONICE_VERSION=""
+TUXONICE_TARGET="3.0"
+
+# Because "current" patches can change without notifying, we need to supply them
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="http://dev.gentoo.org/~pacho/tuxonice/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch"
+ UNIPATCH_LIST="${DISTDIR}/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch.bz2"
+else
+ TUXONICE_SRC="http://www.tuxonice.net/files/tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+ UNIPATCH_LIST="${DISTDIR}/tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch.bz2"
+fi
+
+TUXONICE_URI="${TUXONICE_SRC}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}