summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-11-28 11:57:52 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-11-28 11:57:52 +0000
commitc433ced1f6ec8662d44e77eea8a7cf7c02f81625 (patch)
tree3ea40a01bebc964a015d2547649971fb9d7cb6d1 /sys-kernel/uclinux-sources
parentAdding fixed 2.6 AF_UNIX security patch for 2.6 branch; bug #72688. (Manifest... (diff)
downloadgentoo-2-c433ced1f6ec8662d44e77eea8a7cf7c02f81625.tar.gz
gentoo-2-c433ced1f6ec8662d44e77eea8a7cf7c02f81625.tar.bz2
gentoo-2-c433ced1f6ec8662d44e77eea8a7cf7c02f81625.zip
Adding fixed 2.6 AF_UNIX security patch for 2.6 branch; bug #72688.
Diffstat (limited to 'sys-kernel/uclinux-sources')
-rw-r--r--sys-kernel/uclinux-sources/ChangeLog6
-rw-r--r--sys-kernel/uclinux-sources/files/uclinux-sources-2.6.AF_UNIX.patch24
-rw-r--r--sys-kernel/uclinux-sources/uclinux-sources-2.6.7_p0-r10.ebuild4
3 files changed, 31 insertions, 3 deletions
diff --git a/sys-kernel/uclinux-sources/ChangeLog b/sys-kernel/uclinux-sources/ChangeLog
index 509ba29bb66c..03914ad9c75f 100644
--- a/sys-kernel/uclinux-sources/ChangeLog
+++ b/sys-kernel/uclinux-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/uclinux-sources
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/uclinux-sources/ChangeLog,v 1.23 2004/11/27 18:25:13 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/uclinux-sources/ChangeLog,v 1.24 2004/11/28 11:56:06 plasmaroo Exp $
+
+ 28 Nov 2004; <plasmaroo@gentoo.org> uclinux-sources-2.6.7_p0-r10.ebuild,
+ +files/uclinux-sources-2.6.AF_UNIX.patch:
+ Adding fixed 2.6 AF_UNIX security patch for 2.6 branch; bug #72688.
*uclinux-sources-2.6.7_p0-r10 (27 Nov 2004)
diff --git a/sys-kernel/uclinux-sources/files/uclinux-sources-2.6.AF_UNIX.patch b/sys-kernel/uclinux-sources/files/uclinux-sources-2.6.AF_UNIX.patch
new file mode 100644
index 000000000000..a95e94fd9362
--- /dev/null
+++ b/sys-kernel/uclinux-sources/files/uclinux-sources-2.6.AF_UNIX.patch
@@ -0,0 +1,24 @@
+--- linux-2.6.9/net/unix/af_unix.c 2004-11-24 08:23:21 -08:00
++++ linux-2.6.9.plasmaroo/net/unix/af_unix.c 2004-11-24 08:23:21 -08:00
+@@ -1535,9 +1535,11 @@
+
+ msg->msg_namelen = 0;
+
++ down(&u->readsem);
++
+ skb = skb_recv_datagram(sk, flags, noblock, &err);
+ if (!skb)
+- goto out;
++ goto out_unlock;
+
+ wake_up_interruptible(&u->peer_wait);
+
+@@ -1587,6 +1589,8 @@
+
+ out_free:
+ skb_free_datagram(sk,skb);
++out_unlock:
++ up(&u->readsem);
+ out:
+ return err;
+ }
diff --git a/sys-kernel/uclinux-sources/uclinux-sources-2.6.7_p0-r10.ebuild b/sys-kernel/uclinux-sources/uclinux-sources-2.6.7_p0-r10.ebuild
index b8530ac0160c..1e79e9b2bcb6 100644
--- a/sys-kernel/uclinux-sources/uclinux-sources-2.6.7_p0-r10.ebuild
+++ b/sys-kernel/uclinux-sources/uclinux-sources-2.6.7_p0-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/uclinux-sources/uclinux-sources-2.6.7_p0-r10.ebuild,v 1.1 2004/11/27 18:25:13 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/uclinux-sources/uclinux-sources-2.6.7_p0-r10.ebuild,v 1.2 2004/11/28 11:56:06 plasmaroo Exp $
IUSE=""
@@ -52,7 +52,7 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-2.6.devPtmx.patch || die "Failed to apply /dev/ptmx patch!"
epatch ${FILESDIR}/${PN}-2.6.binfmt_elf.patch || die "Failed to apply binfmt_elf patch!"
epatch ${FILESDIR}/${PN}-2.6.smbfs.patch || die "Failed to apply SMBFS patch!"
- epatch ${FILESDIR}/${PN}.AF_UNIX.patch || die "Failed to apply the AF_UNIX patch!"
+ epatch ${FILESDIR}/${PN}-2.6.AF_UNIX.patch || die "Failed to apply the AF_UNIX patch!"
epatch ${FILESDIR}/${PN}-2.6.binfmt_a.out.patch || die "Failed to apply the a.out patch!"
set MY_ARCH=${ARCH}