summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-03-05 21:23:37 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-03-05 21:23:37 +0000
commit2f8a3ef2a1e66f51b6807fa6355d9f10911e1da4 (patch)
tree4a1ccbb3a3e6cb257e5a6c0521a88d855679f59f /sys-kernel/usermode-sources
parentcommitting new version (now unmasked), removing all old ones. fixed all known... (diff)
downloadgentoo-2-2f8a3ef2a1e66f51b6807fa6355d9f10911e1da4.tar.gz
gentoo-2-2f8a3ef2a1e66f51b6807fa6355d9f10911e1da4.tar.bz2
gentoo-2-2f8a3ef2a1e66f51b6807fa6355d9f10911e1da4.zip
Was dev-util/usermode-kernel; now here.
Diffstat (limited to 'sys-kernel/usermode-sources')
-rw-r--r--sys-kernel/usermode-sources/ChangeLog10
-rw-r--r--sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.18-r12
-rw-r--r--sys-kernel/usermode-sources/usermode-sources-2.4.18-r1.ebuild61
3 files changed, 73 insertions, 0 deletions
diff --git a/sys-kernel/usermode-sources/ChangeLog b/sys-kernel/usermode-sources/ChangeLog
new file mode 100644
index 000000000000..7412b7600eb0
--- /dev/null
+++ b/sys-kernel/usermode-sources/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/ChangeLog,v 1.1 2002/03/05 21:23:37 g2boojum Exp $
+
+*usermode-kernel-2.4.18 (4 March 2002)
+
+ 4 March 2002; Grant Goodyear <g2boojum@gentoo.org> :
+
+ Initial ebuild.
+
diff --git a/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.18-r1 b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.18-r1
new file mode 100644
index 000000000000..32e99373d31a
--- /dev/null
+++ b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.18-r1
@@ -0,0 +1,2 @@
+MD5 ad92859baaa837847b34d842b9f39d38 linux-2.4.18.tar.bz2 24161675
+MD5 b55ead34476cefa8825b2c2660516e9c uml-patch-2.4.18-2.bz2 114495
diff --git a/sys-kernel/usermode-sources/usermode-sources-2.4.18-r1.ebuild b/sys-kernel/usermode-sources/usermode-sources-2.4.18-r1.ebuild
new file mode 100644
index 000000000000..c241b7788e2f
--- /dev/null
+++ b/sys-kernel/usermode-sources/usermode-sources-2.4.18-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/usermode-sources-2.4.18-r1.ebuild,v 1.1 2002/03/05 21:23:37 g2boojum Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+UML_PATCH="uml-patch-${PV}-2"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# User mode linux patch
+# http://user-mode-linux.sourceforge.net
+# UML clashes with the current Gentoo patch, so I've ignored it for now.
+
+DESCRIPTION="Full (vanilla) sources for the User Mode Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://uml-pub.ists.dartmouth.edu/uml/${UML_PATCH}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://user-mode-linux.sourceforge.net"
+
+#console-tools is needed to solve the loadkeys fiasco.
+#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-devel/perl"
+RDEPEND=">=sys-libs/ncurses-5.2"
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/${UML_PATCH}.bz2 | patch -d ${S} -p1
+ echo "Preparing for compilation..."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ echo "Nothing to compile. That's up to the user"
+}
+
+src_install() {
+ dodir /usr/src/uml
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src/uml
+ cd ${D}/usr/src/uml
+ ln -sf linux-${KV} linux
+}
+
+