summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Johnson <livewire@gentoo.org>2003-03-29 22:01:07 +0000
committerBob Johnson <livewire@gentoo.org>2003-03-29 22:01:07 +0000
commit1df670eb8487a63eefce631b91dd68c98721b391 (patch)
tree5a0132cd2cabdca54b885b2d947e15850bc27a8f /sys-kernel
parentVersion bump. (diff)
downloadgentoo-2-1df670eb8487a63eefce631b91dd68c98721b391.tar.gz
gentoo-2-1df670eb8487a63eefce631b91dd68c98721b391.tar.bz2
gentoo-2-1df670eb8487a63eefce631b91dd68c98721b391.zip
new version
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/gs-sources/ChangeLog10
-rw-r--r--sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre62
-rw-r--r--sys-kernel/gs-sources/gs-sources-2.4.21_pre6.ebuild55
3 files changed, 66 insertions, 1 deletions
diff --git a/sys-kernel/gs-sources/ChangeLog b/sys-kernel/gs-sources/ChangeLog
index 8668285504ae..17f5f19d8247 100644
--- a/sys-kernel/gs-sources/ChangeLog
+++ b/sys-kernel/gs-sources/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/gs-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.8 2003/03/19 03:27:11 livewire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.9 2003/03/29 22:01:07 livewire Exp $
+
+*gs-sources-2.4.21_pre6 (29 March 2003)
+
+ 29 March 2003: Bob Johnso <livewire@gentoo.org>
+
+ - updated to 2.4.21_pre6
+ - updated acpi to acpi-20030328-2.4.21-pre6
+ - updated aic79xx-linux-2.4-20030318
*gs-sources-2.4.21_pre5-r1 (18 March 2003)
diff --git a/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre6 b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre6
new file mode 100644
index 000000000000..eab8b0533ddb
--- /dev/null
+++ b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre6
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 7fffa1c894d77ab77bb66c8a4feb4383 patches-2.4.21_pre6-gss.tar.bz2 5173938
diff --git a/sys-kernel/gs-sources/gs-sources-2.4.21_pre6.ebuild b/sys-kernel/gs-sources/gs-sources-2.4.21_pre6.ebuild
new file mode 100644
index 000000000000..8574c4f7e387
--- /dev/null
+++ b/sys-kernel/gs-sources/gs-sources-2.4.21_pre6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/gs-sources-2.4.21_pre6.ebuild,v 1.1 2003/03/29 22:01:07 livewire Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV=2.4.20
+EXTRAVERSION=_pre6-gss
+KV=2.4.21_pre6-gss
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="This kernel stays up to date with current kernel pres, with recent acpi,evms
+win3lin ,futexes,aic79xx,superfreeswan,preempt/ll, and various hw fixes."
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+}