summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-01-30 23:54:03 +0000
committerMichael Januszewski <spock@gentoo.org>2004-01-30 23:54:03 +0000
commit3b916c316bd31b9f2d984cc1f865a3acc9fd3e40 (patch)
treeb3fdf4f0b1284f1176005163d21c7d7108c477b9 /sys-kernel
parentUpdated ebuild for 2.6.1-r1. (Manifest recommit) (diff)
downloadgentoo-2-3b916c316bd31b9f2d984cc1f865a3acc9fd3e40.tar.gz
gentoo-2-3b916c316bd31b9f2d984cc1f865a3acc9fd3e40.tar.bz2
gentoo-2-3b916c316bd31b9f2d984cc1f865a3acc9fd3e40.zip
Version bump.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/vanilla-prepatch-sources/ChangeLog8
-rw-r--r--sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.25_pre82
-rw-r--r--sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.25_pre8.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/sys-kernel/vanilla-prepatch-sources/ChangeLog b/sys-kernel/vanilla-prepatch-sources/ChangeLog
index b1274a7c8739..c253c5ed95cc 100644
--- a/sys-kernel/vanilla-prepatch-sources/ChangeLog
+++ b/sys-kernel/vanilla-prepatch-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/vanilla-prepatch-sources
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/ChangeLog,v 1.24 2004/01/26 11:12:45 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/ChangeLog,v 1.25 2004/01/30 23:54:03 spock Exp $
+
+*vanilla-prepatch-sources-2.4.25_pre8 (31 Jan 2004)
+
+ 31 Jan 2004; Michal Januszewski <spock@gentoo.org>
+ vanilla-prepatch-sources-2.4.25_pre8.ebuild:
+ Version bump.
*vanilla-prepatch-sources-2.4.25_pre7 (26 Jan 2004)
diff --git a/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.25_pre8 b/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.25_pre8
new file mode 100644
index 000000000000..1945a6bf4a04
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.25_pre8
@@ -0,0 +1,2 @@
+MD5 1e055c42921b2396a559d84df4c3d9aa linux-2.4.24.tar.bz2 29837818
+MD5 1cc7ebb245a2ce12fb1de519837473fe patch-2.4.25-pre8.bz2 1848890
diff --git a/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.25_pre8.ebuild b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.25_pre8.ebuild
new file mode 100644
index 000000000000..2ef57d16e472
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.25_pre8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.25_pre8.ebuild,v 1.1 2004/01/30 23:54:03 spock Exp $
+
+IUSE="build"
+
+ETYPE="sources"
+inherit kernel
+
+# OKV=original kernel version, KV=patched kernel version.
+
+OKV=2.4.24
+KV="${PV/_/-}"
+S=${WORKDIR}/linux-${KV}
+
+EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+DESCRIPTION="Full sources for the prerelease vanilla Linux kernel"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://kernel/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+SLOT="${KV}"
+
+# We'll see how not mirroring kernels goes over with the mirrors
+restrict="nomirror"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+ bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "Failed to apply patch!"
+
+ kernel_universal_unpack
+}
+
+pkg_postinst() {
+ einfo "Prepatches are the equivalent to alpha releases for Linux."
+ einfo "They may be poorly tested, and may not work at all."
+ einfo "Prepatches with -rc in the name are release candidates and"
+ einfo "may become full versions. It is particularly important"
+ einfo "that these are thoroughly tested and bugs are reported back"
+ einfo "upstream (and not to the Gentoo team)."
+}