summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-15 07:38:04 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-15 07:38:04 +0000
commit60295362cde2da686a73a1de1b2ed723df05211b (patch)
treeb4bfce41254ba60177a174f22b7af72fb6b8150e /sys-kernel
parentVersion bump. (diff)
downloadgentoo-2-60295362cde2da686a73a1de1b2ed723df05211b.tar.gz
gentoo-2-60295362cde2da686a73a1de1b2ed723df05211b.tar.bz2
gentoo-2-60295362cde2da686a73a1de1b2ed723df05211b.zip
sys-kernel/aufs-sources: Bump to latest aufs3, linux and genpatches release
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/aufs-sources/ChangeLog9
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.10.19.ebuild71
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.11.8.ebuild71
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.12.0.ebuild4
4 files changed, 152 insertions, 3 deletions
diff --git a/sys-kernel/aufs-sources/ChangeLog b/sys-kernel/aufs-sources/ChangeLog
index 721b76a729c9..6436bbda33bc 100644
--- a/sys-kernel/aufs-sources/ChangeLog
+++ b/sys-kernel/aufs-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/aufs-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.71 2013/11/10 09:52:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.72 2013/11/15 07:38:04 jlec Exp $
+
+*aufs-sources-3.11.8 (15 Nov 2013)
+*aufs-sources-3.10.19 (15 Nov 2013)
+
+ 15 Nov 2013; Justin Lecher <jlec@gentoo.org> +aufs-sources-3.10.19.ebuild,
+ +aufs-sources-3.11.8.ebuild, aufs-sources-3.12.0.ebuild:
+ Bump to latest aufs3, linux and genpatches release
10 Nov 2013; Justin Lecher <jlec@gentoo.org> aufs-sources-3.10.18.ebuild,
aufs-sources-3.11.7.ebuild:
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.10.19.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.10.19.ebuild
new file mode 100644
index 000000000000..0b1de5493d11
--- /dev/null
+++ b/sys-kernel/aufs-sources/aufs-sources-3.10.19.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.10.19.ebuild,v 1.1 2013/11/15 07:38:04 jlec Exp $
+
+EAPI=5
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="27"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+AUFS_VERSION=3.10_p20131111
+AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
+# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs3-standalone aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
+AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
+
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
+IUSE="deblob experimental module vanilla"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${AUFS_URI}
+ !vanilla? ( ${GENPATCHES_URI} )
+ "
+
+PDEPEND=">=sys-fs/aufs-util-3.9"
+
+src_unpack() {
+ if use vanilla; then
+ unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
+ ewarn "You are using USE=vanilla"
+ ewarn "This will drop all support from the gentoo kernel security team"
+ fi
+
+ UNIPATCH_LIST="
+ "${WORKDIR}"/aufs3-kbuild.patch
+ "${WORKDIR}"/aufs3-base.patch
+ "${WORKDIR}"/aufs3-mmap.patch"
+
+ use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"
+
+ unpack ${AUFS_TARBALL}
+
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ if ! use module; then
+ sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ cp -f "${WORKDIR}"/include/uapi/linux/aufs_type.h include/uapi/linux/aufs_type.h || die
+ cp -rf "${WORKDIR}"/{Documentation,fs} . || die
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+ has_version sys-fs/aufs-util && \
+ einfo "In order to use aufs FS you need to install sys-fs/aufs-util"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.11.8.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.11.8.ebuild
new file mode 100644
index 000000000000..58c554d4f8d4
--- /dev/null
+++ b/sys-kernel/aufs-sources/aufs-sources-3.11.8.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.11.8.ebuild,v 1.1 2013/11/15 07:38:04 jlec Exp $
+
+EAPI=5
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="12"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+AUFS_VERSION=3.11_p20131111
+AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
+# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs3-standalone aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
+AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
+
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
+IUSE="deblob experimental module vanilla"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${AUFS_URI}
+ !vanilla? ( ${GENPATCHES_URI} )
+ "
+
+PDEPEND=">=sys-fs/aufs-util-3.9"
+
+src_unpack() {
+ if use vanilla; then
+ unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
+ ewarn "You are using USE=vanilla"
+ ewarn "This will drop all support from the gentoo kernel security team"
+ fi
+
+ UNIPATCH_LIST="
+ "${WORKDIR}"/aufs3-kbuild.patch
+ "${WORKDIR}"/aufs3-base.patch
+ "${WORKDIR}"/aufs3-mmap.patch"
+
+ use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"
+
+ unpack ${AUFS_TARBALL}
+
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ if ! use module; then
+ sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ cp -f "${WORKDIR}"/include/uapi/linux/aufs_type.h include/uapi/linux/aufs_type.h || die
+ cp -rf "${WORKDIR}"/{Documentation,fs} . || die
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+ has_version sys-fs/aufs-util && \
+ einfo "In order to use aufs FS you need to install sys-fs/aufs-util"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.12.0.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.12.0.ebuild
index e977cf1de43c..55d0cc725fca 100644
--- a/sys-kernel/aufs-sources/aufs-sources-3.12.0.ebuild
+++ b/sys-kernel/aufs-sources/aufs-sources-3.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.12.0.ebuild,v 1.2 2013/11/05 18:36:01 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.12.0.ebuild,v 1.3 2013/11/15 07:38:04 jlec Exp $
EAPI=5
@@ -12,7 +12,7 @@ inherit kernel-2 eutils
detect_version
detect_arch
-AUFS_VERSION=3.12_p20131104
+AUFS_VERSION=3.12_p20131111
AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs3-standalone aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"