summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-02-27 17:40:06 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-02-27 17:40:06 +0000
commit6a0f0c6c6a5b159cc2976e419697a487f417109d (patch)
tree822aa72daf9cb2cc912b3423a6a4ff5c6d457aec /sys-kernel
parentremoved qtmt use flag, see thread on -core for more information (diff)
downloadgentoo-2-6a0f0c6c6a5b159cc2976e419697a487f417109d.tar.gz
gentoo-2-6a0f0c6c6a5b159cc2976e419697a487f417109d.tar.bz2
gentoo-2-6a0f0c6c6a5b159cc2976e419697a487f417109d.zip
bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ac-sources/ac-sources-2.4.21_pre4-r7.ebuild38
-rw-r--r--sys-kernel/ac-sources/files/digest-ac-sources-2.4.21_pre4-r73
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/ac-sources/ac-sources-2.4.21_pre4-r7.ebuild b/sys-kernel/ac-sources/ac-sources-2.4.21_pre4-r7.ebuild
new file mode 100644
index 000000000000..627d866cb68a
--- /dev/null
+++ b/sys-kernel/ac-sources/ac-sources-2.4.21_pre4-r7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ac-sources/ac-sources-2.4.21_pre4-r7.ebuild,v 1.1 2003/02/27 17:40:06 lostlogic Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.20"
+ACV=ac${PR/r/}
+KV="${PV/_/-}-${ACV}"
+S=${WORKDIR}/linux-${KV}
+
+EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+DESCRIPTION="Full sources for Alan Cox's Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.4/${BASE}/patch-${KV}.bz2
+http://www.kernel.org/pub/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2"
+
+KEYWORDS="x86"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+ bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "-marcelo patch failed"
+ bzcat ${DISTDIR}/patch-${KV}.bz2|patch -p1 || die "-ac patch failed"
+
+ kernel_universal_unpack
+}
diff --git a/sys-kernel/ac-sources/files/digest-ac-sources-2.4.21_pre4-r7 b/sys-kernel/ac-sources/files/digest-ac-sources-2.4.21_pre4-r7
new file mode 100644
index 000000000000..3541439f1282
--- /dev/null
+++ b/sys-kernel/ac-sources/files/digest-ac-sources-2.4.21_pre4-r7
@@ -0,0 +1,3 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 cfa33036479febe10c1e63b2cdefcad7 patch-2.4.21-pre4-ac7.bz2 1183946
+MD5 2785b6bd5e775ab881af507b7ece236d patch-2.4.21-pre4.bz2 1863302