summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-06-14 22:02:20 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-06-14 22:02:20 +0000
commit8747654087c1808f29074ad23d30c5c4f8eb1262 (patch)
treefa1f1e2b5cb498bf29b1b386b8d7bb948ae72b39 /sys-kernel
parentx support is going to be marked ~ppc64 in the next few commits (diff)
downloadgentoo-2-8747654087c1808f29074ad23d30c5c4f8eb1262.tar.gz
gentoo-2-8747654087c1808f29074ad23d30c5c4f8eb1262.tar.bz2
gentoo-2-8747654087c1808f29074ad23d30c5c4f8eb1262.zip
Added a patch for the FPU-lockup issue; please see bug #58304 for details.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/xfs-sources/ChangeLog8
-rw-r--r--sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.24-r72
-rw-r--r--sys-kernel/xfs-sources/files/xfs-sources.FPULockup-53804.patch11
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.24-r7.ebuild49
4 files changed, 69 insertions, 1 deletions
diff --git a/sys-kernel/xfs-sources/ChangeLog b/sys-kernel/xfs-sources/ChangeLog
index 4d0fcdfde534..8d1aea309eaa 100644
--- a/sys-kernel/xfs-sources/ChangeLog
+++ b/sys-kernel/xfs-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/xfs-sources
# Copyright 1999-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.47 2004/06/04 15:54:18 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.48 2004/06/14 22:02:20 plasmaroo Exp $
+
+*xfs-sources-2.4.24-r7 (14 Jun 2004)
+
+ 14 Jun 2004; <plasmaroo@gentoo.org> +xfs-sources-2.4.24-r7.ebuild,
+ +files/xfs-sources.FPULockup-53804.patch:
+ Added a patch for the FPU-lockup issue; please see bug #58304 for details.
*xfs-sources-2.4.24-r6 (04 Jun 2004)
diff --git a/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.24-r7 b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.24-r7
new file mode 100644
index 000000000000..981a129bcbef
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.24-r7
@@ -0,0 +1,2 @@
+MD5 1e055c42921b2396a559d84df4c3d9aa linux-2.4.24.tar.bz2 29837818
+MD5 572ff310d39ce7fd20568bf27299ded8 xfs-sources-2.4.24-r3.patch.bz2 1718289
diff --git a/sys-kernel/xfs-sources/files/xfs-sources.FPULockup-53804.patch b/sys-kernel/xfs-sources/files/xfs-sources.FPULockup-53804.patch
new file mode 100644
index 000000000000..1dd5ed87b520
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/xfs-sources.FPULockup-53804.patch
@@ -0,0 +1,11 @@
+--- linux-2.4/include/asm-i386/i387.h 2004-06-13 20:06:05.044881328 +0100
++++ linux-2.4/include/asm-i386/i387.h 2004-06-13 20:25:42.836829736 +0100
+@@ -34,7 +34,7 @@
+
+ #define clear_fpu( tsk ) do { \
+ if ( tsk->flags & PF_USEDFPU ) { \
+- asm volatile("fwait"); \
++ asm volatile("fnclex ; fwait"); \
+ tsk->flags &= ~PF_USEDFPU; \
+ stts(); \
+ } \
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.24-r7.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.24-r7.ebuild
new file mode 100644
index 000000000000..83341c0b1471
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.24-r7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.24-r7.ebuild,v 1.1 2004/06/14 22:02:20 plasmaroo Exp $
+
+ETYPE="sources"
+
+inherit kernel eutils
+IUSE=""
+OKV="`echo ${PV}|sed -e 's:^\([0-9]\+\.[0-9]\+\.[0-9]\+\).*:\1:'`"
+EXTRAVERSION="-${PN/-*/}-${PR}"
+KV=${OKV}${EXTRAVERSION}
+
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/xfs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the XFS Specialized Gentoo Linux kernel"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://dev.gentoo.org/~scox/kernels/v2.4/xfs-sources-${PV}-r3.patch.bz2"
+
+KEYWORDS="x86 -ppc -sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+ bzcat ${DISTDIR}/xfs-sources-${PV}-r3.patch.bz2 | patch -p1 \
+ || die "Failed to patch kernel"
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}.munmap.patch || die "Failed to apply munmap!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0010.patch || die "Failed to add the CAN-2004-0010 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0075.patch || die "Failed to add the CAN-2004-0075 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0109.patch || die "Failed to add the CAN-2004-0109 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0133.patch || die "Failed to add the CAN-2004-0133 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0177.patch || die "Failed to add the CAN-2004-0177 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0178.patch || die "Failed to add the CAN-2004-0178 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0181.patch || die "Failed to add the CAN-2004-0181 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0394.patch || die "Failed to add the CAN-2004-0394 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0427.patch || die "Failed to add the CAN-2004-0427 patch!"
+ epatch ${FILESDIR}/${PN}.FPULockup-53804.patch || die "Failed to apply FPU-lockup patch!"
+
+ make mrproper || die "make mrproper failed"
+ kernel_universal_unpack
+}