summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-01-16 08:57:37 +0000
committerRichard Yao <ryao@gentoo.org>2013-01-16 08:57:37 +0000
commit91436531e1ce71f0e6570319e44193b7cb7ed3ce (patch)
tree5519914d21d1f8afff85ce2201141b4cef4a2bee /sys-kernel
parentFix cross-compilation, wrt bug #424473. Thanks to DaboD <daiderek AT gmail.co... (diff)
downloadgentoo-2-91436531e1ce71f0e6570319e44193b7cb7ed3ce.tar.gz
gentoo-2-91436531e1ce71f0e6570319e44193b7cb7ed3ce.tar.bz2
gentoo-2-91436531e1ce71f0e6570319e44193b7cb7ed3ce.zip
Filter -Wl,* from LDFLAGS to prevent build failures on ARM
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/spl/ChangeLog7
-rw-r--r--sys-kernel/spl/spl-0.6.0_rc13-r2.ebuild101
2 files changed, 107 insertions, 1 deletions
diff --git a/sys-kernel/spl/ChangeLog b/sys-kernel/spl/ChangeLog
index 9650e2309901..07ce497423b1 100644
--- a/sys-kernel/spl/ChangeLog
+++ b/sys-kernel/spl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/spl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/ChangeLog,v 1.39 2013/01/14 21:11:56 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/ChangeLog,v 1.40 2013/01/16 08:57:37 ryao Exp $
+
+*spl-0.6.0_rc13-r2 (16 Jan 2013)
+
+ 16 Jan 2013; Richard Yao <ryao@gentoo.org> +spl-0.6.0_rc13-r2.ebuild:
+ Filter -Wl,* from LDFLAGS to prevent build failures on ARM
14 Jan 2013; Richard Yao <ryao@gentoo.org> spl-0.6.0_rc13-r1.ebuild:
Fix trailing whitespace in ebuild
diff --git a/sys-kernel/spl/spl-0.6.0_rc13-r2.ebuild b/sys-kernel/spl/spl-0.6.0_rc13-r2.ebuild
new file mode 100644
index 000000000000..a7b7e1849223
--- /dev/null
+++ b/sys-kernel/spl/spl-0.6.0_rc13-r2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/spl-0.6.0_rc13-r2.ebuild,v 1.1 2013/01/16 08:57:37 ryao Exp $
+
+EAPI="4"
+AUTOTOOLS_AUTORECONF="1"
+
+inherit flag-o-matic linux-mod autotools-utils
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/zfsonlinux/${PN}.git"
+else
+ inherit eutils versionator
+ MY_PV=$(replace_version_separator 3 '-')
+ SRC_URI="https://github.com/zfsonlinux/${PN}/archive/${PN}-${MY_PV}.tar.gz"
+ S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="The Solaris Porting Layer is a Linux kernel module which provides many of the Solaris kernel APIs"
+HOMEPAGE="http://zfsonlinux.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="custom-cflags debug debug-log"
+RESTRICT="test"
+
+RDEPEND="!sys-devel/spl"
+
+AT_M4DIR="config"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+pkg_setup() {
+ CONFIG_CHECK="
+ !DEBUG_LOCK_ALLOC
+ !GRKERNSEC_HIDESYM
+ MODULES
+ KALLSYMS
+ !PAX_KERNEXEC_PLUGIN_METHOD_OR
+ ZLIB_DEFLATE
+ ZLIB_INFLATE
+ "
+
+ kernel_is ge 2 6 26 || die "Linux 2.6.26 or newer required"
+
+ [ ${PV} != "9999" ] && \
+ { kernel_is le 3 8 || die "Linux 3.8 is the latest supported version."; }
+
+ check_extra_config
+}
+
+src_prepare() {
+ # Workaround for hard coded path
+ sed -i "s|/sbin/lsmod|/bin/lsmod|" scripts/check.sh || die
+
+ if [ ${PV} != "9999" ]
+ then
+ # Fix on_each_cpu autotools to work correctly
+ epatch "${FILESDIR}/${P}-fix-on_each_cpu-autotools-check.patch"
+
+ # Fix soft lockup regression
+ epatch "${FILESDIR}/${P}-fix-soft-lockup.patch"
+ fi
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ filter-ldflags -Wl,*
+
+ set_arch_to_kernel
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --sbindir="${EPREFIX}/sbin"
+ --with-config=all
+ --with-linux="${KV_DIR}"
+ --with-linux-obj="${KV_OUT_DIR}"
+ $(use_enable debug)
+ $(use_enable debug-log)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ if [[ ! -e /proc/modules ]]
+ then
+ die "Missing /proc/modules"
+ elif [[ $UID -ne 0 ]]
+ then
+ ewarn "Cannot run make check tests with FEATURES=userpriv."
+ ewarn "Skipping make check tests."
+ elif grep -q '^spl ' /proc/modules
+ then
+ ewarn "Cannot run make check tests with module spl loaded."
+ ewarn "Skipping make check tests."
+ else
+ autotools-utils_src_test
+ fi
+}