summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStratos Psomadakis <psomas@gentoo.org>2011-08-31 14:26:51 +0000
committerStratos Psomadakis <psomas@gentoo.org>2011-08-31 14:26:51 +0000
commitb470243fe08af7daf584b435401548964e047595 (patch)
tree3e36f00f89c202ad14d16f868e12a2d4fe1bd345 /sys-kernel
parentVersion bump (diff)
downloadgentoo-2-b470243fe08af7daf584b435401548964e047595.tar.gz
gentoo-2-b470243fe08af7daf584b435401548964e047595.tar.bz2
gentoo-2-b470243fe08af7daf584b435401548964e047595.zip
Add deblob support
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/rt-sources/ChangeLog8
-rw-r--r--sys-kernel/rt-sources/metadata.xml3
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.0.3_p12-r1.ebuild50
3 files changed, 60 insertions, 1 deletions
diff --git a/sys-kernel/rt-sources/ChangeLog b/sys-kernel/rt-sources/ChangeLog
index d3b9ce81e4bb..f2f6dd62bdca 100644
--- a/sys-kernel/rt-sources/ChangeLog
+++ b/sys-kernel/rt-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/rt-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.3 2011/08/27 12:31:04 psomas Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.4 2011/08/31 14:26:51 psomas Exp $
+
+*rt-sources-3.0.3_p12-r1 (31 Aug 2011)
+
+ 31 Aug 2011; Stratos Psomadakis <psomas@gentoo.org>
+ +rt-sources-3.0.3_p12-r1.ebuild, metadata.xml:
+ Add deblob support
*rt-sources-3.0.3_p12 (27 Aug 2011)
diff --git a/sys-kernel/rt-sources/metadata.xml b/sys-kernel/rt-sources/metadata.xml
index 4b7bcf7a9cb4..466e5a3b0aa9 100644
--- a/sys-kernel/rt-sources/metadata.xml
+++ b/sys-kernel/rt-sources/metadata.xml
@@ -10,4 +10,7 @@
<longdescription>
Real-time patchset for the Linux Kernel
</longdescription>
+ <use>
+ <flag name='deblob'>Remove binary blobs from kernel sources to provide libre license compliance.</flag>
+ </use>
</pkgmetadata>
diff --git a/sys-kernel/rt-sources/rt-sources-3.0.3_p12-r1.ebuild b/sys-kernel/rt-sources/rt-sources-3.0.3_p12-r1.ebuild
new file mode 100644
index 000000000000..0c81c4abf1ed
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-3.0.3_p12-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+EAPI="2"
+
+COMPRESSTYPE=".bz2"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="4"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE="1"
+
+ETYPE="sources"
+inherit kernel-2
+detect_version
+detect_arch
+
+RT_PATCHSET="${PV/*_p}"
+RT_KERNEL="${PV/_p[0-9]*}"
+RT_KERNEL="${RT_KERNEL/_/-}"
+RT_FILE="patch-${RT_KERNEL}-rt${RT_PATCHSET}.patch${COMPRESSTYPE}"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${RT_FILE}"
+
+DESCRIPTION="Real-time patchset for the Linux Kernel"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/projects/rt/"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${RT_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="deblob"
+
+KV_FULL="${PVR/_p/-rt}"
+EXTRAVERSION="-rt${RT_PATCHSET}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${RT_FILE}"
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."