summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-09-12 02:50:28 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-09-12 02:50:28 +0000
commitc612781bf1c49f107d7ac1a6af690e72c4a01720 (patch)
tree2b36a44fe93703a515016286cd9a217e09a415d8 /sys-kernel
parentvanilla-2.6.32.59 + genpatches-2.6.32-48 + grsecurity-2.9.1-2.6.32.59-2012091... (diff)
downloadgentoo-2-c612781bf1c49f107d7ac1a6af690e72c4a01720.tar.gz
gentoo-2-c612781bf1c49f107d7ac1a6af690e72c4a01720.tar.bz2
gentoo-2-c612781bf1c49f107d7ac1a6af690e72c4a01720.zip
vanilla-3.2.28 + genpatches-3.2-16 + grsecurity-2.9.1-3.2.28-201209101830
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.2.28-r4.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index db0b0e212569..caa0db19803b 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.679 2012/09/12 02:48:44 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.680 2012/09/12 02:50:28 blueness Exp $
+
+*hardened-sources-3.2.28-r4 (12 Sep 2012)
+
+ 12 Sep 2012; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-3.2.28-r4.ebuild:
+ vanilla-3.2.28 + genpatches-3.2-16 + grsecurity-2.9.1-3.2.28-201209101830
*hardened-sources-2.6.32-r127 (12 Sep 2012)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.2.28-r4.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.2.28-r4.ebuild
new file mode 100644
index 000000000000..689f7a628bea
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.2.28-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.28-r4.ebuild,v 1.1 2012/09/12 02:50:28 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="16"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-4"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.9.1*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]. Those who intend to"
+ ewarn "use one of these predefined grsecurity levels should read the help"
+ ewarn "associated with the level. Because some options require >=gcc-4.5,"
+ ewarn "users with more, than one version of gcc installed should use gcc-config"
+ ewarn "to select a compatible version."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}