summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-01-21 11:57:07 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-01-21 11:57:07 +0000
commitc6b25d5e5db5c7a566bfae7400443b8947606e17 (patch)
tree4bfd1cc8cc6b8a631385737640c3d6506f79bfb4 /sys-kernel
parentFix szip configure logic, respect CC (diff)
downloadgentoo-2-c6b25d5e5db5c7a566bfae7400443b8947606e17.tar.gz
gentoo-2-c6b25d5e5db5c7a566bfae7400443b8947606e17.tar.bz2
gentoo-2-c6b25d5e5db5c7a566bfae7400443b8947606e17.zip
Based on 2.6.32.54 + genpatches-2.6.32-48 + grsecurity-2.2.2-2.6.32.54-201201201821
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r86.ebuild51
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 81ed704140c4..ab03e0700e12 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.525 2012/01/13 17:36:22 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.526 2012/01/21 11:57:07 blueness Exp $
+
+*hardened-sources-2.6.32-r86 (21 Jan 2012)
+
+ 21 Jan 2012; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r86.ebuild:
+ Based on 2.6.32.54 + genpatches-2.6.32-48 +
+ grsecurity-2.2.2-2.6.32.54-201201201821
*hardened-sources-3.1.8 (13 Jan 2012)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r86.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r86.ebuild
new file mode 100644
index 000000000000..5b171a31815b
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r86.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r86.ebuild,v 1.1 2012/01/21 11:57:07 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="48"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-88"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="2901_kbuild-fix-passing-wno-options-to-gcc-4.4.patch 4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.2*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]."
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}