summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-06-19 17:45:40 +0000
committerBen de Groot <yngwin@gentoo.org>2012-06-19 17:45:40 +0000
commitd549584bff54f8bc9875c38437cd4e64a98402e9 (patch)
treee5835355a8e2e5384bca33a20923e8fdd0df9298 /sys-kernel
parentadded support for spidermonkey-1.8.7, relates to bug 422169 (diff)
downloadgentoo-2-d549584bff54f8bc9875c38437cd4e64a98402e9.tar.gz
gentoo-2-d549584bff54f8bc9875c38437cd4e64a98402e9.tar.bz2
gentoo-2-d549584bff54f8bc9875c38437cd4e64a98402e9.zip
Version bump
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/pf-sources/ChangeLog7
-rw-r--r--sys-kernel/pf-sources/pf-sources-3.4.2.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index 14aa88f59ead..987599f2677d 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/pf-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.63 2012/06/05 10:02:05 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.64 2012/06/19 17:45:40 yngwin Exp $
+
+*pf-sources-3.4.2 (19 Jun 2012)
+
+ 19 Jun 2012; Ben de Groot <yngwin@gentoo.org> +pf-sources-3.4.2.ebuild:
+ Version bump
*pf-sources-3.4.1 (05 Jun 2012)
diff --git a/sys-kernel/pf-sources/pf-sources-3.4.2.ebuild b/sys-kernel/pf-sources/pf-sources-3.4.2.ebuild
new file mode 100644
index 000000000000..bdb23d1bd6ad
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-3.4.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-3.4.2.ebuild,v 1.1 2012/06/19 17:45:40 yngwin Exp $
+
+EAPI="2"
+
+inherit versionator
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="$(get_version_component_range 1-2)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and LinuxIMQ"
+HOMEPAGE="http://pf.natalenko.name/"
+
+PF_FILE="patch-${PV}-pf${COMPRESSTYPE}"
+PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
+EXPERIMENTAL_PATCHES=(
+ # http://ck-hack.blogspot.com/2010/11/create-task-groups-by-tty-comment.html
+ # http://ck.kolivas.org/patches/bfs/bfs357-penalise_fork_depth_account_threads.patch
+)
+EXPERIMENTAL_URI="
+ experimental? (
+ ${EXPERIMENTAL_PATCHES[@]}
+ )
+"
+SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="" # experimental
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog
+ elog "${P} has the following optional runtime dependencies:"
+ elog " sys-apps/tuxonice-userui"
+ elog " provides minimal userspace progress information related to"
+ elog " suspending and resuming process"
+ elog " sys-power/hibernate-script or sys-power/pm-utils"
+ elog " runtime utilites for hibernating and suspending your computer"
+ elog
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."