summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-12-30 19:43:40 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-12-30 19:43:40 +0000
commitf84c5102ce5cead9b76dd29a38482f6a188e1838 (patch)
treefb352edba14cff02acc23aa4cbe31f8adb1cf858 /sys-kernel
parentadded "max-idx-128" for dev-db/mysql (diff)
downloadgentoo-2-f84c5102ce5cead9b76dd29a38482f6a188e1838.tar.gz
gentoo-2-f84c5102ce5cead9b76dd29a38482f6a188e1838.tar.bz2
gentoo-2-f84c5102ce5cead9b76dd29a38482f6a188e1838.zip
Fix glibc compile; start running headers___fix on all the headers by default; bug #117227.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-headers/ChangeLog6
-rw-r--r--sys-kernel/linux-headers/files/digest-linux-headers-2.6.15_rc62
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.15_rc6.ebuild29
3 files changed, 22 insertions, 15 deletions
diff --git a/sys-kernel/linux-headers/ChangeLog b/sys-kernel/linux-headers/ChangeLog
index 4272fde777cf..2918865edd9f 100644
--- a/sys-kernel/linux-headers/ChangeLog
+++ b/sys-kernel/linux-headers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/linux-headers
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.158 2005/12/28 18:58:07 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.159 2005/12/30 19:43:40 plasmaroo Exp $
+
+ 30 Dec 2005; <plasmaroo@gentoo.org> linux-headers-2.6.15_rc6.ebuild:
+ Fix glibc compile; start running headers___fix on all the headers
+ by default.
28 Dec 2005; <plasmaroo@gentoo.org> linux-headers-2.6.11-r4.ebuild:
Fix joystick.h issue on SPARC.
diff --git a/sys-kernel/linux-headers/files/digest-linux-headers-2.6.15_rc6 b/sys-kernel/linux-headers/files/digest-linux-headers-2.6.15_rc6
index 2cfcf0dd1f2d..6041b1c01722 100644
--- a/sys-kernel/linux-headers/files/digest-linux-headers-2.6.15_rc6
+++ b/sys-kernel/linux-headers/files/digest-linux-headers-2.6.15_rc6
@@ -1,4 +1,4 @@
MD5 9c1d46fca842361a84e499e851c7548e patch-2.6.15-rc6.bz2 6224690
MD5 66d02cbd723876c6d69846a067875a22 linux-2.6.14.tar.bz2 39172170
MD5 0880556aadd7dc0b77258dcf4ea9b88b linux-2.6.11-m68k-headers.patch.bz2 12090
-MD5 b67d982a61e89e7a486545965b4013c0 gentoo-headers-2.6.15_rc6-1.tar.bz2 19706
+MD5 9d898af8ad6f241ba19230ba0c1509e0 gentoo-headers-2.6.15_rc6-2.tar.bz2 19910
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.15_rc6.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.15_rc6.ebuild
index 2fb8c36975cb..9d144826cb25 100644
--- a/sys-kernel/linux-headers/linux-headers-2.6.15_rc6.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.6.15_rc6.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.15_rc6.ebuild,v 1.1 2005/12/22 00:52:16 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.15_rc6.ebuild,v 1.2 2005/12/30 19:43:40 plasmaroo Exp $
ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arm hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
inherit eutils kernel-2
detect_version
-PATCHES_V='1'
+PATCHES_V='2'
SRC_URI="${KERNEL_URI} mirror://gentoo/linux-2.6.11-m68k-headers.patch.bz2
http://dev.gentoo.org/~plasmaroo/patches/kernel/gentoo-headers/gentoo-headers-${PV}-${PATCHES_V}.tar.bz2"
@@ -18,6 +18,17 @@ DEPEND="ppc? ( gcc64? ( sys-devel/gcc-powerpc64 ) )
UNIPATCH_LIST="${DISTDIR}/gentoo-headers-${PV}-${PATCHES_V}.tar.bz2"
+wrap_headers_fix() {
+ for i in $*
+ do
+ echo -n " $1/"
+ cd ${S}/include/$1
+ headers___fix $(find . -type f -mindepth 1 -print)
+ shift
+ done
+ echo
+}
+
src_unpack() {
kernel-2_src_unpack
@@ -29,17 +40,9 @@ src_unpack() {
# Fixes ... all the mv magic is to keep sed from dumping
# ugly warnings about how it can't work on a directory.
cd "${S}"/include
- mv asm-ia64/sn asm-ppc64/iSeries .
- headers___fix asm-ia64/*
- mv sn asm-ia64/
- headers___fix asm-ppc64/*
- mv iSeries asm-ppc64/
- headers___fix asm-ppc64/iSeries/*
- headers___fix linux/{ethtool,jiffies}.h
-
- # #114767...
- headers___fix asm-alpha/bitops.h linux/{bitops,wait}.h
- headers___fix asm-generic/*
+ einfo "Applying automated fixes:"
+ wrap_headers_fix asm-* linux
+ einfo "... done"
# Apply patch for spinlick.h only with 32bit userland on ppc64.
# Will add to the main patchball when plasmaroo returns.