summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-12-16 10:29:20 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-12-16 10:29:20 +0000
commit5076048e9bb6a543c8f597c7c2ec837528b0e7f4 (patch)
tree7cd4e21a0ff337e84bb980ecce8a56c8083deeb5 /sys-libs/db/db-3.2.9-r10.ebuild
parentStable on amd64. (Manifest recommit) (diff)
downloadgentoo-2-5076048e9bb6a543c8f597c7c2ec837528b0e7f4.tar.gz
gentoo-2-5076048e9bb6a543c8f597c7c2ec837528b0e7f4.tar.bz2
gentoo-2-5076048e9bb6a543c8f597c7c2ec837528b0e7f4.zip
get_libdir support for multilib archs.
Diffstat (limited to 'sys-libs/db/db-3.2.9-r10.ebuild')
-rw-r--r--sys-libs/db/db-3.2.9-r10.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-libs/db/db-3.2.9-r10.ebuild b/sys-libs/db/db-3.2.9-r10.ebuild
index 9cfae39a7b4c..04cf814d11a4 100644
--- a/sys-libs/db/db-3.2.9-r10.ebuild
+++ b/sys-libs/db/db-3.2.9-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.14 2004/09/27 08:05:46 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.15 2004/12/16 10:29:20 eradicator Exp $
inherit gnuconfig libtool eutils db
@@ -93,12 +93,14 @@ src_compile() {
mkdir -p ${S}/build-static
cd ${S}/build-static
../dist/configure ${conf} ${conf_static} \
+ --libdir=/usr/$(get_libdir) \
--enable-static || die
einfo "Configuring ${P} (shared)..."
mkdir -p ${S}/build-shared
cd ${S}/build-shared
../dist/configure ${conf} ${conf_shared} \
+ --libdir=/usr/$(get_libdir) \
--enable-shared || die
# Parallel make does not work
@@ -116,6 +118,7 @@ src_install () {
make libdb=libdb-3.2.a \
libcxx=libcxx_3.2.a \
prefix=${D}/usr \
+ libdir=${D}/usr/$(get_libdir) \
install || die
cd ${S}/build-static
@@ -131,7 +134,7 @@ src_install () {
# For some reason, db.so's are *not* readable by group or others,
# resulting in no one but root being able to use them!!!
# This fixes it -- DR 15 Jun 2001
- cd ${D}/usr/lib
+ cd ${D}/usr/$(get_libdir)
chmod go+rx *.so
# The .la's aren't readable either
chmod go+r *.la