summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-09-13 18:03:19 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-09-13 18:03:19 +0000
commitc8be8c113c363a79dd6aed5b305b68d183af0b3b (patch)
treece94d771f4b2ab2877302eaf67691221cc66f8a3 /sys-libs/db
parentia64 stable wrt #282232 (diff)
downloadgentoo-2-c8be8c113c363a79dd6aed5b305b68d183af0b3b.tar.gz
gentoo-2-c8be8c113c363a79dd6aed5b305b68d183af0b3b.tar.bz2
gentoo-2-c8be8c113c363a79dd6aed5b305b68d183af0b3b.zip
Bug #270851: with FEATURES=test USE=-tcl, we need to include Tcl anyway so that the testsuite works.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog6
-rw-r--r--sys-libs/db/db-4.7.25_p4.ebuild15
2 files changed, 17 insertions, 4 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 48121a629cbe..3f1d005f3459 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.287 2009/07/30 11:01:33 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.288 2009/09/13 18:03:19 robbat2 Exp $
+
+ 13 Sep 2009; Robin H. Johnson <robbat2@gentoo.org> db-4.7.25_p4.ebuild:
+ Bug #270851: with FEATURES=test USE=-tcl, we need to include Tcl anyway so
+ that the testsuite works.
29 Jul 2009; Paul de Vrieze <pauldv@gentoo.org> db-3.2.9-r11.ebuild,
db-3.2.9_p2.ebuild, db-4.2.52_p4-r2.ebuild, db-4.2.52_p5.ebuild,
diff --git a/sys-libs/db/db-4.7.25_p4.ebuild b/sys-libs/db/db-4.7.25_p4.ebuild
index 54dd7cbbccf1..8f5c23429bda 100644
--- a/sys-libs/db/db-4.7.25_p4.ebuild
+++ b/sys-libs/db/db-4.7.25_p4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25_p4.ebuild,v 1.2 2009/07/05 19:52:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25_p4.ebuild,v 1.3 2009/09/13 18:03:19 robbat2 Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -77,6 +77,8 @@ src_unpack() {
}
src_compile() {
+ local myconf=''
+
# compilation with -O0 fails on amd64, see bug #171231
if use amd64; then
replace-flags -O0 -O2
@@ -96,6 +98,14 @@ src_compile() {
if use userland_GNU ; then
append-ldflags -Wl,--default-symver
fi
+
+ # Bug #270851: test needs TCL support
+ if use tcl || use test ; then
+ myconf="${myconf} --enable-tcl"
+ myconf="${myconf} --with-tcl=/usr/$(get_libdir)"
+ else
+ myconf="${myconf} --disable-tcl"
+ fi
cd "${S}"
ECONF_SOURCE="${S}"/../dist \
@@ -109,8 +119,7 @@ src_compile() {
$(use amd64 && echo --with-mutex=x86/gcc-assembly) \
$(use_enable !nocxx cxx) \
$(use_enable java) \
- $(use_enable tcl) \
- $(use tcl && echo --with-tcl=/usr/$(get_libdir)) \
+ ${myconf} \
$(use_enable test) \
"$@"