summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-07-10 19:05:02 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-07-10 19:05:02 +0000
commit654dbf79c3c554539675071de47fc6bcac31eb5d (patch)
treeb07d7967afbda3907670b5bcd534505b1147f819 /sys-libs/e2fsprogs-libs
parentVersion bump. (diff)
downloadgentoo-2-654dbf79c3c554539675071de47fc6bcac31eb5d.tar.gz
gentoo-2-654dbf79c3c554539675071de47fc6bcac31eb5d.tar.bz2
gentoo-2-654dbf79c3c554539675071de47fc6bcac31eb5d.zip
fixed cross-compiling, bug 516854, with Poly-C's blessing
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sys-libs/e2fsprogs-libs')
-rw-r--r--sys-libs/e2fsprogs-libs/ChangeLog7
-rw-r--r--sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.10.ebuild15
-rw-r--r--sys-libs/e2fsprogs-libs/files/e2fsprogs-libs-1.42.10-fix-build-cflags.patch11
3 files changed, 29 insertions, 4 deletions
diff --git a/sys-libs/e2fsprogs-libs/ChangeLog b/sys-libs/e2fsprogs-libs/ChangeLog
index cdfb589accd3..ee632e8ae820 100644
--- a/sys-libs/e2fsprogs-libs/ChangeLog
+++ b/sys-libs/e2fsprogs-libs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/e2fsprogs-libs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/ChangeLog,v 1.115 2014/07/09 11:12:53 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/ChangeLog,v 1.116 2014/07/10 19:05:02 axs Exp $
+
+ 10 Jul 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +files/e2fsprogs-libs-1.42.10-fix-build-cflags.patch,
+ e2fsprogs-libs-1.42.10.ebuild:
+ fixed cross-compiling, bug 516854, with Poly-C's blessing
09 Jul 2014; Mikle Kolyada <zlogene@gentoo.org> e2fsprogs-libs-1.42.10.ebuild:
amd64 stable wrt bug #516114
diff --git a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.10.ebuild b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.10.ebuild
index 330c5eb627da..e9e50aacd4d3 100644
--- a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.10.ebuild
+++ b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.10.ebuild,v 1.2 2014/07/09 11:12:53 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.10.ebuild,v 1.3 2014/07/10 19:05:02 axs Exp $
EAPI="4"
@@ -9,7 +9,7 @@ case ${PV} in
*) UP_PV=${PV} ;;
esac
-inherit toolchain-funcs eutils multilib-minimal
+inherit autotools toolchain-funcs eutils multilib-minimal
DESCRIPTION="e2fsprogs libraries (common error and subsystem)"
HOMEPAGE="http://e2fsprogs.sourceforge.net/"
@@ -35,6 +35,8 @@ S=${WORKDIR}/${P%_pre*}
src_prepare() {
printf 'all:\n%%:;@:\n' > doc/Makefile.in # don't bother with docs #305613
epatch "${FILESDIR}"/${PN}-1.42.9-no-quota.patch
+ epatch "${FILESDIR}"/${P}-fix-build-cflags.patch
+ eautoreconf
}
multilib_src_configure() {
@@ -43,6 +45,9 @@ multilib_src_configure() {
ac_cv_lib_blkid_blkid_get_cache=yes \
ac_cv_path_LDCONFIG=: \
ECONF_SOURCE="${S}" \
+ CC="$(tc-getCC)" \
+ BUILD_CC="$(tc-getBUILD_CC)" \
+ BUILD_LD="$(tc-getBUILD_LD)" \
econf \
--disable-lib{blkid,uuid} \
--disable-quota \
@@ -51,8 +56,12 @@ multilib_src_configure() {
$(use_enable nls)
}
+multilib_src_compile() {
+ emake V=1
+}
+
multilib_src_install() {
- emake STRIP=: DESTDIR="${D}" install || die
+ emake V=1 STRIP=: DESTDIR="${D}" install || die
multilib_is_native_abi && gen_usr_ldscript -a com_err ss
# configure doesn't have an option to disable static libs :/
use static-libs || find "${ED}" -name '*.a' -delete
diff --git a/sys-libs/e2fsprogs-libs/files/e2fsprogs-libs-1.42.10-fix-build-cflags.patch b/sys-libs/e2fsprogs-libs/files/e2fsprogs-libs-1.42.10-fix-build-cflags.patch
new file mode 100644
index 000000000000..ff68590521fa
--- /dev/null
+++ b/sys-libs/e2fsprogs-libs/files/e2fsprogs-libs-1.42.10-fix-build-cflags.patch
@@ -0,0 +1,11 @@
+--- a/e2fsprogs-libs-1.42.10/configure.in 2014-05-15 13:04:08.000000000 -0400
++++ b/e2fsprogs-libs-1.42.10/configure.in 2014-07-10 13:39:21.374156802 -0400
+@@ -1328,7 +1328,7 @@
+ BUILD_CFLAGS="$CFLAGS $CPPFLAGS $INCLUDES -DHAVE_CONFIG_H"
+ BUILD_LDFLAGS="$LDFLAGS"
+ else
+- BUILD_CFLAGS=
++ BUILD_CFLAGS="$INCLUDES"
+ BUILD_LDFLAGS=
+ fi
+ AC_SUBST(BUILD_CFLAGS)