summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-12-31 19:07:47 +0000
committerMike Frysinger <vapier@gentoo.org>2013-12-31 19:07:47 +0000
commitdfc03d4e9b72d091f132aefcac01f61ae49dd2d3 (patch)
tree449888f1b6b69186bb94086979fa7f3d74b10b0a /sys-libs/e2fsprogs-libs
parentAdd a use flag to enable KDBUS by default; this may be enabled unconditionall... (diff)
downloadgentoo-2-dfc03d4e9b72d091f132aefcac01f61ae49dd2d3.tar.gz
gentoo-2-dfc03d4e9b72d091f132aefcac01f61ae49dd2d3.tar.bz2
gentoo-2-dfc03d4e9b72d091f132aefcac01f61ae49dd2d3.zip
Version bump #496594 by Ulenrich.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs/e2fsprogs-libs')
-rw-r--r--sys-libs/e2fsprogs-libs/ChangeLog8
-rw-r--r--sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.9.ebuild67
-rw-r--r--sys-libs/e2fsprogs-libs/files/e2fsprogs-libs-1.42.9-no-quota.patch36
3 files changed, 110 insertions, 1 deletions
diff --git a/sys-libs/e2fsprogs-libs/ChangeLog b/sys-libs/e2fsprogs-libs/ChangeLog
index dceea78ca53b..8a03b91767c8 100644
--- a/sys-libs/e2fsprogs-libs/ChangeLog
+++ b/sys-libs/e2fsprogs-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/e2fsprogs-libs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/ChangeLog,v 1.108 2013/10/08 12:55:02 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/ChangeLog,v 1.109 2013/12/31 19:07:47 vapier Exp $
+
+*e2fsprogs-libs-1.42.9 (31 Dec 2013)
+
+ 31 Dec 2013; Mike Frysinger <vapier@gentoo.org> +e2fsprogs-libs-1.42.9.ebuild,
+ +files/e2fsprogs-libs-1.42.9-no-quota.patch:
+ Version bump #496594 by Ulenrich.
*e2fsprogs-libs-1.42.8 (08 Oct 2013)
diff --git a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.9.ebuild b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.9.ebuild
new file mode 100644
index 000000000000..6599d8c041dd
--- /dev/null
+++ b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.9.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.42.9.ebuild,v 1.1 2013/12/31 19:07:47 vapier Exp $
+
+EAPI="4"
+
+case ${PV} in
+*_pre*) UP_PV="${PV%_pre*}-WIP-${PV#*_pre}" ;;
+*) UP_PV=${PV} ;;
+esac
+
+inherit toolchain-funcs eutils multilib-minimal
+
+DESCRIPTION="e2fsprogs libraries (common error and subsystem)"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${PN}-${UP_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="nls static-libs"
+
+RDEPEND="!sys-libs/com_err
+ !sys-libs/ss
+ !<sys-fs/e2fsprogs-1.41.8
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r12
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P%_pre*}
+
+src_prepare() {
+ printf 'all:\n%%:;@:\n' > doc/Makefile.in # don't bother with docs #305613
+ epatch "${FILESDIR}"/${PN}-1.42.9-no-quota.patch
+}
+
+multilib_src_configure() {
+ # We want to use the "bsd" libraries while building on Darwin, but while
+ # building on other Gentoo/*BSD we prefer elf-naming scheme.
+ local libtype
+ case ${CHOST} in
+ *-darwin*) libtype=bsd;;
+ *) libtype=elf;;
+ esac
+
+ # we use blkid/uuid from util-linux now
+ ac_cv_lib_uuid_uuid_generate=yes \
+ ac_cv_lib_blkid_blkid_get_cache=yes \
+ ac_cv_path_LDCONFIG=: \
+ ECONF_SOURCE="${S}" \
+ econf \
+ --disable-lib{blkid,uuid} \
+ --disable-quota \
+ --enable-${libtype}-shlibs \
+ $(tc-has-tls || echo --disable-tls) \
+ $(use_enable nls)
+}
+
+multilib_src_install() {
+ emake STRIP=: DESTDIR="${D}" install || die
+ multilib_is_native_abi && gen_usr_ldscript -a com_err ss
+ # configure doesn't have an option to disable static libs :/
+ use static-libs || find "${ED}" -name '*.a' -delete
+}
diff --git a/sys-libs/e2fsprogs-libs/files/e2fsprogs-libs-1.42.9-no-quota.patch b/sys-libs/e2fsprogs-libs/files/e2fsprogs-libs-1.42.9-no-quota.patch
new file mode 100644
index 000000000000..0b472806c777
--- /dev/null
+++ b/sys-libs/e2fsprogs-libs/files/e2fsprogs-libs-1.42.9-no-quota.patch
@@ -0,0 +1,36 @@
+From 947b1fe6c67b2399edd436c74408cb354c381e4a Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 31 Dec 2013 13:35:05 -0500
+Subject: [PATCH] fix build when quota is disabled
+
+Building e2fsprogs-libs with quota disabled fails:
+
+making all in lib/quota
+make[2]: Entering directory '.../lib/quota'
+make[2]: *** No rule to make target '.../lib/ext2fs/ext2_fs.h', needed by 'mkquota.o'. Stop.
+make[2]: *** Waiting for unfinished jobs....
+make[2]: Leaving directory '.../lib/quota'
+Makefile:380: recipe for target 'all-libs-recursive' failed
+make[1]: *** [all-libs-recursive] Error 1
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index f327d19..544ed02 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -13,7 +13,7 @@ INSTALL = @INSTALL@
+ @DEBUGFS_CMT@DEBUGFS_DIR= debugfs
+ @UUID_CMT@UUID_LIB_SUBDIR= lib/uuid
+ @BLKID_CMT@BLKID_LIB_SUBDIR= lib/blkid
+-QUOTA_LIB_SUBDIR= lib/quota
++@QUOTA_CMT@QUOTA_LIB_SUBDIR= lib/quota
+
+ LIB_SUBDIRS=lib/et lib/ss lib/e2p $(UUID_LIB_SUBDIR) lib/ext2fs $(BLKID_LIB_SUBDIR) $(QUOTA_LIB_SUBDIR) intl
+ PROG_SUBDIRS=e2fsck $(DEBUGFS_DIR) misc $(RESIZE_DIR) tests/progs po
+--
+1.8.4.3
+