summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2004-03-23 17:16:13 +0000
committerJon Portnoy <avenj@gentoo.org>2004-03-23 17:16:13 +0000
commit19928e77c27a13bf7c918aa3d66481e1a5c0ec25 (patch)
treedf7874eda01097161b5cac6fa05bd7e5dcc97c13 /sys-libs/gdbm
parentFix amd64 DEPEND construct (Manifest recommit) (diff)
downloadgentoo-2-19928e77c27a13bf7c918aa3d66481e1a5c0ec25.tar.gz
gentoo-2-19928e77c27a13bf7c918aa3d66481e1a5c0ec25.tar.bz2
gentoo-2-19928e77c27a13bf7c918aa3d66481e1a5c0ec25.zip
Fix amd64 conditionals. Run gnuconfig for everybody rather than a long list of individual archs.
Diffstat (limited to 'sys-libs/gdbm')
-rw-r--r--sys-libs/gdbm/ChangeLog8
-rw-r--r--sys-libs/gdbm/gdbm-1.8.0-r5.ebuild12
-rw-r--r--sys-libs/gdbm/gdbm-1.8.3.ebuild12
3 files changed, 17 insertions, 15 deletions
diff --git a/sys-libs/gdbm/ChangeLog b/sys-libs/gdbm/ChangeLog
index ba5f506eff2e..1d319803adf9 100644
--- a/sys-libs/gdbm/ChangeLog
+++ b/sys-libs/gdbm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/gdbm
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/ChangeLog,v 1.15 2004/03/01 01:32:18 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/ChangeLog,v 1.16 2004/03/23 17:16:13 avenj Exp $
+
+ 23 Mar 2004; Jon Portnoy <avenj@gentoo.org> gdbm-1.8.3.ebuild,
+ gdbm-1.8.0-r5.ebuild :
+ Updated ebuilds to remove invalid : in DEPEND for amd64 conditionals.
+ Also trashed all the use arch && gnuconfig_update junk in favor of
+ simply running gnuconfig_update for everybody.
29 Feb 2004; Tom Gall <tgall@gentoo.org> gdbm-1.8.3.ebuild,gdbm-1.8.0-r5.ebuild:
add gnuconfig_update for ppc64
diff --git a/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild b/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild
index 6f4800276367..7a8e2853df72 100644
--- a/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild
+++ b/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild,v 1.31 2004/03/02 16:36:09 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.0-r5.ebuild,v 1.32 2004/03/23 17:16:13 avenj Exp $
inherit gnuconfig eutils flag-o-matic
@@ -16,7 +16,9 @@ LICENSE="GPL-2"
KEYWORDS="amd64 x86 ppc sparc alpha mips hppa ia64 ppc64 s390"
DEPEND="virtual/glibc
- berkdb? ( amd64? sys-libs/db : =sys-libs/db-1.85-r1 )"
+ berkdb? (
+ amd64? sys-libs/db
+ !amd64? ( =sys-libs/db-1.85-r1 ) )"
RDEPEND="virtual/glibc"
@@ -24,11 +26,7 @@ src_unpack() {
unpack ${A}
cd ${WORKDIR}
epatch ${FILESDIR}/${PF}-gentoo.diff
- use alpha && gnuconfig_update
- use hppa && gnuconfig_update
- use amd64 && gnuconfig_update
- use ia64 && gnuconfig_update
- use ppc64 && gnuconfig_update
+ gnuconfig_update
}
src_compile() {
diff --git a/sys-libs/gdbm/gdbm-1.8.3.ebuild b/sys-libs/gdbm/gdbm-1.8.3.ebuild
index d1840fab1389..9941cda3218a 100644
--- a/sys-libs/gdbm/gdbm-1.8.3.ebuild
+++ b/sys-libs/gdbm/gdbm-1.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.3.ebuild,v 1.5 2004/03/01 01:32:18 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.3.ebuild,v 1.6 2004/03/23 17:16:13 avenj Exp $
inherit gnuconfig eutils flag-o-matic
@@ -16,16 +16,14 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~ia64 ppc64"
DEPEND="virtual/glibc
- berkdb? ( amd64? sys-libs/db : =sys-libs/db-1.85-r1 )"
+ berkdb? (
+ amd64? ( sys-libs/db )
+ !amd64? ( =sys-libs/db-1.85-r1 ) )"
RDEPEND="virtual/glibc"
src_compile() {
- use alpha && gnuconfig_update
- use hppa && gnuconfig_update
- use amd64 && gnuconfig_update
- use ia64 && gnuconfig_update
- use ppc64 && gnuconfig_update
+ gnuconfig_update
if [ ! `is-flag "-fomit-frame-pointer"` ]
then