summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-01-17 23:51:59 +0000
committerMike Frysinger <vapier@gentoo.org>2012-01-17 23:51:59 +0000
commit2f8717e78b7c19f6e1d0d664278bbbdb31bd9b6b (patch)
treee6831305a4c39895a5a95b89b115dd08287439e9 /sys-libs/glibc/glibc-2.15.ebuild
parentImport of best_in_place gem. (diff)
downloadgentoo-2-2f8717e78b7c19f6e1d0d664278bbbdb31bd9b6b.tar.gz
gentoo-2-2f8717e78b7c19f6e1d0d664278bbbdb31bd9b6b.tar.bz2
gentoo-2-2f8717e78b7c19f6e1d0d664278bbbdb31bd9b6b.zip
Drop gettext dep (cannot think of a reason for it), and drop USE=nls since the --disable-nls flag has not been in the glibc source for quite some time #398981 by Maxim Kammerer.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/glibc/glibc-2.15.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.15.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-2.15.ebuild b/sys-libs/glibc/glibc-2.15.ebuild
index be463a2d90bf..ef739b6b7c2f 100644
--- a/sys-libs/glibc/glibc-2.15.ebuild
+++ b/sys-libs/glibc/glibc-2.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.15.ebuild,v 1.3 2012/01/16 07:56:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.15.ebuild,v 1.4 2012/01/17 23:51:59 vapier Exp $
inherit eutils versionator libtool toolchain-funcs flag-o-matic gnuconfig multilib
@@ -39,7 +39,7 @@ LT_VER="" # version of linuxthreads addon
NPTL_KERN_VER=${NPTL_KERN_VER:-"2.6.9"} # min kernel version nptl requires
#LT_KERN_VER=${LT_KERN_VER:-"2.4.1"} # min kernel version linuxthreads requires
-IUSE="debug gd glibc-omitfp hardened multilib nls selinux profile vanilla crosscompile_opts_headers-only ${LT_VER:+glibc-compat20 nptl linuxthreads}"
+IUSE="debug gd glibc-omitfp hardened multilib selinux profile vanilla crosscompile_opts_headers-only ${LT_VER:+glibc-compat20 nptl linuxthreads}"
[[ -n ${RELEASE_VER} ]] && S=${WORKDIR}/glibc-${RELEASE_VER}${SNAP_VER:+-${SNAP_VER}}
# Here's how the cross-compile logic breaks down ...
@@ -97,13 +97,11 @@ DEPEND=">=sys-devel/gcc-3.4.4
${LT_VER:+nptl? (} >=sys-kernel/linux-headers-${NPTL_KERN_VER} ${LT_VER:+)}
>=app-misc/pax-utils-0.1.10
virtual/os-headers
- nls? ( sys-devel/gettext )
!<sys-apps/sandbox-1.2.18.1-r2
!<sys-apps/portage-2.1.2
!<sys-devel/patch-2.6
selinux? ( sys-libs/libselinux )"
RDEPEND="!sys-kernel/ps3-sources
- nls? ( sys-devel/gettext )
selinux? ( sys-libs/libselinux )"
if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then