summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-07-11 15:07:17 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-07-11 15:07:17 +0000
commitb5fda2354ed251b8a858bdf8637089d3e19159d9 (patch)
tree00c6968244334519d897ba13a492520c685d298a /sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
parentRemove old versions. (diff)
downloadgentoo-2-b5fda2354ed251b8a858bdf8637089d3e19159d9.tar.gz
gentoo-2-b5fda2354ed251b8a858bdf8637089d3e19159d9.tar.bz2
gentoo-2-b5fda2354ed251b8a858bdf8637089d3e19159d9.zip
Update to support selinux USE flag (blame spb).
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index e05b9d2f6439..7ca2b58c04d5 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.16 2005/07/09 21:11:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.17 2005/07/11 15:07:17 azarah Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -51,7 +51,7 @@ LICENSE="LGPL-2"
&& SLOT="${CTARGET}-2.2" \
|| SLOT="2.2"
KEYWORDS="alpha amd64 -hppa ia64 ~mips ppc ppc64 ~sparc x86"
-IUSE="build erandom hardened multilib nls nomalloccheck nptl nptlonly pic userlocales"
+IUSE="build erandom hardened multilib nls nomalloccheck nptl nptlonly pic userlocales selinux"
RESTRICT="nostrip multilib-pkg-force" # we'll handle stripping ourself #46186
# We need new cleanup attribute support from gcc for NPTL among things ...
@@ -63,9 +63,11 @@ DEPEND=">=sys-devel/gcc-3.2.3-r1
>=sys-devel/binutils-2.14.90.0.6-r1
virtual/os-headers
nptl? ( >=sys-kernel/linux-headers-2.6.5 )
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+ selinux? ( !build? ( sys-libs/libselinux ) )"
RDEPEND="virtual/os-headers
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+ selinux? ( !build? ( sys-libs/libselinux ) )"
# until amd64's 2004.3 is purged out of existence
PDEPEND="amd64? ( multilib? ( app-emulation/emul-linux-x86-glibc ) )"
@@ -687,6 +689,12 @@ glibc_do_configure() {
die "invalid pthread option"
fi
+ if ! use build && use selinux; then
+ myconf="${myconf} --with-selinux"
+ else
+ myconf="${myconf} --without-selinux"
+ fi
+
# Who knows if this works :)
[[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
myconf="${myconf} --without-cvs