summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-17 00:46:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-17 00:46:54 +0000
commit1c9081f17363652994a20cb1f8cade68adb760c9 (patch)
tree4a54c546c512d459b826fdcc163b35cb83230508 /sys-libs/glibc/glibc-2.3.5-r3.ebuild
parentKevin F. Quinn: fix PaX support #115100. (diff)
downloadgentoo-2-1c9081f17363652994a20cb1f8cade68adb760c9.tar.gz
gentoo-2-1c9081f17363652994a20cb1f8cade68adb760c9.tar.bz2
gentoo-2-1c9081f17363652994a20cb1f8cade68adb760c9.zip
fix header searching when emerging into an empty ROOT #114923
(Portage version: 2.0.53)
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.5-r3.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.3.5-r3.ebuild b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
index 5452ed2086db..1f7ca9a0ba2c 100644
--- a/sys-libs/glibc/glibc-2.3.5-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.9 2005/12/03 00:55:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.10 2005/12/17 00:46:54 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -909,6 +909,9 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -916,7 +919,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${ROOT}$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info