summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-08-12 05:44:34 +0000
committerMike Frysinger <vapier@gentoo.org>2012-08-12 05:44:34 +0000
commit183538e41e7aff347e7a7bee1173e2264c84d3c8 (patch)
tree98177f7086881e4ad28f361fb1b7f98b738c00ae /sys-libs/glibc
parentAdd s390/sh love. (diff)
downloadgentoo-2-183538e41e7aff347e7a7bee1173e2264c84d3c8.tar.gz
gentoo-2-183538e41e7aff347e7a7bee1173e2264c84d3c8.tar.bz2
gentoo-2-183538e41e7aff347e7a7bee1173e2264c84d3c8.zip
Do not use the -lgcc_eh hack with glibc-2.17+ since its been addressed upstream.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/files/eblits/src_unpack.eblit12
2 files changed, 13 insertions, 5 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 05d47b04b9b3..a572af31c4e3 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,5 +1,9 @@
# ChangeLog for sys-libs/glibc
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.876 2012/08/12 04:45:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.877 2012/08/12 05:44:34 vapier Exp $
+
+ 12 Aug 2012; Mike Frysinger <vapier@gentoo.org> files/eblits/src_unpack.eblit:
+ Do not use the -lgcc_eh hack with glibc-2.17+ since its been addressed
+ upstream.
12 Aug 2012; Mike Frysinger <vapier@gentoo.org> glibc-2.16.0.ebuild:
Add alpha/arm keywords since it builds for both.
diff --git a/sys-libs/glibc/files/eblits/src_unpack.eblit b/sys-libs/glibc/files/eblits/src_unpack.eblit
index 50500915c4bb..872b6aee766a 100644
--- a/sys-libs/glibc/files/eblits/src_unpack.eblit
+++ b/sys-libs/glibc/files/eblits/src_unpack.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_unpack.eblit,v 1.16 2012/02/16 00:27:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_unpack.eblit,v 1.17 2012/08/12 05:44:34 vapier Exp $
int_to_KV() {
local version=$1 major minor micro
@@ -171,9 +171,13 @@ eblit-glibc-src_unpack() {
# static C-Only gcc, -lgcc_eh doesn't exist.
# http://sources.redhat.com/ml/libc-alpha/2003-09/msg00100.html
# http://sourceware.org/ml/libc-alpha/2005-02/msg00042.html
- echo 'int main(){}' > "${T}"/gcc_eh_test.c
- if ! $(tc-getCC ${CTARGET}) "${T}"/gcc_eh_test.c -lgcc_eh 2>/dev/null ; then
- sed -i -e 's:-lgcc_eh::' Makeconfig || die "sed gcc_eh"
+ # But! Finally fixed in recent versions:
+ # http://sourceware.org/ml/libc-alpha/2012-05/msg01865.html
+ if version_is_at_least 2.17 ${PV} ; then
+ echo 'int main(){}' > "${T}"/gcc_eh_test.c
+ if ! $(tc-getCC ${CTARGET}) "${T}"/gcc_eh_test.c -lgcc_eh 2>/dev/null ; then
+ sed -i -e 's:-lgcc_eh::' Makeconfig || die "sed gcc_eh"
+ fi
fi
cd "${WORKDIR}"