summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-29 16:39:23 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-29 16:39:23 +0000
commit410c5eae381263be1e2b01bfa996cde6bab4fd03 (patch)
treefee051b3ae9992ae1fde889e0b26046e1e1cefb8 /sys-libs/glibc
parentVersion bump. (diff)
downloadgentoo-2-410c5eae381263be1e2b01bfa996cde6bab4fd03.tar.gz
gentoo-2-410c5eae381263be1e2b01bfa996cde6bab4fd03.tar.bz2
gentoo-2-410c5eae381263be1e2b01bfa996cde6bab4fd03.zip
Short circuit header building in pkg testing and ABI recursion. (2.6.1 fix #229923)
(Portage version: 2.2_rc1/cvs/Linux 2.6.25 x86_64)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog5
-rw-r--r--sys-libs/glibc/files/eblits/src_install-2.6.eblit13
2 files changed, 10 insertions, 8 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 841f70933388..2a136b82f28f 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.588 2008/06/23 22:01:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.589 2008/06/29 16:39:22 vapier Exp $
23 Jun 2008; Mike Frysinger <vapier@gentoo.org>
files/eblits/src_compile.eblit:
@@ -8,7 +8,8 @@
23 Jun 2008; Mike Frysinger <vapier@gentoo.org>
files/eblits/src_compile.eblit, files/eblits/src_install.eblit,
- glibc-2.6.1.ebuild, glibc-2.7-r2.ebuild, glibc-2.8_p20080602.ebuild:
+ files/eblits/src_install-2.6.eblit, glibc-2.6.1.ebuild,
+ glibc-2.7-r2.ebuild, glibc-2.8_p20080602.ebuild:
Short circuit header building in pkg testing and ABI recursion.
23 Jun 2008; Mike Frysinger <vapier@gentoo.org> glibc-2.6.1.ebuild,
diff --git a/sys-libs/glibc/files/eblits/src_install-2.6.eblit b/sys-libs/glibc/files/eblits/src_install-2.6.eblit
index 873582ece1d0..15bbf31092d6 100644
--- a/sys-libs/glibc/files/eblits/src_install-2.6.eblit
+++ b/sys-libs/glibc/files/eblits/src_install-2.6.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_install-2.6.eblit,v 1.1 2008/03/24 19:45:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_install-2.6.eblit,v 1.2 2008/06/29 16:39:23 vapier Exp $
toolchain-glibc_src_install() {
# These should not be set, else the
@@ -217,6 +217,11 @@ src_strip() {
}
eblit-glibc-src_install() {
+ if just_headers ; then
+ toolchain-glibc_headers_install
+ return
+ fi
+
setup_env
if [[ -z ${OABI} ]] ; then
@@ -240,10 +245,6 @@ eblit-glibc-src_install() {
fi
fi
- if just_headers ; then
- toolchain-glibc_headers_install
- else
- toolchain-glibc_src_install
- fi
+ toolchain-glibc_src_install
[[ -z ${OABI} ]] && src_strip
}