summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-24 00:41:36 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-24 00:41:36 +0000
commit4eef29e3d4ef884331188e5e1ff551be49a11538 (patch)
treeaa469b408c1513d17ec0e8ac8b619c0f1aded816 /sys-libs/glibc
parentStable on amd64. Bug #120069. (diff)
downloadgentoo-2-4eef29e3d4ef884331188e5e1ff551be49a11538.tar.gz
gentoo-2-4eef29e3d4ef884331188e5e1ff551be49a11538.tar.bz2
gentoo-2-4eef29e3d4ef884331188e5e1ff551be49a11538.zip
Define alt_build_headers for the --with-headers option and for checking for nptl support #114923.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog8
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r1.ebuild15
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r2.ebuild15
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r3.ebuild15
-rw-r--r--sys-libs/glibc/glibc-2.3.5.ebuild17
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r1.ebuild15
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r2.ebuild15
-rw-r--r--sys-libs/glibc/glibc-2.3.6.ebuild15
8 files changed, 78 insertions, 37 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 130c70063623..560bf457c0bd 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.424 2006/01/18 21:09:10 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.425 2006/01/24 00:41:36 vapier Exp $
+
+ 24 Jan 2006; Mike Frysinger <vapier@gentoo.org> glibc-2.3.5.ebuild,
+ glibc-2.3.5-r1.ebuild, glibc-2.3.5-r2.ebuild, glibc-2.3.5-r3.ebuild,
+ glibc-2.3.6.ebuild, glibc-2.3.6-r1.ebuild, glibc-2.3.6-r2.ebuild:
+ Define alt_build_headers for the --with-headers option and for checking for
+ nptl support #114923.
18 Jan 2006; Mark Loeser <halcy0n@gentoo.org>
files/2.3.5/glibc-2.3.5-propolice-guard-functions.patch,
diff --git a/sys-libs/glibc/glibc-2.3.5-r1.ebuild b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
index 8e46a9edf3be..c3bfe6326d01 100644
--- a/sys-libs/glibc/glibc-2.3.5-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.49 2006/01/14 20:12:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.50 2006/01/24 00:41:36 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -567,6 +567,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}${headersloc}
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if is_crosscompile ; then
@@ -665,7 +672,7 @@ setup_flags() {
}
check_kheader_version() {
- local header="${ROOT}$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[[ -z $1 ]] && return 1
@@ -881,8 +888,6 @@ glibc_do_configure() {
fi
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -890,7 +895,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.5-r2.ebuild b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
index de878b4575ee..aad9adf4caef 100644
--- a/sys-libs/glibc/glibc-2.3.5-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.24 2006/01/14 20:12:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.25 2006/01/24 00:41:36 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -555,6 +555,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}${headersloc}
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if is_crosscompile ; then
@@ -672,7 +679,7 @@ setup_flags() {
}
check_kheader_version() {
- local header="${ROOT}$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[[ -z $1 ]] && return 1
@@ -888,8 +895,6 @@ glibc_do_configure() {
fi
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -897,7 +902,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.5-r3.ebuild b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
index 4f3f97616db4..83daa0420b77 100644
--- a/sys-libs/glibc/glibc-2.3.5-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.15 2006/01/15 23:36:30 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.16 2006/01/24 00:41:36 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -560,6 +560,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}${headersloc}
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if is_crosscompile ; then
@@ -677,7 +684,7 @@ setup_flags() {
}
check_kheader_version() {
- local header="${ROOT}$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[[ -z $1 ]] && return 1
@@ -893,8 +900,6 @@ glibc_do_configure() {
fi
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -902,7 +907,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.5.ebuild b/sys-libs/glibc/glibc-2.3.5.ebuild
index 2135ff64f1b7..8acb461ec8b2 100644
--- a/sys-libs/glibc/glibc-2.3.5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.50 2005/12/17 00:46:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.51 2006/01/24 00:41:36 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -593,6 +593,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}${headersloc}
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if is_crosscompile ; then
@@ -695,7 +702,7 @@ setup_flags() {
}
check_kheader_version() {
- local header="${ROOT}$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[[ -z $1 ]] && return 1
@@ -923,8 +930,6 @@ glibc_do_configure() {
fi
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -932,7 +937,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
--disable-profile
--without-gd
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.6-r1.ebuild b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
index ef0b27d63b42..5ce7108b87e7 100644
--- a/sys-libs/glibc/glibc-2.3.6-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.13 2006/01/18 21:09:11 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.14 2006/01/24 00:41:36 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -258,8 +258,6 @@ toolchain-glibc_headers_compile() {
cd "${GBUILDDIR}"
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
local myconf="--disable-sanity-checks --enable-hacker-mode"
myconf="${myconf}
--enable-add-ons=linuxthreads
@@ -267,7 +265,7 @@ toolchain-glibc_headers_compile() {
--enable-bind-now
--build=${CBUILD_OPT:-${CBUILD}}
--host=${CTARGET_OPT:-${CTARGET}}
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
@@ -618,6 +616,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}${headersloc}
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if is_crosscompile ; then
@@ -735,7 +740,7 @@ setup_flags() {
}
check_kheader_version() {
- local header="${ROOT}$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[[ -z $1 ]] && return 1
diff --git a/sys-libs/glibc/glibc-2.3.6-r2.ebuild b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
index 059a7f101660..821349f3cfae 100644
--- a/sys-libs/glibc/glibc-2.3.6-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.10 2006/01/18 21:09:11 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.11 2006/01/24 00:41:36 vapier Exp $
# TODO:
# - fix warning from glibc build system:
@@ -626,6 +626,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}${headersloc}
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if is_crosscompile ; then
@@ -743,7 +750,7 @@ setup_flags() {
}
check_kheader_version() {
- local header="${ROOT}$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[[ -z $1 ]] && return 1
@@ -953,8 +960,6 @@ glibc_do_configure() {
fi
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -962,7 +967,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.6.ebuild b/sys-libs/glibc/glibc-2.3.6.ebuild
index 9752af37c910..e7562d2ad3b3 100644
--- a/sys-libs/glibc/glibc-2.3.6.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6.ebuild,v 1.14 2006/01/18 21:09:11 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6.ebuild,v 1.15 2006/01/24 00:41:36 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -573,6 +573,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}${headersloc}
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if is_crosscompile ; then
@@ -690,7 +697,7 @@ setup_flags() {
}
check_kheader_version() {
- local header="${ROOT}$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[[ -z $1 ]] && return 1
@@ -906,8 +913,6 @@ glibc_do_configure() {
fi
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -915,7 +920,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info