summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-30 02:08:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-30 02:08:08 +0000
commit6f18f9dc4cadd95447e1902eeade1bc2863a1a92 (patch)
treeba44a9b2938e0acb559ddffa30ec80322729243f /sys-libs/glibc
parentVersion bump, bug #104132. Initially in package.mask, needs testing on AFS an... (diff)
downloadgentoo-2-6f18f9dc4cadd95447e1902eeade1bc2863a1a92.tar.gz
gentoo-2-6f18f9dc4cadd95447e1902eeade1bc2863a1a92.tar.bz2
gentoo-2-6f18f9dc4cadd95447e1902eeade1bc2863a1a92.zip
tweak cross-compiling glibc --with-headers option
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r1.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.3.5.20050421.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.5.20050722.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.5.ebuild4
4 files changed, 9 insertions, 9 deletions
diff --git a/sys-libs/glibc/glibc-2.3.5-r1.ebuild b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
index 2c8705c65793..5b4562a26edc 100644
--- a/sys-libs/glibc/glibc-2.3.5-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.22 2005/08/27 17:39:05 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.23 2005/08/30 02:08:08 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -16,7 +16,7 @@
# CHOST = CTARGET - install into /
# CHOST != CTARGET - install into /usr/CTARGET/
-KEYWORDS="amd64 ~ppc64 sh ~sparc x86 ~mips"
+KEYWORDS="amd64 m68k ~mips ~ppc64 sh ~sparc x86"
BRANCH_UPDATE=""
@@ -896,7 +896,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=$(alt_headers)
+ --with-headers=${ROOT}$(alt_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
index 11a030578e2b..975cc6078801 100644
--- a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.31 2005/08/17 00:36:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.32 2005/08/30 02:08:08 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -894,7 +894,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=$(alt_headers)
+ --with-headers=${ROOT}$(alt_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.5.20050722.ebuild b/sys-libs/glibc/glibc-2.3.5.20050722.ebuild
index db85b609622b..a4689c99a62d 100644
--- a/sys-libs/glibc/glibc-2.3.5.20050722.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.20050722.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050722.ebuild,v 1.10 2005/08/21 04:25:11 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050722.ebuild,v 1.11 2005/08/30 02:08:08 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -902,7 +902,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=$(alt_headers)
+ --with-headers=${ROOT}$(alt_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.5.ebuild b/sys-libs/glibc/glibc-2.3.5.ebuild
index f875c536b2a9..1a1d4b93e36c 100644
--- a/sys-libs/glibc/glibc-2.3.5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.42 2005/08/27 17:39:05 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.43 2005/08/30 02:08:08 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -922,7 +922,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
--disable-profile
--without-gd
- --with-headers=$(alt_headers)
+ --with-headers=${ROOT}$(alt_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info