summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-06 18:23:07 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-06 18:23:07 +0000
commita618380e0a6584ed33b062df5d1d92816e5fe782 (patch)
tree97c792208065be318b8fb6a5f4ebe6c835933735 /sys-libs/glibc
parentStable on ppc wrt bug 142466 (diff)
downloadgentoo-2-a618380e0a6584ed33b062df5d1d92816e5fe782.tar.gz
gentoo-2-a618380e0a6584ed33b062df5d1d92816e5fe782.tar.bz2
gentoo-2-a618380e0a6584ed33b062df5d1d92816e5fe782.zip
backport some stuff from glibc-2.5 ebuild
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r5.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r5.ebuild b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
index e3378f9e0dd8..f486d8153ec2 100644
--- a/sys-libs/glibc/glibc-2.3.6-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.3 2006/10/06 16:14:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.4 2006/10/06 18:23:07 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -460,10 +460,8 @@ toolchain-glibc_src_install() {
# Install misc network config files
insinto /etc
- doins "${FILESDIR}"/nscd.conf
- doins "${FILESDIR}"/nsswitch.conf
- doins "${FILESDIR}"/2.3.6/host.conf
- doinitd "${FILESDIR}"/nscd
+ doins "${WORKDIR}"/extra/etc/*.conf || die
+ doinitd "${WORKDIR}"/extra/etc/nscd || die
cd "${S}"
dodoc BUGS ChangeLog* CONFORMANCE FAQ INTERFACE NEWS NOTES PROJECTS README*
@@ -540,7 +538,9 @@ toolchain-glibc_pkg_postinst() {
ewarn "Generating all locales; edit /etc/locale.gen to save time/space"
locale_list="${ROOT}usr/share/i18n/SUPPORTED"
fi
- locale-gen --config "${locale_list}"
+ local x jobs
+ for x in ${MAKEOPTS} ; do [[ ${x} == -j* ]] && jobs=${x#-j} ; done
+ locale-gen -j ${jobs} --config "${locale_list}"
fi
echo