summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-12-30 23:53:45 +0000
committerMike Gilbert <floppym@gentoo.org>2012-12-30 23:53:45 +0000
commitc9f7fe8856b1f175c1ce248fbf0b62af0131b1bb (patch)
treedd2e750cd78d2aa2201c113066a56fca036fb8d8 /sys-libs/gpm
parentfix collision with dev-util/ninja (bug #436804) (diff)
downloadgentoo-2-c9f7fe8856b1f175c1ce248fbf0b62af0131b1bb.tar.gz
gentoo-2-c9f7fe8856b1f175c1ce248fbf0b62af0131b1bb.tar.bz2
gentoo-2-c9f7fe8856b1f175c1ce248fbf0b62af0131b1bb.zip
Install systemd unit taken from Fedora, bug 449350.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/ChangeLog8
-rw-r--r--sys-libs/gpm/files/gpm.service12
-rw-r--r--sys-libs/gpm/gpm-1.20.7-r1.ebuild65
3 files changed, 84 insertions, 1 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index 11bd93d1caa2..1557370da72d 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/gpm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.91 2012/10/28 11:35:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.92 2012/12/30 23:53:45 floppym Exp $
+
+*gpm-1.20.7-r1 (30 Dec 2012)
+
+ 30 Dec 2012; Mike Gilbert <floppym@gentoo.org> +files/gpm.service,
+ +gpm-1.20.7-r1.ebuild:
+ Install systemd unit taken from Fedora, bug 449350.
*gpm-1.20.7 (28 Oct 2012)
diff --git a/sys-libs/gpm/files/gpm.service b/sys-libs/gpm/files/gpm.service
new file mode 100644
index 000000000000..966ad80060fe
--- /dev/null
+++ b/sys-libs/gpm/files/gpm.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Console Mouse manager
+After=syslog.target
+
+[Service]
+ExecStart=/usr/sbin/gpm -m /dev/input/mice -t exps2
+StandardOutput=syslog
+Type=forking
+PIDFile=/var/run/gpm.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-libs/gpm/gpm-1.20.7-r1.ebuild b/sys-libs/gpm/gpm-1.20.7-r1.ebuild
new file mode 100644
index 000000000000..e02b91722246
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.20.7-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.7-r1.ebuild,v 1.1 2012/12/30 23:53:45 floppym Exp $
+
+# emacs support disabled due to #99533 #335900
+
+EAPI="4"
+
+inherit eutils systemd toolchain-funcs autotools
+
+DESCRIPTION="Console-based mouse driver"
+HOMEPAGE="http://www.nico.schottelius.org/software/gpm/"
+SRC_URI="http://www.nico.schottelius.org/software/${PN}/archives/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux static-libs"
+
+RDEPEND="sys-libs/ncurses
+ selinux? ( sec-policy/selinux-gpm )"
+DEPEND="sys-libs/ncurses
+ app-arch/xz-utils
+ virtual/yacc"
+
+src_prepare() {
+ # fix ABI values
+ sed -i \
+ -e '/^abi_lev=/s:=.*:=1:' \
+ -e '/^abi_age=/s:=.*:=20:' \
+ configure.ac.footer || die
+ sed -i -e '/ACLOCAL/,$d' autogen.sh || die
+ ./autogen.sh
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/gpm \
+ $(use_enable static-libs static) \
+ emacs=/bin/false
+}
+
+src_compile() {
+ # make sure nothing compiled is left
+ emake clean
+ emake EMACS=:
+}
+
+src_install() {
+ emake install DESTDIR="${D}" EMACS=: ELISP=""
+
+ dosym libgpm.so.1 /usr/$(get_libdir)/libgpm.so
+ gen_usr_ldscript -a gpm
+
+ insinto /etc/gpm
+ doins conf/gpm-*.conf
+
+ dodoc README TODO
+ dodoc doc/Announce doc/FAQ doc/README*
+
+ newinitd "${FILESDIR}"/gpm.rc6-2 gpm
+ newconfd "${FILESDIR}"/gpm.conf.d gpm
+ systemd_dounit "${FILESDIR}"/gpm.service
+}