summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-11 23:56:06 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-11 23:56:06 +0000
commit6f9491b62c9cf2883f9e377dc11c516351de3c3e (patch)
tree1d2c1946733b974555d040be188ecc4a33b1941c /sys-libs/gwenhywfar
parentFix dodir call, Comment #22 bug 266937 (diff)
downloadgentoo-2-6f9491b62c9cf2883f9e377dc11c516351de3c3e.tar.gz
gentoo-2-6f9491b62c9cf2883f9e377dc11c516351de3c3e.tar.bz2
gentoo-2-6f9491b62c9cf2883f9e377dc11c516351de3c3e.zip
Bump, closes #279933
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/gwenhywfar')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-3.10.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 9670924deb30..714b45315452 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.70 2009/08/02 15:22:19 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.71 2009/09/11 23:56:06 patrick Exp $
+
+*gwenhywfar-3.10.1 (11 Sep 2009)
+
+ 11 Sep 2009; Patrick Lauer <patrick@gentoo.org> +gwenhywfar-3.10.1.ebuild:
+ Bump, closes #279933
02 Aug 2009; Markus Meier <maekke@gentoo.org> gwenhywfar-3.8.2.ebuild:
amd64 stable, bug #275705
diff --git a/sys-libs/gwenhywfar/gwenhywfar-3.10.1.ebuild b/sys-libs/gwenhywfar/gwenhywfar-3.10.1.ebuild
new file mode 100644
index 000000000000..171af8e564ed
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-3.10.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-3.10.1.ebuild,v 1.1 2009/09/11 23:56:06 patrick Exp $
+
+EAPI="2"
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="http://www2.aquamaniac.de/sites/download/download.php?package=01&release=27&file=01&dummy=${P}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug ssl doc"
+
+RDEPEND="ssl? ( net-libs/gnutls )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf --enable-visibility \
+ $(use_enable ssl) \
+ $(use_enable debug) \
+ $(use_enable doc full-doc) \
+ --with-docpath="/usr/share/doc/${PF}/apidoc" || die "configure failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc ; then
+ emake srcdoc || die "emake failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README* AUTHORS ChangeLog TODO || die "dodoc failed"
+ if use doc ; then
+ make DESTDIR="${D}" install-srcdoc || die "install doc failed"
+ fi
+ find "${D}" -name '*.la' -delete
+}