summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2007-08-01 10:16:38 +0000
committerHanno Böck <hanno@gentoo.org>2007-08-01 10:16:38 +0000
commitf9b5a4f567c6285c1c7b4bfe5c05f435ed8c3e4c (patch)
tree4ac3989e460388b81e67142155824e876e85f3f0 /sys-libs/gwenhywfar
parentusing userland_Darwin is a bad idea, use CHOST comparison instead (diff)
downloadgentoo-2-f9b5a4f567c6285c1c7b4bfe5c05f435ed8c3e4c.tar.gz
gentoo-2-f9b5a4f567c6285c1c7b4bfe5c05f435ed8c3e4c.tar.bz2
gentoo-2-f9b5a4f567c6285c1c7b4bfe5c05f435ed8c3e4c.zip
gwenhywfar version bump
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'sys-libs/gwenhywfar')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-2.6.13
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild38
3 files changed, 47 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index cd6d9959151f..c92c5eb047a3 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.44 2007/07/25 18:23:12 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.45 2007/08/01 10:16:38 hanno Exp $
+
+*gwenhywfar-2.6.1 (01 Aug 2007)
+
+ 01 Aug 2007; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-2.6.1.ebuild:
+ Version bump.
25 Jul 2007; Guy Martin <gmsoft@gentoo.org> gwenhywfar-2.5.4.ebuild:
Added ~hppa to KEYWORDS.
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-2.6.1 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-2.6.1
new file mode 100644
index 000000000000..52ef6baa2c1a
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-2.6.1
@@ -0,0 +1,3 @@
+MD5 2cf970cd9d966e95c4254fc89530eca7 gwenhywfar-2.6.1.tar.gz 1201441
+RMD160 dbb9c8e93e37f2524a58fefdf5be94548d505ce6 gwenhywfar-2.6.1.tar.gz 1201441
+SHA256 82f3c663cc19a7e22a7e5fe8290fa8792b3ae36f944abfc7720ddc29c4de541a gwenhywfar-2.6.1.tar.gz 1201441
diff --git a/sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild b/sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild
new file mode 100644
index 000000000000..d77bc93e5a0c
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild,v 1.1 2007/08/01 10:16:38 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="debug ssl doc ncurses"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )
+ ncurses? ( sys-libs/ncurses )"
+
+src_compile() {
+ econf \
+ $(use_enable ssl) \
+ $(use_enable debug) \
+ $(use_enable doc full-doc) \
+ $(use_enable ncurses gwenui) \
+ --with-docpath=/usr/share/doc/${PF}/apidoc || die "configure failed"
+ emake || die "emake failed"
+ if use doc ; then
+ emake srcdoc || die "emake failed"
+ fi
+}
+
+src_install() {
+ einstall || die
+ dodoc README* AUTHORS ChangeLog TODO || die
+ if use doc ; then
+ make DESTDIR="${D}" install-srcdoc || die "make isntall-srcdoc failed"
+ fi
+}