summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamien Krotkine <dams@gentoo.org>2002-12-01 19:02:36 +0000
committerDamien Krotkine <dams@gentoo.org>2002-12-01 19:02:36 +0000
commit08dde208b3cecccf00a71887ee000a468411b653 (patch)
tree54829f2542289f237fa7716b4ab2a09a922ce9c1 /sys-libs/ldetect
parentmjc1 !=mjc2 (diff)
downloadgentoo-2-08dde208b3cecccf00a71887ee000a468411b653.tar.gz
gentoo-2-08dde208b3cecccf00a71887ee000a468411b653.tar.bz2
gentoo-2-08dde208b3cecccf00a71887ee000a468411b653.zip
added ldetect, lightware hardware detection
Diffstat (limited to 'sys-libs/ldetect')
-rw-r--r--sys-libs/ldetect/ChangeLog9
-rw-r--r--sys-libs/ldetect/files/ldetect-0.4.6.patch11
-rw-r--r--sys-libs/ldetect/ldetect-0.4.6.ebuild61
3 files changed, 81 insertions, 0 deletions
diff --git a/sys-libs/ldetect/ChangeLog b/sys-libs/ldetect/ChangeLog
new file mode 100644
index 000000000000..25372e35b83d
--- /dev/null
+++ b/sys-libs/ldetect/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-libs/ldetect
+# Copyright 2002 Damien Krotkine; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ldetect/ChangeLog,v 1.1 2002/12/01 19:02:36 dams Exp $
+
+*ldetect-0.4.6 (1 Dec 2002)
+
+ 1 Dec 2002; <dams@gentoo.org> Common-0.4.6.ebuild:
+
+ Initial version.
diff --git a/sys-libs/ldetect/files/ldetect-0.4.6.patch b/sys-libs/ldetect/files/ldetect-0.4.6.patch
new file mode 100644
index 000000000000..c880dbc59f83
--- /dev/null
+++ b/sys-libs/ldetect/files/ldetect-0.4.6.patch
@@ -0,0 +1,11 @@
+--- ldetect/Makefile.old 2002-12-01 16:37:18.000000000 +0100
++++ ldetect/Makefile 2002-12-01 16:37:29.000000000 +0100
+@@ -22,7 +22,7 @@
+ perl generate_pciclass.pl $^ > $@
+ chmod a-w $@
+
+-usbclass.c: /usr/share/usb.ids
++usbclass.c: /usr/share/misc/usb.ids
+ rm -f $@
+ perl generate_usbclass.pl $^ > $@
+ chmod a-w $@
diff --git a/sys-libs/ldetect/ldetect-0.4.6.ebuild b/sys-libs/ldetect/ldetect-0.4.6.ebuild
new file mode 100644
index 000000000000..c93077af156d
--- /dev/null
+++ b/sys-libs/ldetect/ldetect-0.4.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2002 damien krotkine <dams@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ldetect/ldetect-0.4.6.ebuild,v 1.1 2002/12/01 19:02:36 dams Exp $
+
+ECVS_ANON="no"
+ECVS_USER="anoncvs"
+ECVS_SERVER="cvs.mandrakesoft.com:/cooker"
+ECVS_MODULE="soft/ldetect"
+ECVS_PASS="cvs"
+ECVS_CVS_OPTIONS="-dP"
+
+#inherit perl-module
+inherit cvs
+
+S=${WORKDIR}/${ECVS_MODULE}
+DESCRIPTION="Light hardware detection library. The hardware device lists provided by this package are used as lookup table to get hardware autodetection"
+HOMEPAGE="http://cvs.mandrakesoft.com/cgi-bin/cvsweb.cgi/soft/ldetect/"
+SRC_URI=""
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~x86"
+
+#DEPEND="${DEPEND}
+# >=dev-lang/ocaml"
+
+#This patch may or may not be backwards compatible with perl-5.6.1
+#Add gaurd as necessary...
+
+#src_unpack() {
+# echo " ***** pouet $PWD";
+# echo "filesdir : ${FILESDIR}"
+# #unpack ${A}
+# echo " pwd : $PWD"
+# patch -p0 <${FILESDIR}/Common-1.0.4.patch || die
+#}
+
+src_compile() {
+ cd ../../ldetect;
+ echo " ------- pwd : $PWD"
+ patch -p1 <${FILESDIR}/ldetect-0.4.6.patch || die
+ echo "compile in ${PWD}";
+ make clean;
+ make
+ #perl-module_src_prep;
+ #perl-module_src_compile;
+}
+
+src_install() {
+ cd ../../ldetect;
+ echo " ----------- install in ${PWD}"
+ make prefix=${D}/usr install
+}
+
+src_prep() {
+ SRC_PREP="yes"
+ cd ../../perl-MDK-Common
+ echo "prep in ${PWD}";
+}
+
+