summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-16 16:35:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-16 16:35:44 +0000
commit050322effe5a62ed6ce1985d861fffbaaffc103e (patch)
treef8d776abafb305e1c6d7e5077458c18ec4ca27a9 /sys-libs/libcap/files
parentSome homegrown crash and bugfixes (diff)
downloadgentoo-2-050322effe5a62ed6ce1985d861fffbaaffc103e.tar.gz
gentoo-2-050322effe5a62ed6ce1985d861fffbaaffc103e.tar.bz2
gentoo-2-050322effe5a62ed6ce1985d861fffbaaffc103e.zip
remove -r5, it has no point
Diffstat (limited to 'sys-libs/libcap/files')
-rw-r--r--sys-libs/libcap/files/1.10-python.patch3
-rw-r--r--sys-libs/libcap/files/digest-libcap-1.10-r52
-rw-r--r--sys-libs/libcap/files/libcap-1.10-python.patch123
-rw-r--r--sys-libs/libcap/files/libcap-1.10-r5-staticfix.patch49
4 files changed, 2 insertions, 175 deletions
diff --git a/sys-libs/libcap/files/1.10-python.patch b/sys-libs/libcap/files/1.10-python.patch
index f6c3517f68a7..6e87babc983e 100644
--- a/sys-libs/libcap/files/1.10-python.patch
+++ b/sys-libs/libcap/files/1.10-python.patch
@@ -37,13 +37,14 @@ diff -ur libcap-1.10.orig/libcap/Makefile libcap-1.10/libcap/Makefile
%.o: %.c $(INCLS)
$(CC) $(CFLAGS) -c $< -o $@
-@@ -82,10 +93,14 @@
+@@ -82,10 +93,15 @@
ln -sf $(MINLIBNAME) $(LIBDIR)/$(MAJLIBNAME)
ln -sf $(MAJLIBNAME) $(LIBDIR)/$(LIBNAME).so
-/sbin/ldconfig
+ifdef PYTHON
+ mkdir -p $(PYTHONMODDIR)
+ install -m 0644 $(PYTHONMODNAME) $(PYTHONMODDIR)/$(PYTHONMODNAME)
++ install -m 0644 libcap.py $(PYTHONMODDIR)/
+endif
clean:
diff --git a/sys-libs/libcap/files/digest-libcap-1.10-r5 b/sys-libs/libcap/files/digest-libcap-1.10-r5
deleted file mode 100644
index ec126de2271e..000000000000
--- a/sys-libs/libcap/files/digest-libcap-1.10-r5
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 4426a413128142cab89eb2e6f13d8571 libcap-1.10.tar.bz2 26686
-MD5 b867a0c1db9e8ff568415bbcd1fa65dc libcap_1.10-14.diff.gz 12928
diff --git a/sys-libs/libcap/files/libcap-1.10-python.patch b/sys-libs/libcap/files/libcap-1.10-python.patch
deleted file mode 100644
index f7866614e115..000000000000
--- a/sys-libs/libcap/files/libcap-1.10-python.patch
+++ /dev/null
@@ -1,123 +0,0 @@
-diff -Nur libcap-1.10/libcap/include/sys/capability.h libcap-1.10-python/libcap/include/sys/capability.h
---- libcap-1.10/libcap/include/sys/capability.h 1999-11-18 07:19:21.000000000 +0100
-+++ libcap-1.10-python/libcap/include/sys/capability.h 2002-07-26 12:46:56.000000000 +0200
-@@ -15,13 +15,25 @@
- extern "C" {
- #endif
-
-+#ifdef SWIG
-+%module libcap
-+#endif
-+
- /*
- * This file complements the kernel file by providing prototype
- * information for the user library.
- */
-
-+#ifdef SWIG
-+%{
-+#include <sys/types.h>
-+#include <linux/capability.h>
-+#include "libcap.h"
-+%}
-+#else
- #include <sys/types.h>
- #include <linux/capability.h>
-+#endif
-
- /*
- * POSIX capability types
-@@ -73,10 +85,12 @@
- int cap_clear(cap_t);
-
- /* libcap/cap_file.c */
-+#ifndef SWIG
- cap_t cap_get_fd(int);
- cap_t cap_get_file(const char *);
- int cap_set_fd(int, cap_t);
- int cap_set_file(const char *, cap_t);
-+#endif
-
- /* libcap/cap_proc.c */
- cap_t cap_get_proc(void);
-@@ -96,6 +110,7 @@
- * if the following _POSIX_SOURCE is _undefined_
- */
-
-+#ifndef SWIG
- #if !defined(_POSIX_SOURCE)
-
- extern int capset(cap_user_header_t header, cap_user_data_t data);
-@@ -105,6 +120,7 @@
- extern char const *_cap_names[];
-
- #endif /* !defined(_POSIX_SOURCE) */
-+#endif
-
- #ifdef __cplusplus
- }
-Binary files libcap-1.10/libcap/libcapmodule.so and libcap-1.10-python/libcap/libcapmodule.so differ
-Binary files libcap-1.10/libcap/libcap_wrap.o and libcap-1.10-python/libcap/libcap_wrap.o differ
-diff -Nur libcap-1.10/libcap/Makefile libcap-1.10-python/libcap/Makefile
---- libcap-1.10/libcap/Makefile 1999-04-18 00:16:31.000000000 +0200
-+++ libcap-1.10-python/libcap/Makefile 2002-07-26 14:07:48.000000000 +0200
-@@ -30,6 +30,7 @@
- # Library version
- #
- LIBNAME=libcap.so
-+PYTHONMODNAME=libcapmodule.so
- #
-
- FILES=cap_alloc cap_proc cap_extint cap_flag cap_text cap_sys
-@@ -42,7 +43,11 @@
- MAJLIBNAME=$(LIBNAME).$(VERSION)
- MINLIBNAME=$(MAJLIBNAME).$(MINOR)
-
-+ifdef PYTHON
-+all: $(MINLIBNAME) $(PYTHONMODNAME)
-+else
- all: $(MINLIBNAME)
-+endif
-
- _makenames: _makenames.c cap_names.sed
- $(CC) $(CFLAGS) $(LDFLAGS) $< -o $@
-@@ -60,6 +65,12 @@
- ln -sf $(MINLIBNAME) $(MAJLIBNAME)
- ln -sf $(MAJLIBNAME) $(LIBNAME)
-
-+libcap_wrap.c: include/sys/capability.h
-+ swig -python -o libcap_wrap.c include/sys/capability.h
-+
-+$(PYTHONMODNAME): $(OBJS) libcap_wrap.o
-+ $(LD) -x -shared -o $@ libcap_wrap.o $(OBJS)
-+
- %.o: %.c $(INCLS)
- $(CC) $(CFLAGS) -c $< -o $@
-
-@@ -71,10 +82,14 @@
- ln -sf $(MINLIBNAME) $(LIBDIR)/$(MAJLIBNAME)
- ln -sf $(MAJLIBNAME) $(LIBDIR)/$(LIBNAME)
- -/sbin/ldconfig
-+ifdef PYTHON
-+ mkdir -p $(PYTHONMODDIR)
-+ install -m 0644 $(PYTHONMODNAME) $(PYTHONMODDIR)/$(PYTHONMODNAME)
-+endif
-
- clean:
- $(LOCALCLEAN)
- rm -f $(OBJS) $(LIBNAME)*
-- rm -f cap_names.h cap_names.sed _makenames
-+ rm -f cap_names.h cap_names.sed _makenames libcap_wrap.c
- cd include/sys && $(LOCALCLEAN)
-
-diff -Nur libcap-1.10/Make.Rules libcap-1.10-python/Make.Rules
---- libcap-1.10/Make.Rules 1999-11-18 07:06:02.000000000 +0100
-+++ libcap-1.10-python/Make.Rules 2002-07-26 14:03:26.000000000 +0200
-@@ -33,6 +33,7 @@
- SBINDIR=$(FAKEROOT)$(exec_prefix)/sbin
- INCDIR=$(FAKEROOT)$(inc_prefix)/include
- LIBDIR=$(FAKEROOT)$(lib_prefix)/lib
-+PYTHONMODDIR=$(FAKEROOT)$(prefix)/lib/python/site-packages
-
- # common defines for libcap (suitable for 2.2.1+ Linux kernels)
- VERSION=1
diff --git a/sys-libs/libcap/files/libcap-1.10-r5-staticfix.patch b/sys-libs/libcap/files/libcap-1.10-r5-staticfix.patch
deleted file mode 100644
index ce3445a45ae0..000000000000
--- a/sys-libs/libcap/files/libcap-1.10-r5-staticfix.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -Nur libcap-1.10-14/libcap/Makefile libcap-1.10-14.static/libcap/Makefile
---- libcap-1.10-14/libcap/Makefile 2004-09-16 02:45:13.000000000 +0200
-+++ libcap-1.10-14.static/libcap/Makefile 2004-09-16 02:48:30.000000000 +0200
-@@ -33,6 +33,7 @@
- # Library version
- #
- LIBNAME=libcap
-+STATLIBNAME=$(LIBNAME).a
- #
-
- FILES=cap_alloc cap_proc cap_extint cap_flag cap_text cap_sys
-@@ -46,7 +47,7 @@
- MAJLIBNAME=$(LIBNAME).so.$(VERSION)
- MINLIBNAME=$(MAJLIBNAME).$(MINOR)
-
--all: $(MINLIBNAME) $(LIBNAME).a
-+all: $(MINLIBNAME) $(STATLIBNAME)
-
- _makenames: _makenames.c cap_names.sed
- $(CC) $(CFLAGS) $(LDFLAGS) $< -o $@
-@@ -58,8 +59,8 @@
- @echo "=> making cap_names.c from <sys/capability.h>"
- @sed -ne '/^#define[ \t]CAP[_A-Z]\+[ \t]\+[0-9]\+/{s/^#define \([^ \t]*\)[ \t]*\([^ \t]*\)/ \{ \2, \"\1\" \},/;y/ABCDEFGHIJKLMNOPQRSTUVWXYZ/abcdefghijklmnopqrstuvwxyz/;p;}' < include/sys/capability.h | fgrep -v 0x > cap_names.sed # @sed -ne '/^#define[ \t]CAP[_A-Z]\+[ \t]\+[0-9]\+/{s/^#define CAP_\([^ \t]*\)[ \t]*\([^ \t]*\)/ \{ \2, \"\1\" \},/;y/ABCDEFGHIJKLMNOPQRSTUVWXYZ/abcdefghijklmnopqrstuvwxyz/;p;}' < /usr/include/linux/capability.h | fgrep -v 0x > cap_names.sed
-
--$(LIBNAME).a: $(OBJS)
-- ar cruv $(LIBNAME).a $(OBJS)
-+$(STATLIBNAME): $(OBJS)
-+ ar csruv $(STATLIBNAME) $(OBJS)
-
- $(MINLIBNAME): $(LOBJS)
- $(CC) -shared -fPIC -Wl,-soname,$(MAJLIBNAME) -o $@ $(LOBJS)
-@@ -77,7 +78,7 @@
- mkdir -p -m 0755 $(INCDIR)/sys
- install -m 0644 include/sys/capability.h $(INCDIR)/sys
- mkdir -p -m 0755 $(LIBDIR)
-- install -m 0644 $(LIBNAME).a $(LIBDIR)
-+ install -m 0644 $(STATLIBNAME) $(LIBDIR)
- install -m 0644 $(MINLIBNAME) $(LIBDIR)/$(MINLIBNAME)
- ln -sf $(MINLIBNAME) $(LIBDIR)/$(MAJLIBNAME)
- ln -sf $(MAJLIBNAME) $(LIBDIR)/$(LIBNAME).so
-@@ -85,7 +86,7 @@
-
- clean:
- $(LOCALCLEAN)
-- rm -f $(OBJS) $(LOBJS) $(LIBNAME).a $(LIBNAME).so*
-+ rm -f $(OBJS) $(LOBJS) $(STATLIBNAME) $(LIBNAME).so*
- rm -f cap_names.h cap_names.sed _makenames
- cd include/sys && $(LOCALCLEAN)
-