summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-06-01 01:45:23 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-06-01 01:45:23 +0000
commit658781ce864bec5ac39d46250ec15b0fbf4bc950 (patch)
treefede14254f0674be4d596166d6c24a8608ecd6b4 /sys-libs/libcap
parentAdd kdevelop in the mask, too. (diff)
downloadgentoo-2-658781ce864bec5ac39d46250ec15b0fbf4bc950.tar.gz
gentoo-2-658781ce864bec5ac39d46250ec15b0fbf4bc950.tar.bz2
gentoo-2-658781ce864bec5ac39d46250ec15b0fbf4bc950.zip
Fix QA error with pre-stripped binaries being installed, and clean up the horrible mess in src_install.
(Portage version: 2.1_rc3-r3)
Diffstat (limited to 'sys-libs/libcap')
-rw-r--r--sys-libs/libcap/ChangeLog10
-rw-r--r--sys-libs/libcap/files/digest-libcap-1.10-r62
-rw-r--r--sys-libs/libcap/libcap-1.10-r6.ebuild74
3 files changed, 84 insertions, 2 deletions
diff --git a/sys-libs/libcap/ChangeLog b/sys-libs/libcap/ChangeLog
index c6d5d47ea21f..70df109b076f 100644
--- a/sys-libs/libcap/ChangeLog
+++ b/sys-libs/libcap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libcap
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.33 2005/02/09 23:06:17 vapier Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.34 2006/06/01 01:45:23 robbat2 Exp $
+
+*libcap-1.10-r6 (01 Jun 2006)
+
+ 01 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> +libcap-1.10-r6.ebuild:
+ Fix QA error with pre-stripped binaries being installed, and clean up the
+ horrible mess in src_install.
*libcap-1.10-r5 (09 Feb 2005)
diff --git a/sys-libs/libcap/files/digest-libcap-1.10-r6 b/sys-libs/libcap/files/digest-libcap-1.10-r6
new file mode 100644
index 000000000000..ec126de2271e
--- /dev/null
+++ b/sys-libs/libcap/files/digest-libcap-1.10-r6
@@ -0,0 +1,2 @@
+MD5 4426a413128142cab89eb2e6f13d8571 libcap-1.10.tar.bz2 26686
+MD5 b867a0c1db9e8ff568415bbcd1fa65dc libcap_1.10-14.diff.gz 12928
diff --git a/sys-libs/libcap/libcap-1.10-r6.ebuild b/sys-libs/libcap/libcap-1.10-r6.ebuild
new file mode 100644
index 000000000000..8c51f382951e
--- /dev/null
+++ b/sys-libs/libcap/libcap-1.10-r6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10-r6.ebuild,v 1.1 2006/06/01 01:45:23 robbat2 Exp $
+
+inherit flag-o-matic eutils
+
+DEB_PVER=14
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/libs/security/linux-privs/"
+SRC_URI="http://www.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.4/${P}.tar.bz2
+ mirror://debian/pool/main/libc/libcap/libcap_${PV}-${DEB_PVER}.diff.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nocxx python static"
+
+#patch is in recent 2.2 kernels so it works there
+DEPEND="virtual/os-headers
+ !nocxx? ( python? ( >=virtual/python-2.2.1
+ >=dev-lang/swig-1.3.10 ) )"
+RDEPEND="!nocxx? ( python? ( >=virtual/python-2.2.1 ) )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${S}
+ epatch ${DISTDIR}/libcap_${PV}-${DEB_PVER}.diff.gz
+ epatch ${FILESDIR}/${PV}-python.patch
+ epatch ${FILESDIR}/libcap-1.10-r4-staticfix.diff
+ sed -i.orig \
+ -e 's|WARNINGS=-ansi|WARNINGS=|' \
+ -e 's|^LDFLAGS=-s.*|LDFLAGS = |' \
+ -e '/^COPTFLAGS/d' \
+ Make.Rules
+}
+
+src_compile() {
+ local myflags=""
+ if use static; then
+ append-flags -static
+ append-ldflags -static
+ fi
+ if ! use nocxx && use python ; then
+ local PYTHONVER="`python -V 2>&1 | sed 's/^Python //'|sed 's/\([0-9]*\.[0-9]*\).*/\1/'`"
+ myflags="${myflags} PYTHON=1 PYTHONMODDIR=/usr/$(get_libdir)/python${PYTHONVER}/site-packages"
+ append-flags -I/usr/include/python${PYTHONVER}
+ fi
+
+ emake COPTFLAG="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${myflags} || die
+}
+
+src_install() {
+ into /
+ dosbin progs/sucap progs/execcap progs/setpcaps progs/getpcaps
+ dolib.so libcap/libcap.so.1.10
+ gen_usr_ldscript libcap.so.1.10
+ into /usr
+ dolib.a libcap/libcap.a
+
+ insinto /usr/include/sys
+ doins libcap/include/sys/capability.h
+
+ dodoc CHANGELOG README pgp.keys.asc doc/capability.notes capfaq-0.2.txt
+ doman doc/*.3
+
+ if use python; then
+ local PYTHONVER="`python -V 2>&1 | sed 's/^Python //'|sed 's/\([0-9]*\.[0-9]*\).*/\1/'`"
+ local PYTHONMODDIR=/usr/$(get_libdir)/python${PYTHONVER}/site-packages
+ exeinto ${PYTHONMODDIR}
+ doexe libcap/libcapmodule.so
+ insinto ${PYTHONMODDIR}
+ doins libcap/libcap.py
+ fi
+}