summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2007-11-18 05:44:13 +0000
committerDavid Shakaryan <omp@gentoo.org>2007-11-18 05:44:13 +0000
commit7b125dbd6d0e5a59cdedc56c0728e040da1c2112 (patch)
treef50e0b893681742b0cce9ca6c3c9b778b9bc5203 /sys-libs/libixp/libixp-0.4.ebuild
parentfixed lib32 dirname bug (diff)
downloadgentoo-2-7b125dbd6d0e5a59cdedc56c0728e040da1c2112.tar.gz
gentoo-2-7b125dbd6d0e5a59cdedc56c0728e040da1c2112.tar.bz2
gentoo-2-7b125dbd6d0e5a59cdedc56c0728e040da1c2112.zip
Version bump.
(Portage version: 2.1.3.16)
Diffstat (limited to 'sys-libs/libixp/libixp-0.4.ebuild')
-rw-r--r--sys-libs/libixp/libixp-0.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-libs/libixp/libixp-0.4.ebuild b/sys-libs/libixp/libixp-0.4.ebuild
new file mode 100644
index 000000000000..600037fb2000
--- /dev/null
+++ b/sys-libs/libixp/libixp-0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libixp/libixp-0.4.ebuild,v 1.1 2007/11/18 05:44:12 omp Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Standalone client/server 9P library"
+HOMEPAGE="http://libs.suckless.org/"
+SRC_URI="http://libs.suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "/^PREFIX/s|=.*|= ${D}/usr|" \
+ -e "/^ETC/s|=.*|= ${D}/etc|" \
+ -e "/^CFLAGS/s|=|+=|" \
+ -e "/^LDFLAGS/s|=|+=|" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+}