summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2003-10-03 16:39:49 +0000
committerChris PeBenito <pebenito@gentoo.org>2003-10-03 16:39:49 +0000
commit47baad590acbba464dd22ad9d5f21dfb7097e615 (patch)
tree2654ba0f22904af1e0ebea36c2598f97f2e3bec3 /sys-libs/libselinux
parentFixed Makefile errors about .d files (diff)
downloadgentoo-2-47baad590acbba464dd22ad9d5f21dfb7097e615.tar.gz
gentoo-2-47baad590acbba464dd22ad9d5f21dfb7097e615.tar.bz2
gentoo-2-47baad590acbba464dd22ad9d5f21dfb7097e615.zip
new upstream version
Diffstat (limited to 'sys-libs/libselinux')
-rw-r--r--sys-libs/libselinux/ChangeLog8
-rw-r--r--sys-libs/libselinux/Manifest5
-rw-r--r--sys-libs/libselinux/files/digest-libselinux-1.21
-rw-r--r--sys-libs/libselinux/files/libselinux-1.2-const.diff131
-rw-r--r--sys-libs/libselinux/libselinux-1.2.ebuild37
5 files changed, 180 insertions, 2 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index 61334b4f7f07..88795cfd1178 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libselinux
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.8 2003/09/22 12:15:28 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.9 2003/10/03 16:39:46 pebenito Exp $
+
+*libselinux-1.2 (03 Oct 2003)
+
+ 03 Oct 2003; Chris PeBenito <pebenito@gentoo.org> libselinux-1.2.ebuild,
+ files/libselinux-1.2-const.diff:
+ New upstream version.
22 Sep 2003; <paul@gentoo.org> metadata.xml:
Fix metadata.xml
diff --git a/sys-libs/libselinux/Manifest b/sys-libs/libselinux/Manifest
index 6144c6af3964..b36ebc566c46 100644
--- a/sys-libs/libselinux/Manifest
+++ b/sys-libs/libselinux/Manifest
@@ -1,6 +1,9 @@
+MD5 93ae22ff3961818903bb4da511f15cc3 libselinux-1.2.ebuild 843
MD5 652c5e8a0a081bf4317359f04f65a603 metadata.xml 537
-MD5 789f73dc517727d572f6203340b58e61 ChangeLog 1562
+MD5 a970390dd067f3f2a60f4a7fc79f9fc6 ChangeLog 1730
MD5 63cfcf5b8cfd21a5caba0527082f513a libselinux-1.1-r1.ebuild 826
+MD5 ed35b412c4b957fe6121ea3d8d0a01ac files/digest-libselinux-1.2 62
+MD5 740bc8d55ebd8f695dd659ef63aef072 files/libselinux-1.2-const.diff 5020
MD5 ee2480e816c5fb6bdc78e94cf0a4d1f5 files/libselinux-1.1-gentoo.diff 1242
MD5 4276fc22ccd5de38cc3ce45f83343f68 files/digest-libselinux-1.1-r1 62
MD5 9fbf39a4f64f805072e80f9a38d0c56f files/libselinux-1.1-linkfix.diff 430
diff --git a/sys-libs/libselinux/files/digest-libselinux-1.2 b/sys-libs/libselinux/files/digest-libselinux-1.2
new file mode 100644
index 000000000000..32663d6490ab
--- /dev/null
+++ b/sys-libs/libselinux/files/digest-libselinux-1.2
@@ -0,0 +1 @@
+MD5 f8a568affa7da710ca3218f034daf583 libselinux-1.2.tgz 22880
diff --git a/sys-libs/libselinux/files/libselinux-1.2-const.diff b/sys-libs/libselinux/files/libselinux-1.2-const.diff
new file mode 100644
index 000000000000..344807533ad1
--- /dev/null
+++ b/sys-libs/libselinux/files/libselinux-1.2-const.diff
@@ -0,0 +1,131 @@
+--- include/selinux/get_context_list.h
++++ include/selinux/get_context_list.h 2003/10/03 06:17:18
+@@ -13,7 +13,7 @@
+ customizable preferences. Returns number of entries in *conary.
+ If 'fromcon' is NULL, defaults to current context.
+ Caller must free via freeconary. */
+-extern int get_ordered_context_list(char *user,
++extern int get_ordered_context_list(const char *user,
+ security_context_t fromcon,
+ security_context_t **list);
+
+@@ -24,7 +24,7 @@
+ If 'fromcon' is NULL, defaults to current context.
+ Returns 0 on success or -1 otherwise.
+ Caller must free via freecon. */
+-extern int get_default_context(char* user,
++extern int get_default_context(const char* user,
+ security_context_t fromcon,
+ security_context_t *newcon);
+
+@@ -39,6 +39,7 @@
+ if a list of authorized contexts could not be obtained.
+ Caller must free via freecon.
+ Returns 0 on success or -1 otherwise. */
+-extern int manual_user_enter_context(char *user, security_context_t *newcon);
++extern int manual_user_enter_context(const char *user,
++ security_context_t *newcon);
+
+ #endif
+--- include/selinux/selinux.h
++++ include/selinux/selinux.h 2003/10/03 06:19:39
+@@ -98,7 +98,7 @@
+ /* Compute the set of reachable user contexts and set *con to refer to
+ the NULL-terminated array of contexts. Caller must free via freeconary. */
+ extern int security_compute_user(security_context_t scon,
+- char *username,
++ const char *username,
+ security_context_t **con);
+
+ /* Load a policy configuration. */
+--- src/compute_user.c
++++ src/compute_user.c 2003/10/03 06:19:00
+@@ -10,7 +10,7 @@
+ #include "policy.h"
+
+ int security_compute_user(security_context_t scon,
+- char *user,
++ const char *user,
+ security_context_t **con)
+ {
+ char **ary;
+--- src/get_context_list.c
++++ src/get_context_list.c 2003/10/03 06:17:18
+@@ -10,7 +10,7 @@
+ #define USERPRIORITY 1
+ #define SYSTEMPRIORITY 2
+
+-int get_default_context(char* user,
++int get_default_context(const char* user,
+ security_context_t fromcon,
+ security_context_t *newcon)
+ {
+@@ -112,7 +112,7 @@
+ pri_list. The number of elements stored in pri_list
+ is returned.
+ */
+-static int list_from_string (char *instr, char *user,
++static int list_from_string (char *instr, const char *user,
+ security_context_t *pri_list,
+ int pri_length)
+ {
+@@ -170,7 +170,7 @@
+ in pri_list or -1 on error.
+ */
+ static int get_context_list (FILE *infile, security_context_t fromcon,
+- char *user, security_context_t *pri_list,
++ const char *user, security_context_t *pri_list,
+ int pri_length)
+ {
+ int ret_val = 0; /* Used for return values */
+@@ -197,7 +197,7 @@
+ system configuration file. The number of contexts placed
+ in pri_list is returned.
+ */
+-static int get_config_priority (security_context_t fromcon, char *user,
++static int get_config_priority (security_context_t fromcon, const char *user,
+ security_context_t *pri_list, int pri_length, int which,
+ int default_user_flag)
+ {
+@@ -346,7 +346,7 @@
+ return ret_val;
+ }
+
+-int get_ordered_context_list (char *user,
++int get_ordered_context_list (const char *user,
+ security_context_t fromcon,
+ security_context_t **list)
+ {
+@@ -376,7 +376,7 @@
+ freefrom = 1;
+ }
+
+- rc = security_compute_user(fromcon, (char*)user, &init_list);
++ rc = security_compute_user(fromcon, user, &init_list);
+ if (rc < 0) {
+ /* Retry with the default SELinux user identity. */
+ rc = security_compute_user(fromcon,
+--- src/query_user_context.c
++++ src/query_user_context.c 2003/10/03 06:17:18
+@@ -109,7 +109,7 @@
+ * context chosen by the user into usercon. Returns 0
+ * on success.
+ */
+-int manual_user_enter_context (char *user, security_context_t *newcon)
++int manual_user_enter_context (const char *user, security_context_t *newcon)
+ {
+ char response[10]; /* Used to get yes or no answers from user */
+ char role[100]; /* The role requested by the user */
+@@ -120,9 +120,9 @@
+ int levellen = 100;
+ int mls_enabled = 0;
+
+- context_t new_context; /* The new context chosen by the user */
+- char *user_context; /* String value of the user's context */
+- int done = 0; /* true if a valid sid has been obtained */
++ context_t new_context; /* The new context chosen by the user */
++ char *user_context = NULL; /* String value of the user's context */
++ int done = 0; /* true if a valid sid has been obtained */
+
+ /* Initialize the context. How this is done depends on whether
+ or not MLS is enabled */
diff --git a/sys-libs/libselinux/libselinux-1.2.ebuild b/sys-libs/libselinux/libselinux-1.2.ebuild
new file mode 100644
index 000000000000..b0f208bcf47f
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-1.2.ebuild,v 1.1 2003/10/03 16:39:46 pebenito Exp $
+
+IUSE=""
+
+DESCRIPTION="SELinux library (libselinux)"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="sys-apps/attr"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/libselinux-1.1-gentoo.diff
+ epatch ${FILESDIR}/libselinux-1.2-const.diff
+}
+
+src_compile() {
+ cd ${S}/src
+ emake EXTRA_CFLAGS="${CFLAGS}" || die "libselinux compile failed."
+
+ cd ${S}/utils
+ emake EXTRA_CFLAGS="${CFLAGS}" || die "Utilities compile failed."
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+}
+