summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2012-03-31 11:03:18 +0000
committerSven Vermeulen <swift@gentoo.org>2012-03-31 11:03:18 +0000
commitd15030640c2508e1b55baf34f34982caae010dcc (patch)
tree203260b4a694710b4662a0d4219d8adab27080d4 /sys-libs/libsepol/libsepol-2.1.4-r1.ebuild
parentUpdating SELinux userspace utilities to support pending 2.20120215 policies (diff)
downloadgentoo-2-d15030640c2508e1b55baf34f34982caae010dcc.tar.gz
gentoo-2-d15030640c2508e1b55baf34f34982caae010dcc.tar.bz2
gentoo-2-d15030640c2508e1b55baf34f34982caae010dcc.zip
Updating SELinux userspace utilities to support pending 2.20120215 policies
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libsepol/libsepol-2.1.4-r1.ebuild')
-rw-r--r--sys-libs/libsepol/libsepol-2.1.4-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-libs/libsepol/libsepol-2.1.4-r1.ebuild b/sys-libs/libsepol/libsepol-2.1.4-r1.ebuild
new file mode 100644
index 000000000000..2fd091887b0c
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.1.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.1.4-r1.ebuild,v 1.1 2012/03/31 11:03:18 swift Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20120216/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+ epatch "${FILESDIR}/libsepol-2.1.4-fix_role_fix_callback.patch"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}